Subject: Re: [Isis-wg] WGLC draft-ietf-isis-te-metric-extensions

From: János Farkas <[email-masked]>
Date: Sun, 9 Nov 2014 20:47:23 +0100

Hi,

I suggest to allow finer delay resolution than microseconds in the delay 
sub-TLVs:
-    Unidirectional Link Delay Sub-TLV
-    Min/Max Unidirectional Link Delay Sub-TLV
-    Unidirectional Delay Variation Sub-TLV

Currently the resolution is hardcoded to be microseconds in these 
sub-TLVs. However, there are time sensitive networks where the scale of 
delay values is nanoseconds, see e.g. 
http://datatracker.ietf.org/wg/detnet/charter. Supporting nanoseconds 
resolution would allow the use of these sub-TLVs in these time sensitive 
networks as well.

There would be various ways to provide nanoseconds delay resolution by 
these sub-TLVs. For instance, a 1-bit flag could indicate whether the 
delay value is in microseconds or nanoseconds.

Best regards,
Janos

On 10/31/2014 11:00, Hannes Gredler wrote:
> hi folks,
>
> http://datatracker.ietf.org/doc/draft-ietf-isis-te-metric-extensions/
> has gotten enough soak time and hence we're issuing
> a 3-week WGLC until Nov 21st 2014.
>
> please provide feedback, concerns, suggestion etc. up until
> the door closes.
>
> thanks,
>
> Hannes & Chris
>
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>
>

---

From: Paul Unbehagen <[email-masked]>
Date: Tue, 11 Nov 2014 04:31:22 -0700

I agree on the use case for the flag to trigger a finer resolution to nanoseconds. If the network diameter is small, microseconds will not work very well. 

- Paul

> On Nov 9, 2014, at 12:47 PM, János Farkas <[email-masked]> wrote:
> 
> Hi,
> 
> I suggest to allow finer delay resolution than microseconds in the delay sub-TLVs:
> Currently the resolution is hardcoded to be microseconds in these sub-TLVs. However, there are time sensitive networks where the scale of delay values is nanoseconds, see e.g. http://datatracker.ietf.org/wg/detnet/charter. Supporting nanoseconds resolution would allow the use of these sub-TLVs in these time sensitive networks as well.
> 
> There would be various ways to provide nanoseconds delay resolution by these sub-TLVs. For instance, a 1-bit flag could indicate whether the delay value is in microseconds or nanoseconds.
> 
> Best regards,
> Janos
> 
>