Subject: [Isis-wg] Fwd: AD review of draft-ietf-isis-extended-sequence-no-tlv-04

From: Alia Atlas <[email-masked]>
Date: Wed, 18 Mar 2015 17:32:56 -0400

As is customary, I have done an AD review
of draft-ietf-isis-extended-sequence-no-tlv-04.
Thanks for the work on making our routing protocols more secure.  My
comments are below.  I have requested an IETF Last Call to go through April
8.

1) Sec 1: I can't even parse "At the meantime the SDN-enabled networks even
though put more power to Internet applications and also make network
management easier,"

2)  It would be nice to clarify the sequencing for fully enabling and
disabling this extension on a link.

Thanks,
Alia

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 20 Mar 2015 22:09:32 +0000

Hi Alia,

Thanks for your review comments.

In-line [Uma]:

--
Uma C.

From: Isis-wg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, March 18, 2015 2:33 PM
To: [email-masked]
Subject: [Isis-wg] Fwd: AD review of draft-ietf-isis-extended-sequence-no-tlv-04

As is customary, I have done an AD review of draft-ietf-isis-extended-sequence-no-tlv-04.
Thanks for the work on making our routing protocols more secure.

[Uma]: Thank you.
My comments are below.  I have requested an IETF Last Call to go through April 8.

1) Sec 1: I can't even parse "At the meantime the SDN-enabled networks even though put more power to Internet applications and also make network management easier,"
[Uma]:

Current text says this -
   “At the meantime the
   SDN-enabled networks even though put more power to Internet
   applications and also make network management easier, it does raise
   the security requirement of network routing infrastructure to another
   level.”
Shall change this to –
   “At the meantime in spite of the claimed provisioning and management advantage, the
   SDN-enabled networks do raise
   the security requirement of network routing infrastructure to another
   level.”

2)  It would be nice to clarify the sequencing for fully enabling and disabling this extension on a link.

[Uma]:  Though it’s more of an operational aspect, this is covered in Section 5.1 2nd paragraph.
               However it  captures the sequencing to enabling  the same on a link.
               Do you want us add disabling sequence too ?? Will it be good idea to move this part to Appendix-B,
              “11.1.  Operational/Implementation consideration”?

Please suggest.

Thanks,
Alia