Subject: [Isis-wg] WG Adoption Call for draft-farkas-isis-pcr

From: Philippe Klein <[email-masked]>
Date: Tue, 28 Apr 2015 10:01:21 +0000

Supported

Philippe Klein, PhD |Technical Director, Broadband Technology Group
Broadcom Corporation | Golan House, P.O.Box 273, Airport City, 70100 Israel
(M) +972 54 313 4500 | [email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>

-----Original Message-----
From: Isis-wg [mailto:isis-wg-bounces at ietf.org] On Behalf Of Christian Hopps
Sent: Tuesday, April 14, 2015 12:50 AM
To: isis-wg at ietf.org list
Subject: [Isis-wg] WG Adoption Call for draft-farkas-isis-pcr

Hi Folks,

The authors have requested the IS-IS WG adopt draft-farkas-isis-pcr as a working group document.

Please indicate support or no-support for taking on this work until April 28th, 2015.

---

From: Huaimo Chen <[email-masked]>
Date: Wed, 29 Apr 2015 21:23:56 +0000

Hi Everyone,

Some service interruptions may occur while splitting a network running ISIS into more areas.

   During IETF 92 in Dallas, someone said that this issue could be resolved in some ways in ISIS when I presented ISIS TTZ (draft-chen-isis-ttz-02) which solves this issue. But this seems not always true. That is that "there may be service interruptions while splitting the network into more ISIS areas."

    In ISIS, when splitting a part of level 2 network area into a new level 1 area, the routing in the new area will be changed. A change for a route to a destination will cause service interruptions if there are services going through that route. Before splitting, every router in the level 2 network area has the same topology and uses this topology to compute the route (shortest path) to a destination. After splitting, every router in the new area (except for the edge routers) does not have the original level 2 network topology, it just uses the topology of its level 1 area to compute a shortest path to each of the edge routers of the area and selects an edge router that is closest to it. For every destination outside of the area, it just uses the path (or next hop) to that edge router.  For a destination, if this path (or next hop) is different from the original one, then there is a route change.

Best Regards,
Huaimo