Subject: [Isis-wg] draft-ginsberg-isis-prefix-attributes & draft-ietf-isis-segment-routing-extensions

From: <[email-masked]>
Date: Mon, 20 Apr 2015 14:58:03 +0000

Hi,

Introducing the IPv4/IPv6 extended reachability attribute flags, we are introducing some redundancy with some informations contained in Prefix-SID SubTLV, especially the N-Flag representing that the prefix belongs to the node itself.

I'm not sure this is a good idea to keep both flags or if we do, we need to define the relationship between them (are they independent or not ...)

N-Flag was introduced in Prefix SID SubTLV because the information was not existing at this time. 
Now we defined new attributes for the prefix containing this information, so the PrefixSID information is redundant and not useful anymore.

For sure, we need to take care about backward compatibility as some SR codes already used N-Flag in Prefix SID for FRR.

Thoughts ?

Best Regards,

Stephane

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 20 Apr 2015 15:04:56 +0000

Stephane -

We have stated publicly that the plan is to deprecate the N flag in the prefix-SID sub-TLV. The only issue is timing as we have early deployments of SR. So we need to:

1)Get prefix-attributes as a WG document
2)Get early allocation of codepoints for prefix-attributes so folks can implement it
3)Allow a transition period for early SR deployments to add prefix-attributes support
4)Deprecate the redundant flag in SR

During the transition implementations will send both flags and accept either one.

We won't reuse the flag in SR until we are certain there are no legacy deployments. (A long time...)

   Les

> -----Original Message-----
> From: Isis-wg [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, April 20, 2015 7:58 AM
> To: [email-masked]
> Subject: [Isis-wg] draft-ginsberg-isis-prefix-attributes & draft-ietf-isis-
> segment-routing-extensions
> 
> Hi,
> 
> Introducing the IPv4/IPv6 extended reachability attribute flags, we are
> introducing some redundancy with some informations contained in Prefix-
> SID SubTLV, especially the N-Flag representing that the prefix belongs to the
> node itself.
> 
> I'm not sure this is a good idea to keep both flags or if we do, we need to
> define the relationship between them (are they independent or not ...)
> 
> Now we defined new attributes for the prefix containing this information, so
> the PrefixSID information is redundant and not useful anymore.
> 
> For sure, we need to take care about backward compatibility as some SR
> codes already used N-Flag in Prefix SID for FRR.
> 
> Thoughts ?
> 
> 
> Best Regards,
> 
> Stephane
> 
> 
> 
> __________________________________________________________
> __________________________________________________________
> _____
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites
> ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez
> le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: <[email-masked]>
Date: Mon, 20 Apr 2015 15:15:09 +0000

> We have stated publicly that the plan is to deprecate the N flag in the prefix-SID sub-TLV

Great, I missed this ... .

Thanks for the info.

-----Original Message-----
From: Les Ginsberg (ginsberg) [mailto:[email-masked]] 
Sent: Monday, April 20, 2015 17:05
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: RE: draft-ginsberg-isis-prefix-attributes & draft-ietf-isis-segment-routing-extensions

Stephane -

1)Get prefix-attributes as a WG document 2)Get early allocation of codepoints for prefix-attributes so folks can implement it 3)Allow a transition period for early SR deployments to add prefix-attributes support 4)Deprecate the redundant flag in SR

   Les

> Subject: [Isis-wg] draft-ginsberg-isis-prefix-attributes & 
> draft-ietf-isis- segment-routing-extensions
> 
> Hi,
> 
> Introducing the IPv4/IPv6 extended reachability attribute flags, we 
> are introducing some redundancy with some informations contained in 
> Prefix- SID SubTLV, especially the N-Flag representing that the prefix 
> belongs to the node itself.
> 
> I'm not sure this is a good idea to keep both flags or if we do, we 
> need to define the relationship between them (are they independent or 
> not ...)
> 
> Now we defined new attributes for the prefix containing this 
> information, so the PrefixSID information is redundant and not useful anymore.
> 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.