Subject: [Isis-wg] I-D Action: draft-ietf-isis-te-metric-extensions-05.txt

From: [email-masked]
Date: Wed, 15 Apr 2015 01:52:59 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IS-IS for IP Internets Working Group of the IETF.

        Title           : IS-IS Traffic Engineering (TE) Metric Extensions
        Authors         : Stefano Previdi
                          Spencer Giacalone
                          Dave Ward
                          John Drake
                          Alia Atlas
                          Clarence Filsfils
                          Qin Wu
	Filename        : draft-ietf-isis-te-metric-extensions-05.txt
	Pages           : 17
	Date            : 2015-04-15

Abstract:
   In certain networks, such as, but not limited to, financial
   information networks (e.g. stock market data providers), network
   performance criteria (e.g. latency) are becoming as critical to data
   path selection as other metrics.

   This document describes extensions to IS-IS Traffic Engineering
   Extensions (RFC5305) such that network performance information can be
   distributed and collected in a scalable fashion.  The information
   distributed using ISIS TE Metric Extensions can then be used to make
   path selection decisions based on network performance.

   Note that this document only covers the mechanisms with which network
   performance information is distributed.  The mechanisms for measuring
   network performance or acting on that information, once distributed,
   are outside the scope of this document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-isis-te-metric-extensions/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-isis-te-metric-extensions-05

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-isis-te-metric-extensions-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 15 Apr 2015 08:56:55 +0000

Hi,

the ISIS TE Metric Extensions draft has been updated in order to be aligned with the OSPF version.

Thanks.

s.

On Apr 15, 2015, at 10:52 AM, <[email-masked]> wrote:

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 15 Apr 2015 18:34:45 +0000

Dear Authors,

To help early implementations of this draft ,
it would be great if early IANA code points are assigned to the TLVs in  this document (not sure how far it's from being published). At least some suggested values should be documented. Thx!

--
Uma C.

-----Original Message-----
From: Isis-wg [mailto:[email-masked]] On Behalf Of Stefano Previdi (sprevidi)
Sent: Wednesday, April 15, 2015 1:57 AM
To: [email-masked]
Subject: Re: [Isis-wg] I-D Action: draft-ietf-isis-te-metric-extensions-05.txt

Hi,

Thanks.

s.

On Apr 15, 2015, at 10:52 AM, <[email-masked]> wrote:

> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 15 Apr 2015 18:59:25 +0000

> it would be great if early IANA code points are assigned to the TLVs in  this document (not sure how far it's from being published). At least some suggested values should be documented. Thx!

all (suggested) code-points are documented in the draft and we just started the early allocation process.

Thanks.
s.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 15 Apr 2015 19:32:55 +0000

Hi Uma,

sorry, I thought you were referring to sr-extensions while you pointed to te-metric-extensions.

s.

On Apr 15, 2015, at 9:19 PM, Uma Chunduri <[email-masked]> wrote:
> Hi Stefano,
> 
>> all (suggested) code-points are documented in the draft
> 
> I checked the diff and couldn't see the same. Could  you plz check  if you uploaded the right version then?
> 
> --
> Uma C.
> 
> 
> From: Stefano Previdi (sprevidi) [mailto:[email-masked]] 
> Sent: Wednesday, April 15, 2015 11:59 AM
> To: Uma Chunduri
> Cc: [email-masked]
>> To help early implementations of this draft , it would be great if 
>> early IANA code points are assigned to the TLVs in  this document (not sure how far it's from being published). At least some suggested values should be documented. Thx!
> 
> 
>> Subject: Re: [Isis-wg] I-D Action: 
>> draft-ietf-isis-te-metric-extensions-05.txt
>> 
>> Hi,
>> 
>>> Note that this document only covers the mechanisms with which 
>>> network  performance information is distributed.  The mechanisms for 
>>> measuring  network performance or acting on that information, once 
>>> distributed,  are outside the scope of this document.
>>> 
>>> 
>>> 
>>> http://www.ietf.org/rfcdiff?url2=draft-ietf-isis-te-metric-extensions
>>> -
>>> 05
>>> 
>>>