Subject: Re: [Isis-wg] draft-previdi-isis-segment-routing-extensions-05

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 22 Sep 2015 11:08:13 +0000

Hi Anil,
Since the setting of the flag being set indicates that the SID is local, L-Flag seems like a more appropriate moniker for this IS-IS protocol flag.  Calling it the G flag will only result in confusion.
Thanks,
Acee

From: Isis-wg <[email-masked]<mailto:[email-masked]>> on behalf of "Anil Kumar S N (VRP Network BL)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 22, 2015 at 2:43 AM
To: "Anil Kumar S N (VRP Network BL)" <[email-masked]<mailto:[email-masked]>>, "Stefano Previdi (sprevidi)" <[email-masked]<mailto:[email-masked]>>, "Clarence Filsfils (cfilsfil)" <[email-masked]<mailto:[email-masked]>>, "Ahmed Bashandy (bashandy)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Stephane Litkowski <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Isis-wg] draft-previdi-isis-segment-routing-extensions-05

Hi Authors,

In Section : 2.1.  Prefix Segment Identifier (Prefix-SID Sub-TLV), L-Flag represent IGP segment is local or global (Suggest to change to G so that it will be consistent with Segment Routing Architecture draft) similar to that can we have A-Flag to indicate Anycast SID.

L-Flag: Local Flag.  If set, then the value/index carried by
         the Prefix-SID has local significance.  By default the flag is
         UNSET.

https://tools.ietf.org/html/draft-filsfils-rtgwg-segment-routing-00#page-17
3.2<https://tools.ietf.org/html/draft-filsfils-rtgwg-segment-routing-00#section-3.2>.  IGP Segment Terminology
3.2.1<https://tools.ietf.org/html/draft-filsfils-rtgwg-segment-routing-00#section-3.2.1>.  IGP Segment, IGP SID
   The terms "IGP Segment" and "IGP SID" are the generic names for a
   segment attached to a piece of information advertised by a link-state
   IGP, e.g. an IGP prefix or an IGP adjacency.

   The IGP signaling extension to advertise an IGP segment includes the
   G-Flag indicating whether the IGP segment is global or local.
                                       IGP-SID
                                       +--+--+
                                      /   |   \
                             Prefix-SID   x   Adj-SID
                             +----+---+
                            /     |    \
                      Node-SID    y   Anycast-SID

                       Figure 7: IGP SID Terminology

   The IGP Segment terminology is introduced to ease the documentation
   of SR use-cases and hence does not propose a name for any possible
   variation of IGP segment supported by the architecture.  For example,
   y in Figure 7 could represent a local IGP segment attached to an IGP
   Prefix.  This variation, while supported by the SR architecture is
   not seen in the SR use-cases and hence does not receive a specific
   name.

Thanks & Regards
Anil S N

“Be liberal in what you accept, and conservative in what you send” - Jon Postel

From: Anil Kumar S N (VRP Network BL)
Sent: 21 September 2015 20:00
To: [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>'; Jeff Tantsura
Cc: [email-masked]<mailto:[email-masked]>'
Subject: draft-previdi-isis-segment-routing-extensions-05

Hi Authors,

In Segment Routing Architecture draft,  There is a provision to allocate multiple Adj-SIDs to same adjacency in case of bundle interface.
In IGP extension draft we need to have one more Adjacency Segment Identifier (Adj-SID) Sub-TLV type to distribute SID’s for bundle members with bundle member ID.

Please let me know your opinion.

Reference :

https://tools.ietf.org/html/draft-ietf-spring-segment-routing-05

3.5.  IGP-Adjacency Segment, Adj-SID

A node MAY allocate multiple Adj-SIDs to the same adjacency.  An
   example is where the adjacency is established over a bundle
   interface.  Each bundle member MAY have its own Adj-SID.

Thanks & Regards
Anil S N

“Be liberal in what you accept, and conservative in what you send” - Jon Postel

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Tue, 22 Sep 2015 11:11:02 +0000

Hi Acee,

                It was my mistake referring old draft, current draft are consistent.  Both OSPF extension and SR Architecture draft use L-Flag.
                Apart from this other comments are valid I support , yet to hear from authors.

Thanks & Regards
Anil S N

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: 22 September 2015 16:38
To: Anil Kumar S N (VRP Network BL); Stefano Previdi (sprevidi); Clarence Filsfils (cfilsfil); Ahmed Bashandy (bashandy); [email-masked]; [email-masked]; Jeff Tantsura; [email-masked]
Cc: [email-masked]
Subject: Re: [Isis-wg] draft-previdi-isis-segment-routing-extensions-05

Hi Anil,

Hi Authors,

Thanks & Regards
Anil S N

Hi Authors,

Reference :

Thanks & Regards
Anil S N