Subject: [Isis-wg] More support? Re: WG Last Call for draft-ietf-isis-sbfd-discriminator-02

From: Christian Hopps <[email-masked]>
Date: Thu, 01 Oct 2015 06:31:08 -0400

Hi Folks,

far there's not been much public indication of support for this
draft. It did clear WG last call and we can move it forward on the
belief that everyone is quietly accepting it; however, I would prefer it
if a few more people could be vocal in their support of the document.

Thanks,
Chris.

Christian Hopps <[email-masked]> writes:

> Hi Folks,
>
> We are starting a WG Last Call on the following draft.
>
> “Advertising S-BFD Discriminators in IS-IS”
> https://datatracker.ietf.org/doc/draft-ietf-isis-sbfd-discriminator/
>
> The LC is set to expire 3 weeks from now (allowing for common vacation
> time) on Friday, September 4th, 2015.
>
> Thanks,
> Chris & Hannes.
>
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 1 Oct 2015 14:57:02 +0000

FWIW...

I support this as co-author.

But, it also seems relevant to comment on what seems to be a "behavior change".

In the past, expressions of support were expected when asking if a document should be made a WG item. However, once that happened, when a last call was issued it was only expected that folks should express reservations if they had any. Expressions of support for last call were not expected because it was assumed that since the WG had already been actively working on the document since it became a WG item support was implicit.

Now however it seems that there is an expectation that despite all of the history of the document post WG acceptance folks are supposed to once again say "Yes I support this".
When did this behavior change and could the chairs and/or the ADs explain why the change was made?

Thanx.

   Les

> -----Original Message-----
> From: Isis-wg [mailto:[email-masked]] On Behalf Of Christian
> Hopps
> Sent: Thursday, October 01, 2015 3:31 AM
> To: ISIS-WG
> Cc: [email-masked]
> Subject: [Isis-wg] More support? Re: WG Last Call for draft-ietf-isis-sbfd-
> discriminator-02
> 
> 
> Hi Folks,
> 
> far there's not been much public indication of support for this draft. It did
> clear WG last call and we can move it forward on the belief that everyone is
> quietly accepting it; however, I would prefer it if a few more people could be
> vocal in their support of the document.
> 
> Thanks,
> Chris.
>

---

From: Uma Chunduri <[email-masked]>
Date: Thu, 1 Oct 2015 18:28:51 +0000

Support.

--
Uma C.

-----Original Message-----
From: Isis-wg [mailto:[email-masked]] On Behalf Of Christian Hopps
Sent: Thursday, October 01, 2015 3:31 AM
To: ISIS-WG
Cc: [email-masked]
Subject: [Isis-wg] More support? Re: WG Last Call for draft-ietf-isis-sbfd-discriminator-02

Hi Folks,

far there's not been much public indication of support for this draft. It did clear WG last call and we can move it forward on the belief that everyone is quietly accepting it; however, I would prefer it if a few more people could be vocal in their support of the document.

Thanks,
Chris.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 1 Oct 2015 18:31:09 +0000

Some additional context here...

My remarks regarding expectations of support during last call are not specifically aimed at the SBFD draft nor the IS-IS WG. I see this change of behavior across multiple WGs and I am wondering why?
Some enlightenment from the ADs would be appreciated.

   Les

> From: Isis-wg [mailto:[email-masked]] On Behalf Of Les Ginsberg
> (ginsberg)
> Sent: Thursday, October 01, 2015 7:57 AM
> To: Christian Hopps; ISIS-WG
> Subject: Re: [Isis-wg] More support? Re: WG Last Call for draft-ietf-isis-sbfd-
> discriminator-02
> 
> FWIW...
> 
> In the past, expressions of support were expected when asking if a
> document should be made a WG item. However, once that happened, when
> a last call was issued it was only expected that folks should express
> reservations if they had any. Expressions of support for last call were not
> expected because it was assumed that since the WG had already been
> actively working on the document since it became a WG item support was
> implicit.
> 
> Now however it seems that there is an expectation that despite all of the
> history of the document post WG acceptance folks are supposed to once
> again say "Yes I support this".
> > far there's not been much public indication of support for this draft.
> > It did clear WG last call and we can move it forward on the belief
> > that everyone is quietly accepting it; however, I would prefer it if a
> > few more people could be vocal in their support of the document.
> >
> > Thanks,
> > Chris.
> >

---

From: Alia Atlas <[email-masked]>
Date: Thu, 1 Oct 2015 16:43:59 -0400

Les,

It's all too common for interest in a draft to peak at WG adoption.
Particularly if there hasn't been much active discussion, it is very useful
to
know that a draft has gotten significant review, is still needed, and is
ready to be published.

Having clear evidence of WG consensus at WGLC assures that the work is
still needed and ready.

There are some drafts where publication is requested and one wonders if
anyone
has fully read the draft or just looked at diffs.

Hope that helps,
Alia

On Thu, Oct 1, 2015 at 2:31 PM, Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> My remarks regarding expectations of support during last call are not
> specifically aimed at the SBFD draft nor the IS-IS WG. I see this change of
> behavior across multiple WGs and I am wondering why?

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 2 Oct 2015 00:31:04 +0000

Alia –

It is not that I strongly object to the new behavior – it just seems a bit odd.

The document gets adopted by the WG – that clearly requires some level of support.
The document then gets presented – often multiple times – and undergoes multiple revisions – each of which is based on feedback received.
Once the authors/chairs believe the document is mature last call is requested.

For all the folks who have participated in the review of the document the work is done and clearly there has been interest in the work – an inspection of the WG archives reveals that.

I don’t know of any document that goes to last call w/o any comment whatsoever during the time it is a WG doc. If that is the case I would think the chairs are justified in saying there is no reason to go to last call because no work has been done on the document post becoming a WG item.
If you want evidence of review it should be found in the WG archives – not in a statement in response to last call.

I have always interpreted last call as an opportunity for folks who believe the document is not yet mature to say so – but instead it seems  to be used as a way of verifying that there is actually interest in the document – which is too late and too perfunctory for my tastes.

   Les

From: Alia Atlas [mailto:[email-masked]]
Sent: Thursday, October 01, 2015 1:44 PM
To: Les Ginsberg (ginsberg)
Cc: Christian Hopps; ISIS-WG
Subject: Re: [Isis-wg] More support? Re: WG Last Call for draft-ietf-isis-sbfd-discriminator-02

Les,

It's all too common for interest in a draft to peak at WG adoption.
Particularly if there hasn't been much active discussion, it is very useful to
know that a draft has gotten significant review, is still needed, and is
ready to be published.

There are some drafts where publication is requested and one wonders if anyone
has fully read the draft or just looked at diffs.

Hope that helps,
Alia

On Thu, Oct 1, 2015 at 2:31 PM, Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>> wrote:
Some additional context here...

   Les

> From: Isis-wg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Les Ginsberg
> (ginsberg)
> > From: Isis-wg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Christian
> > Hopps
> > Cc: [email-masked]<mailto:[email-masked]>
> > Christian Hopps <[email-masked]<mailto:[email-masked]>> writes:
> >
> > > Hi Folks,
> > >
> > > [email-masked]<mailto:[email-masked]>
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
Isis-wg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Marc Binderberger <[email-masked]>
Date: Sat, 3 Oct 2015 23:38:07 -0700

Hello Les, Alia, Christian et al.,

first: I still do support the document :-) and think it should move on 
towards RFC.

Then: I see the points made by Les and Alia but at the end the "fail" is on 
the supporter side - it's just a quick "I support" email. Yes, I'm guilty too 
(and yes, nobody wants to hear my excuse :-)

Regards, Marc

On Fri, 2 Oct 2015 00:31:04 +0000, Les Ginsberg (ginsberg) wrote:
> The document then gets presented – often multiple times – and undergoes 
> multiple revisions – each of which is based on feedback received.
> For all the folks who have participated in the review of the document the 
> work is done and clearly there has been interest in the work – an 
> inspection of the WG archives reveals that. 
>  
> I don’t know of any document that goes to last call w/o any comment 
> whatsoever during the time it is a WG doc. If that is the case I would 
> think the chairs are justified in saying there is no reason to go to last 
> call because no work has been done on the document post becoming a WG item.
> I have always interpreted last call as an opportunity for folks who believe 
> the document is not yet mature to say so – but instead it seems  to be 
> used as a way of verifying that there is actually interest in the document 
> – which is too late and too perfunctory for my tastes.
>  
>    Les
>  
>  
> On Thu, Oct 1, 2015 at 2:31 PM, Les Ginsberg (ginsberg) 
> <[email-masked]> wrote:

---

From: Manav Bhatia <[email-masked]>
Date: Sun, 4 Oct 2015 16:53:15 +0000 (UTC)

I support the draft AND i am not the co-author ! :-)
Cheers, Manav 

     On Friday, 2 October 2015, 2:14, Alia Atlas <[email-masked]> wrote:

 Les,
It's all too common for interest in a draft to peak at WG adoption.Particularly if there hasn't been much active discussion, it is very useful toknow that a draft has gotten significant review, is still needed, and isready to be published.
Having clear evidence of WG consensus at WGLC assures that the work isstill needed and ready.
There are some drafts where publication is requested and one wonders if anyonehas fully read the draft or just looked at diffs.
Hope that helps,Alia

On Thu, Oct 1, 2015 at 2:31 PM, Les Ginsberg (ginsberg) <[email-masked]> wrote:

   Les

---

From: Alia Atlas <[email-masked]>
Date: Mon, 5 Oct 2015 11:29:31 -0400

Les,

It's frequently a final effort to determine whether and how much interest
there
really is in the draft.  Adoption and WGLC can be separated by quite some
time.
Some drafts show good discussion and support all along the process - and
some
seem to have fallen into deep black holes.  Discussion and support and
reviews
(even of the "I read this and it was good" variety) are all preferable -
but what does
a WG Chair do when those haven't really happened but the draft is ready?

I would note that I (and I believe the other ADs) haven't specifically
pushed for
this.  What we have done is encourage our WG Chairs to think about what
judging consensus and looking for an active consensus is like.  You might
find reading RFC 7282 interesting.  We did a Routing Area WG chair training
on
it about a year ago (
http://wiki.tools.ietf.org/area/rtg/trac/wiki/WGChairTraining )
that might be interesting.

Regards,
Alia

On Thu, Oct 1, 2015 at 8:31 PM, Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> I have always interpreted last call as an opportunity for folks who
> believe the document is not yet mature to say so – but instead it seems  to
> be used as a way of verifying that there is actually interest in the
> document – which is too late and too perfunctory for my tastes.
>
>
>
>    Les
>
>
>
>
>
> *From:* Alia Atlas [mailto:[email-masked]]
> *Sent:* Thursday, October 01, 2015 1:44 PM
> *To:* Les Ginsberg (ginsberg)
> *Cc:* Christian Hopps; ISIS-WG
>
> *Subject:* Re: [Isis-wg] More support? Re: WG Last Call for
> draft-ietf-isis-sbfd-discriminator-02
>
>
>
> Les,
>
>
>

---

From: Ayan Banerjee <[email-masked]>
Date: Tue, 6 Oct 2015 10:14:42 -0700

Support as well.

Thanks,
Ayan

On Sat, Oct 3, 2015 at 11:38 PM, Marc Binderberger <[email-masked]> wrote:

> > It is not that I strongly object to the new behavior – it just seems a
> bit
> > odd.
> >
> > If you want evidence of review it should be found in the WG archives –
> not
> > in a statement in response to last call.
> >
> believe
> >> When did this behavior change and could the chairs and/or the ADs
> explain
> >> why the change was made?
> >>
> >> Thanx.
> >>
> >>    Les
> >>
> >>