Subject: Re: [Isis-wg] Ben Campbell's No Objection on draft-ietf-isis-route-preference-02: (with COMMENT)

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 18 Nov 2015 04:46:25 +0000

Ben -

Thanx for the review.

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, November 17, 2015 8:07 PM
> To: The IESG
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Ben Campbell's No Objection on draft-ietf-isis-route-preference-02:
> (with COMMENT)
> 
> Ben Campbell has entered the following ballot position 
> draft-ietf-isis-route-preference-0[Les:]  2: No Objection
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-isis-route-preference/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> A security considerations section that says "None." is pretty much the same
> as not having the section.

[Les:] We did think about security. The draft makes no changes to the protocol - it adds no new advertisements nor modifies any existing advertisement. It merely clarifies route preference rules for the existing route types that already exist. So "None" accurately captures the security issues associated with this draft.  Do we actually have to say that? 

The important thing about a security section to me is that it correctly identifies the areas of concern. In this case since there are none it seems to me we have met the requirements admirably. :-)

   Les

 > I assume that means people thought about it, and
> reached the conclusion this was security neutral. It might be helpful to at
> least briefly describe that thought process.
>

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 17 Nov 2015 20:07:09 -0800

Ben Campbell has entered the following ballot position for
draft-ietf-isis-route-preference-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

A security considerations section that says "None." is pretty much the
same as not having the section. I assume that means people thought about
it, and reached the conclusion this was security neutral. It might be
helpful to at least briefly describe that thought process.

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 17 Nov 2015 22:53:47 -0600

On 17 Nov 2015, at 22:46, Les Ginsberg (ginsberg) wrote:

>> email
>> Please refer to 
>> https://www.ietf.org/iesg/statement/discuss-criteria.html
> [Les:] We did think about security. The draft makes no changes to the 
> protocol - it adds no new advertisements nor modifies any existing 
> advertisement. It merely clarifies route preference rules for the 
> existing route types that already exist. So "None" accurately captures 
> the security issues associated with this draft.  Do we actually have 
> to say that?

Have to? I guess that's up to you and your AD :-) This was not a 
DISCUSS, and I don't plan to push the point.

>
> The important thing about a security section to me is that it 
> correctly identifies the areas of concern. In this case since there 
> are none it seems to me we have met the requirements admirably. :-)

My strictly personal opinion is that it's helpful for the section to 
"show it's work" as it were. Knowing the thought process can be helpful 
to the reader. For example, if a reader thinks of a potential issue, 
it's helpful to know if the working group already thought about it and 
decided it wasn't a problem, or if it's something novel that hasn't been 
considered before.