Subject: [Isis-wg] Benoit Claise's No Objection on draft-ietf-isis-sbfd-discriminator-02: (with COMMENT)

From: "Benoit Claise" <[email-masked]>
Date: Wed, 18 Nov 2015 06:33:49 -0800

Benoit Claise has entered the following ballot position for
draft-ietf-isis-sbfd-discriminator-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-isis-sbfd-discriminator/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

As mentioned by Menachem in his OPS DIR review:
NITS
====

The NITS Tool founds the following warnings:

 == The document seems to contain a disclaimer for pre-RFC5378 work, but
was
     first submitted on or after 10 November 2008.  The disclaimer is
usually
     necessary only for documents that revise or obsolete older RFCs, and
that
     take significant amounts of text from those RFCs.  If you can
contact all
     authors of the source material and they are willing to grant the
BCP78
     rights to the IETF Trust, you can and should remove the disclaimer.

     Otherwise, the disclaimer is needed and you can ignore this comment.

     (See the Legal Provisions document at
     http://trustee.ietf.org/license-info for more information.)

 == Outdated reference: A later version (-05) exists of
     draft-ietf-bfd-seamless-base-04

-----------------------------------------

In addition the following sentence may need clarification: 

"When multiple S-BFD discriminators are advertised how a given
discriminator is mapped to a specific use case is out of scope for this
document."

It was not clear to me whether this is defined or will be defined in a
different document or whether this is left open for each implementation.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 18 Nov 2015 16:05:03 +0000

Benoit -

Thanx for the review.
Inline.

> -----Original Message-----
> From: Benoit Claise (bclaise)
> Sent: Wednesday, November 18, 2015 6:34 AM
> To: The IESG
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Benoit Claise's No Objection on draft-ietf-isis-sbfd-discriminator-02:
> (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
>      first submitted on or after 10 November 2008.  The disclaimer is usually
>      necessary only for documents that revise or obsolete older RFCs, and that
>      take significant amounts of text from those RFCs.  If you can contact all
> It was not clear to me whether this is defined or will be defined in a different
> document or whether this is left open for each implementation.
> 

[Les:] The draft says "...out of scope for this document" - which means we intend not to say anything further about this issue in this document. In what way is this not clear?

I do appreciate that people would like an answer to the question of how to map multiple discriminators to use cases - but that is not within the purview of this document (or its companion OSPF document). We are simply defining how to transport an opaque (to the IGP) value. Anything further belongs in the base S-BFD document. I think further discussion on this point belongs there. (I have made the same statement in regards to the same discussion within the context of http://datatracker.ietf.org/doc/draft-ietf-ospf-sbfd-discriminator/ .)

   Les