Subject: Re: [Isis-wg] WG Adoption Call for draft-xu-isis-encapsulation-cap

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 13 Jan 2016 01:25:02 +0000

Apologies for the very late response on this...

I have a couple of concerns regarding taking on this work.

The draft is straightforward enough in terms of the protocol extensions defined, but I am not at all clear on the usefulness of the information being advertised. The introduction to the draft discusses a variety of tunnel types which might be used in a network but does not offer an y reason why advertising the tunnel types supported is of benefit. Given this information is only advertised within a single administrative domain it does not seem to provide any information that is not already known to the network operator. It also logically leads to requiring a configuration for what tunnel types to advertise. If this information is meant to drive automatic configuration of tunnels I presume that the network operator would want to limit what is advertised - not simply accept what the implementation is capable of supporting. So it seems we have simply traded one configuration for another.  I would like to see more detail on this before deciding whether it is worth doing.

It is clear that the information is not at all useful to IS-IS itself - which brings me to my second concern. This is advertising information that has nothing to with IS-IS. Router Capabilities is not meant to be used as a vehicle to advertise information not of direct use to the protocol. In fact, the existence of a couple of exceptions to this guideline is what prompted the creation of GENAPP (RFC 6823) as the appropriate place to advertise such information.

I would like to see further discussion of the above before deciding that WG adoption (which almost always indicates an intent to progress to RFC) is appropriate.

    Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Christian Hopps
Sent: Monday, November 30, 2015 11:45 PM
To: [email-masked] list
Subject: Re: [Isis-wg] WG Adoption Call for draft-xu-isis-encapsulation-cap

[It seems due to some sneaky cut and paste error, the URL was wrong in the original email, I've corrected in this message]

Hi Folks,

The authors have requested the IS-IS WG adopt:

https://datatracker.ietf.org/doc/draft-xu-isis-encapsulation-cap/

as a working group document.

Please indicate support or no-support for taking on this work.

Thanks,
Chris.

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 15 Jan 2016 00:50:50 +0000

Les,

Thanks for your comments, see in line [Uma]:
--
Uma C.

From: Isis-wg [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Tuesday, January 12, 2016 5:25 PM
To: Christian Hopps; [email-masked] list
Subject: Re: [Isis-wg] WG Adoption Call for draft-xu-isis-encapsulation-cap

The draft is straightforward enough in terms of the protocol extensions defined, but I am not at all clear on the usefulness of the information being advertised. The introduction to the draft discusses a variety of tunnel types which might be used in a network but does not offer an y reason why advertising the tunnel types supported is of benefit.

[Uma]: Lot of use cases have been described where there is no configuration possible for all possible egress nodes at a given ingress node; as asymmetric connections can be made dynamically based on the network topology; using the tunnel capabilities or parameters of egress node  from ingress.

Given this information is only advertised within a single administrative domain it does not seem to provide any information that is not already known to the network operator.
[Uma]: This is not about whether network operators know all the information but it's about if it is possible to configure/manage

a.       all options supported by possible egress nodes from ingress nodes perspective or

b.      one option of all "possible" egress nodes from ingress nodes pov.

It also logically leads to requiring a configuration for what tunnel types to advertise. If this information is meant to drive automatic configuration of tunnels I presume that the network operator would want to limit what is advertised - not simply accept what the implementation is capable of supporting. So it seems we have simply traded one configuration for another.
[Uma]: I don't see, we have traded any configuration here. An in-line ingress application/feature  running as part of IS-IS ought to know what kind of tunnel capabilities the egress node is capable of accepting and associated parameters thereof for that tunnel.  Network operator can always limit enabling  capabilities that are being supported and capabilities that are being advertised by an egress node as part of ISIS through configuration.

I would like to see more detail on this before deciding whether it is worth doing.

It is clear that the information is not at all useful to IS-IS itself - which brings me to my second concern. This is advertising information that has nothing to with IS-IS. Router Capabilities is not meant to be used as a vehicle to advertise information not of direct use to the protocol.
[Uma]:  I am not sure why you see it is not all useful to IS-IS ; most of the features/applications listed in  section 1 are related to  ISIS protocols. For example RLFA- computation of PQ nodes done after primary SPF and as part of RLFA  SPFs (neighbor SPF, neighbors rSPF) and PQ nodes are computed dynamically on the current topology. It's not conceivable to provision an ingress node with one/all tunnel capabilities of egress nodes (essentially where ever this feature is enabled and potentially all eventually).  Similarly for Spring/Bier nodes dynamic tunnels can be supported based on the neighboring non-spring/non-bier node capabilities advertised.

In fact, the existence of a couple of exceptions to this guideline is what prompted the creation of GENAPP (RFC 6823) as the appropriate place to advertise such information.

    Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Christian Hopps
Sent: Monday, November 30, 2015 11:45 PM
To: [email-masked]<mailto:[email-masked]> list
Subject: Re: [Isis-wg] WG Adoption Call for draft-xu-isis-encapsulation-cap

Hi Folks,

Thanks,
Chris.