Subject: [Isis-wg] removing Controlled Convergence sub-TLV from draft-ietf-isis-mrt-02

From: Chris Bowers <[email-masked]>
Date: Mon, 17 Oct 2016 15:42:14 +0000

ISIS WG,

The authors of draft-ietf-isis-mrt-02  are planning to remove the Controlled Convergence sub-TLV that draft,
and instead use on an equivalent extension being defined in:

https://tools.ietf.org/html/draft-bryant-rtgwg-param-sync-00

Since the Controlled Convergence sub-TLV communicates information that may be useful for
applications other that MRT, it makes sense to have it in a separate document to allow it to be
better vetted in the context of those other applications.

I don't think that anyone has implemented the Controlled Convergence sub-TLV in draft-ietf-isis-mrt-02.
But if this is not the case, or anyone has another objection to removing it from draft-ietf-isis-mrt-02, please
raise that objection in the next week or so.

Thanks,
Chris

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 20 Oct 2016 20:43:56 +0000

Chris -

draft-bryant-rtgwg-param-sync introduces a new level of hierarchy in IS-IS by defining a generic "NWP" sub-TLV inside Router Capability TLV and then using a new registry to define sub-sub-TLVs.
I fail to see why this is necessary. While it is true that traditional IS-IS is limited to 255 sub-TLV codepoints for Router Capability TLV,  as of today we have only used 20+ of those codepoints - so we are in no danger of running out.  And sub-sub-TLV encoding becomes less efficient as it requires 2 extra bytes to encode the sub-sub-TLV wrapper.

If your argument is that you intend to use "NWP" for a large number of parameters then I immediately get concerned about what it is you have in mind that would quickly exhaust the sub-TLV space.

Please either drop the sub-sub-TLV proposal or be more transparent as to why you think it is needed.

I also note the new proposal does not include MTID associated w the convergence parameter - is that change intentional?

   Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Chris Bowers
Sent: Monday, October 17, 2016 8:42 AM
To: ISIS-WG
Subject: [Isis-wg] removing Controlled Convergence sub-TLV from draft-ietf-isis-mrt-02

ISIS WG,

Thanks,
Chris