Subject: Re: [Isis-wg] WG adoption of draft-baker-ipv6-isis-dst-src-routing-06

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 8 Dec 2016 13:12:19 +0100 (CET)

On Thu, 10 Nov 2016, [email-masked] wrote:

> Hi Folks,
>
> The authors of draft-baker-ipv6-isis-dst-src-routing-06 have requested
> WG adoption. Please indicate whether you support adoption of this work
> (some folks already have on the list). This is a 2 week call ending
> Thursday, November 24th, 2016.

I'm a bit late but yes, I suport adopting this document.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 8 Dec 2016 11:25:05 -0800

I sent good amount of comments on the draft a while ago. While I support
adoption I think those need addressing to ensure correctness of the draft
... tony

On Thu, Nov 10, 2016 at 6:27 AM, <[email-masked]> wrote:

> Can the authors also reply to this mail indicating whether they know of
> any IPR related to this draft?
>
> Thanks,
> Chris.
>
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>
>

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 8 Dec 2016 20:35:50 +0000

I think the bigger question – from the standpoint of WG adoption – is do we really believe there is a need for this extension?

There was a time when IS-IS was being considered as the homenet protocol – that ship seems to have sailed.
So the question becomes do we really think there is a deployment where these extensions will be needed? If the answer to that is yes, then I am convinced that the direction this draft has taken is the right one and we should then do the diligence necessary to finish the job.
But if the answer is “no” then this does not seem a worthwhile use of our time.

David (and/or others) – can you comment on this?

   Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Tony Przygienda
Sent: Thursday, December 08, 2016 11:25 AM
To: Christian Hopps
Cc: [email-masked]; [email-masked]
Subject: Re: [Isis-wg] WG adoption of draft-baker-ipv6-isis-dst-src-routing-06

I sent good amount of comments on the draft a while ago. While I support adoption I think those need addressing to ensure correctness of the draft ... tony

On Thu, Nov 10, 2016 at 6:27 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Folks,

Thanks,
Chris.

_______________________________________________
Isis-wg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/isis-wg

--
We’ve heard that a million monkeys at a million keyboards could produce the complete works of Shakespeare; now, thanks to the Internet, we know that is not true.
—Robert Wilensky

---

From: Alia Atlas <[email-masked]>
Date: Thu, 8 Dec 2016 15:39:48 -0500

Les,

On Thu, Dec 8, 2016 at 3:35 PM, Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> I think the bigger question – from the standpoint of WG adoption – is do
> we really believe there is a need for this extension?
>
>
>
> So the question becomes do we really think there is a deployment where
> these extensions will be needed? If the answer to that is yes, then I am
> convinced that the direction this draft has taken is the right one and we
> should then do the diligence necessary to finish the job.
>
Have you been following the discussion in RTGWG around
https://datatracker.ietf.org/doc/draft-bowbakova-rtgwg-enterprise-pa-multihoming/
and https://datatracker.ietf.org/doc/draft-ietf-rtgwg-dst-src-routing/
<https://datatracker.ietf.org/doc/draft-ietf-rtgwg-dst-src-routing/>  ?

The issues around IPv6 multihoming are not primarily related to homenet -
though homenet also has those same issues.

Regards,
Alia

>
>
>
>    Les
>
>
>
>
>
> *From:* Isis-wg [mailto:[email-masked]] *On Behalf Of *Tony
> Przygienda
> *Sent:* Thursday, December 08, 2016 11:25 AM
> *To:* Christian Hopps
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Isis-wg] WG adoption of draft-baker-ipv6-isis-dst-src-
> routing-06
>
>
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 8 Dec 2016 21:40:25 +0000

Alia –

I am aware of the RTGWG work – I am asking do we have reason to believe that there will be devices running IS-IS that require this support.
If you have some information on this I would be interested to see it.

   Les

From: Alia Atlas [mailto:[email-masked]]
Sent: Thursday, December 08, 2016 12:40 PM
To: Les Ginsberg (ginsberg)
Cc: Tony Przygienda; Christian Hopps; [email-masked]; [email-masked]
Subject: Re: [Isis-wg] WG adoption of draft-baker-ipv6-isis-dst-src-routing-06

Les,

On Thu, Dec 8, 2016 at 3:35 PM, Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>> wrote:
I think the bigger question – from the standpoint of WG adoption – is do we really believe there is a need for this extension?

Have you been following the discussion in RTGWG around https://datatracker.ietf.org/doc/draft-bowbakova-rtgwg-enterprise-pa-multihoming/
and https://datatracker.ietf.org/doc/draft-ietf-rtgwg-dst-src-routing/<https://datatracker.ietf.org/doc/draft-ietf-rtgwg-dst-src-routing/>  ?

The issues around IPv6 multihoming are not primarily related to homenet - though homenet also has those same issues.

Regards,
Alia

   Les

From: Isis-wg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Tony Przygienda
Sent: Thursday, December 08, 2016 11:25 AM
To: Christian Hopps
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] WG adoption of draft-baker-ipv6-isis-dst-src-routing-06

Thanks,
Chris.

---

From: Alia Atlas <[email-masked]>
Date: Thu, 8 Dec 2016 17:20:09 -0500

Les,

I don't personally.  I'm still poking and hearing there is the problem.

Regards,
Alia

On Thu, Dec 8, 2016 at 4:40 PM, Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> Alia –
>
>
>
> I am aware of the RTGWG work – I am asking do we have reason to believe
> that there will be devices running IS-IS that require this support.
>
> *From:* Alia Atlas [mailto:[email-masked]]
> *Sent:* Thursday, December 08, 2016 12:40 PM
> *To:* Les Ginsberg (ginsberg)
> *Cc:* Tony Przygienda; Christian Hopps; [email-masked];
> [email-masked]
>
> On Thu, Dec 8, 2016 at 3:35 PM, Les Ginsberg (ginsberg) <
> [email-masked]> wrote:
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 8 Dec 2016 22:24:49 +0000

Alia –

Yes – I am in the same boat – which is why I am asking the authors to provide some input on this point. Of course if anyone else has input I am happy to hear from you as well.
If we don’t have real deployments we are unlikely to get the kind of feedback essential to producing a specification that actually works.

   Les

Sent: Thursday, December 08, 2016 2:20 PM

Les,

Regards,
Alia

On Thu, Dec 8, 2016 at 4:40 PM, Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>> wrote:
Alia –

   Les

From: Alia Atlas [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, December 08, 2016 12:40 PM
To: Les Ginsberg (ginsberg)
Cc: Tony Przygienda; Christian Hopps; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Les,

Regards,
Alia

   Les

Thanks,
Chris.

---

From: David Lamparter <[email-masked]>
Date: Fri, 9 Dec 2016 12:03:12 +0100

Les,

to give a more direct answer - yes, I think there will be devices
running IS-IS with dst-src routing.  It'll be more rare than OSPF, but
my subjective impression is that it'll still be significant.

I'm basing my subjective impression on 2 factors:

- Enterprise networks aren't always homogenous large blobs;  there's
  things like smaller branch offices that aren't integrated well and
  such.  It's reasonable to expect they might be running IS-IS as a
  "grand policy", yet run some branches on "pa-multihoming" setups.

- Choice of IS-IS vs. OSPF is for operators I know not quite related to
  target scope or size, but actually to "who started the setup".  If the
  person you hire to scale up your network likes IS-IS, they'll just
  deploy that and you're running it for the next 10 years.

  (Assuming their chosen vendor doesn't charge a larger license to
  enable IS-IS, which many unfortunately do.)

These two boil down to "dst-src is not unreasonable in a large
enterprise network" and "IS-IS is not solely a large-enterprise routing
protocol".

Apart from that, while I don't want to take this assumption, I believe
dst-src has applications outside BCP38 exit routing, e.g. in separating
voice traffic for QoS, and in pushing security differentiations /
zoning.

I still agree that dst-src setups are an order of magnitude more likely
to use OSPF, and OSPF is an order of magnitude more likely to see
dst-src deployments; but I believe there is enough dst-src IS-IS use
case to proceed here.

-David

P.S.: The more interesting question is who else will be implementing
this.  That's where I see the larger potential for this draft to die
off -- but I'd like to make that evaluation at WGLC, not adoption ;)

(And I have heard of at least two large vendors looking at the topic.)

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 12 Dec 2016 17:45:41 +0100 (CET)

> If you have some information on this I would be interested to see it.

I believe there is. I believe the future will require more src/dst routing 
compared to before (because of IPv6 multihoming) and I do not want to 
concede this use-case to Babel (and OSPF) and rule out IS-IS for this 
application.