Subject: [Isis-wg] I-D Action: draft-ietf-isis-encapsulation-cap-01.txt

From: [email-masked]
Date: Mon, 24 Apr 2017 20:13:27 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IS-IS for IP Internets of the IETF.

        Title           : Advertising Tunnelling Capability in IS-IS
        Authors         : Xiaohu Xu
                          Bruno Decraene 
                          Robert Raszuk
                          Uma Chunduri
                          Luis M. Contreras
                          Luay Jalil
	Filename        : draft-ietf-isis-encapsulation-cap-01.txt
	Pages           : 11
	Date            : 2017-04-24

Abstract:
   Some networks use tunnels for a variety of reasons.  A large variety
   of tunnel types are defined and the ingress needs to select a type of
   tunnel which is supported by the egress.  This document defines how
   to advertise egress tunnel capabilities in IS-IS Router Capability
   TLV.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-isis-encapsulation-cap/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-isis-encapsulation-cap-01
https://datatracker.ietf.org/doc/html/draft-ietf-isis-encapsulation-cap-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-isis-encapsulation-cap-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Philip Christian <[email-masked]>
Date: Tue, 25 Apr 2017 08:50:00 +0100

There is already an existing standard for encapsulation capability TLV
in IS-IS.

Please see Annex B of ITU-T G.7712 here:-
https://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-G.7712-201009-I!!PDF-E&type=items

In summary it already defines a tunnelling capability TLV 16.
Within TLV 16 it defines subTLV 1 with the sets of 47,NLPID,NLPID for
GRE unencapsulation capabilities.

Surely it would be better to re-use this and use 1-46 for encapsulation
techniques other than GRE.

regards, Philip Christian

On 25/04/2017 04:13, [email-masked] wrote:
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 26 Apr 2017 01:26:47 +0000

Philip -

I appreciate your vigilance/persistence (really - I do!!).

If we (ISIS-WG)  try to pursue your suggestion it means that the WG has to discuss - in addition to the merits/demerits/use cases defined in draft-ietf-isis-encapsulation-cap-01.txt - the merits/demerits/use cases defined in Annex B of ITU-T G.7712 (and previously in your old draft https://www.ietf.org/archive/id/draft-ietf-isis-auto-encap-03.txt ).

I am not sure it is wise to try to legitimize the ITU usage in this way. But, if you want to pursue this I think you should put the question squarely to the WG, chairs, AD. I don't think either of us wants to be surreptitious about this.

   Les

> -----Original Message-----
> From: Isis-wg [mailto:[email-masked]] On Behalf Of Philip Christian
> Sent: Tuesday, April 25, 2017 12:50 AM
> To: [email-masked]
> Subject: Re: [Isis-wg] I-D Action: draft-ietf-isis-encapsulation-cap-01.txt
> 
> There is already an existing standard for encapsulation capability TLV in IS-IS.
> 
> Within TLV 16 it defines subTLV 1 with the sets of 47,NLPID,NLPID for GRE
> unencapsulation capabilities.
> 
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >