Subject: [Isis-wg] Regd encoding of ISIS SRMS range inside BGP-LS

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 14 Jun 2017 13:22:28 +0000

Hello All,

Needed some clarification from the authors and implementers of BGP-LS on Sec 3.4 of the https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-01#page-26 

It currently states ...

3.4.  Advertisement of a range of IS-IS SR bindings

   The advertisement of a range of IS-IS SR bindings has following
   rules:

      In IS-IS the Mapping Server binding ranges are advertised using
      the Binding TLV.  The IS-IS Binding TLV is encoded in the BGP-LS
      Prefix Attribute Range TLV as defined in Section 2.3.5 using the
      Binding Sub-TLV as defined in Section 2.3.6.  The flags in the
      Range TLV are all set to zero on transmit and ignored on
      reception.  The range value from the original IS-IS Binding TLV is
      encoded in the Range TLV "Range" field.

My understanding what that the encoding for ISIS is done with Range TLV + Prefix-SID sub-TLV (very similar to how it is specified in Sec 3.3 for OSPF). However the language is indirectly referring to the Prefix-SID sub-TLV by saying  "using the Binding Sub-TLV".

This may give an impression that the encoding for ISIS is done as Range TLV + Binding TLV + Prefix-SID sub-TLV and differently than done for OSPF. It would be clearer if the ISIS sec 3.4 were to also use similar language as OSPF sec 3.3. Would like to propose something like below:

3.4.  Advertisement of a range of IS-IS SR bindings

   The advertisement of a range of IS-IS SR bindings has following
   rules:

      In IS-IS the Mapping Server binding ranges are advertised using
      the IS-IS Binding TLV
      ([I-D.ietf-isis-segment-routing-extensions]).  The IS-IS Binding
      TLV is encoded in the BGP-LS Prefix Attribute Range TLV as defined
      in Section 2.3.4.
      The flags in the Range TLV are all set to zero on transmit and
      ignored on reception.  The range value from the original IS-IS
      Binding TLV is encoded in the Range TLV "Range" field. The
      Prefix-SID from the original ISIS Prefix SID Sub-TLV is encoded
      using the BGP-LS Prefix Attribute Prefix-SID as defined in
      Section 2.3.1 with the flags set according to the definition in
     [I-D.ietf-isis-segment-routing-extensions]

I would also like to check if anyone has implemented the encoding of ISIS SRMS range using the Binding SID TLV.

Thanks,
Ketan

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Fri, 16 Jun 2017 18:12:03 +0000

practically speaking, it would be helpful to know if there are any implementations of draft-ietf-idr-bgp-ls-segment-routing-ext and especially the Binding SID TLV.

We’re in the process of updating the draft and in an effort of simplification, we’d like to change the way the ISIS SRMS (SR Mapping Server) is encoded.

The changes we’d like to propose are not backward compatible so it is important to know if any implementation exists.

Thanks for coming back to us.

s.

> On Jun 14, 2017, at 3:22 PM, Ketan Talaulikar (ketant) <[email-masked]> wrote:
> 
> Hello All,
>