Subject: [Isis-wg] FW: New Version Notification for draft-ginsberg-isis-te-app-03.txt

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 20 Jun 2017 14:29:52 +0000

Folks -

This new version adds support for using a set of link attribute advertisements for ANY application - something which the OSPF companion draft (draft-ppsenak-ospf-te-link-attr-reuse) supports.
It also aligns the encoding so that is similar to that defined in the OSPF draft.

    Les

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, June 20, 2017 7:17 AM
To: Wim Henderickx; Stefano Previdi; Peter Psenak (ppsenak); Les Ginsberg (ginsberg)
Subject: New Version Notification for draft-ginsberg-isis-te-app-03.txt

A new version of I-D, draft-ginsberg-isis-te-app-03.txt has been successfully submitted by Les Ginsberg and posted to the IETF repository.

Name:		draft-ginsberg-isis-te-app
Revision:	03
Title:		IS-IS TE Attributes per application
Document date:	2017-06-20
Group:		Individual Submission
Pages:		15
URL:            https://www.ietf.org/internet-drafts/draft-ginsberg-isis-te-app-03.txt
Status:         https://datatracker.ietf.org/doc/draft-ginsberg-isis-te-app/
Htmlized:       https://tools.ietf.org/html/draft-ginsberg-isis-te-app-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ginsberg-isis-te-app-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ginsberg-isis-te-app-03

Abstract:
   Existing traffic engineering related link attribute advertisements
   have been defined and are used in RSVP-TE deployments.  In cases
   where multiple applications wish to make use of these link attributes
   the current advertisements do not support application specific values
   for a given attribute nor do they support indication of which
   applications are using the advertised value for a given link.

   This draft introduces new link attribute advertisements which address
   both of these shortcomings.  It also discusses backwards
   compatibility issues and how to minimize duplicate advertisements in
   the presence of routers which do not support the extensions defined
   in this document.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Wed, 21 Jun 2017 07:42:30 +0000

Hi Les,

The proposal has a better shape. Still two comments:
- As mentioned earlier, please precise that LFA means any flavor of LFA (LFA,rLFA,dLFA,TILFA...). 
- I would also like to see that "standard" applications may also use UDAs instead of the standard bit and possibility two sets of attributes (two UDAs or 1 std + 1 UDA): one example could be having an SR-TE tunnel using a particular set of attributes, and another SR-TE tunnel using another set of attributes.

Brgds,

Stephane

-----Original Message-----
From: Isis-wg [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Tuesday, June 20, 2017 16:30
To: [email-masked]
Subject: [Isis-wg] FW: New Version Notification for draft-ginsberg-isis-te-app-03.txt

Folks -

    Les

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, June 20, 2017 7:17 AM
To: Wim Henderickx; Stefano Previdi; Peter Psenak (ppsenak); Les Ginsberg (ginsberg)
Subject: New Version Notification for draft-ginsberg-isis-te-app-03.txt

Abstract:

                                                                                  

The IETF Secretariat

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Peter Psenak <[email-masked]>
Date: Wed, 21 Jun 2017 10:08:09 +0200

Hi Stephane,

> - As mentioned earlier, please precise that LFA means any flavor of LFA (LFA,rLFA,dLFA,TILFA...).

I would just say any flavor of LFA. Not all LFA types are defined in 
IETF documents.

> - I would also like to see that "standard" applications may also use UDAs instead of the standard bit and possibility two sets of attributes (two UDAs or 1 std + 1 UDA): one example could be having…

nobody is preventing you to do that. You can map any application to a 
UDA bits.

thanks,
Peter

> .

---

From: <[email-masked]>
Date: Thu, 22 Jun 2017 07:15:16 +0000

Hi Peter,

Thanks for your feedback, few comments inline

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Wednesday, June 21, 2017 10:08
To: LITKOWSKI Stephane OBS/OINIS; Les Ginsberg (ginsberg); [email-masked]
Subject: Re: [Isis-wg] New Version Notification for draft-ginsberg-isis-te-app-03.txt

Hi Stephane,

> - As mentioned earlier, please precise that LFA means any flavor of LFA (LFA,rLFA,dLFA,TILFA...).

I would just say any flavor of LFA. Not all LFA types are defined in IETF documents.
[SLI] I agree, "any flavor" works

> - I would also like to see that "standard" applications may also use UDAs instead of the standard bit and possibility two sets of attributes (two UDAs or 1 std + 1 UDA): one example could be having…

nobody is preventing you to do that. You can map any application to a UDA bits.

[SLI] Yes, but nothings tells that it is also allowed. I just want this point to be clear in the text.

thanks,
Peter

> ______________________________________________________________________
> ___________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 22 Jun 2017 14:36:11 +0000

Stephane -

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Thursday, June 22, 2017 12:15 AM
> To: Peter Psenak (ppsenak); Les Ginsberg (ginsberg); [email-masked]
> Subject: RE: [Isis-wg] New Version Notification for draft-ginsberg-isis-te-app-
> 03.txt
> 
> Hi Peter,
> 
> > - I would also like to see that "standard" applications may also use UDAs
> instead of the standard bit and possibility two sets of attributes (two UDAs or
> 1 std + 1 UDA): one example could be having an SR-TE tunnel using a
> particular set of attributes, and another SR-TE tunnel using another set of
> attributes.
> 
[Les:] The draft explicitly states that the use of UDA bits is outside the purview of any standards body. It would be unwise - and contradictory - to then start specifying how UDA bits can/cannot be used. The whole point of UDA is that it is up to the user to decide what the bits mean.

You clearly have some ideas about how you want to use them - but it is not the role of any specification to comment on your ideas any more than anyone else's ideas.

I think it is necessary for the draft to remain silent in this area.

   Les

> > This new version adds support for using a set of link attribute
> advertisements for ANY application - something which the OSPF companion
> draft (draft-ppsenak-ospf-te-link-attr-reuse) supports.
> > A new version of I-D, draft-ginsberg-isis-te-app-03.txt has been
> successfully submitted by Les Ginsberg and posted to the IETF repository.
> >
> > Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >
> > par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> > privileged information that may be protected by law; they should not be
> distributed, used or copied without authorisation.
> __________________________________________________________
> __________________________________________________________
> _____
> 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites
> ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez
> le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration, Orange decline toute
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.

---

From: <[email-masked]>
Date: Fri, 23 Jun 2017 06:57:56 +0000

My point is not to tell what to do with UDAs. It is to tell that standard applications MAY not use standard bits.

-----Original Message-----
From: Les Ginsberg (ginsberg) [mailto:[email-masked]] 
Sent: Thursday, June 22, 2017 16:36
To: LITKOWSKI Stephane OBS/OINIS; Peter Psenak (ppsenak); [email-masked]
Subject: RE: [Isis-wg] New Version Notification for draft-ginsberg-isis-te-app-03.txt

Stephane -

> Subject: RE: [Isis-wg] New Version Notification for 
> draft-ginsberg-isis-te-app- 03.txt
> 
> Hi Peter,
> 
> Subject: Re: [Isis-wg] New Version Notification for 
> draft-ginsberg-isis-te-app- 03.txt
> 
> Hi Stephane,
> 
> > - As mentioned earlier, please precise that LFA means any flavor of 
> > LFA
> (LFA,rLFA,dLFA,TILFA...).
> 
> particular set of attributes, and another SR-TE tunnel using another 
> set of attributes.
> 

   Les

> advertisements for ANY application - something which the OSPF 
> companion draft (draft-ppsenak-ospf-te-link-attr-reuse) supports.
> > It also aligns the encoding so that is similar to that defined in 
> > the OSPF
> draft.
> >
> >      Les
> >
> >
> ____________
> > confidentielles ou privilegiees et ne doivent donc pas etre 
> > diffuses, exploites ou copies sans autorisation. Si vous avez recu 
> > ce message par erreur, veuillez le signaler a l'expediteur et le 
> > detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete 
> altere, deforme ou falsifie. Merci.
> >
> > If you have received this email in error, please notify the sender 
> > and delete
> this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that 
> > have been
> modified, changed or falsified.
> > Thank you.
> >
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 23 Jun 2017 07:11:00 +0000

Stephane -

I do understand what you have asked for - please understand my point.

If something is outside the scope of the specification then the specification MUST NOT: infer, recommend, suggest, imply, or otherwise comment...

The specification has provided support for advertising User Defined Apps - you can use this space as you wish without violating the specification. And someone else can use the space in a way different than you choose to do - and they also will not be violating the specification.

   Les

> Sent: Thursday, June 22, 2017 11:58 PM
> To: Les Ginsberg (ginsberg); Peter Psenak (ppsenak); [email-masked]
> [Les:] The draft explicitly states that the use of UDA bits is outside the
> purview of any standards body. It would be unwise - and contradictory - to
> then start specifying how UDA bits can/cannot be used. The whole point of
> UDA is that it is up to the user to decide what the bits mean.
> 
> You clearly have some ideas about how you want to use them - but it is not
> the role of any specification to comment on your ideas any more than
> anyone else's ideas.
> 
> > > URL:            https://www.ietf.org/internet-drafts/draft-ginsberg-isis-te-
> app-
> > 03.txt
> > > be

---

From: John E Drake <[email-masked]>
Date: Fri, 23 Jun 2017 13:07:56 +0000

Hi,

I think what you wanted to say was that standard applications MAY use the UDA bits.  However, as Les pointed out the UDA bits are open range so nothing further needs to be said. 

Yours Irrespectively,

John

> From: Isis-wg [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, June 23, 2017 2:58 AM
> To: Les Ginsberg (ginsberg) <[email-masked]>; Peter Psenak (ppsenak)
> <[email-masked]>; [email-masked]
> [Les:] The draft explicitly states that the use of UDA bits is outside the purview
> of any standards body. It would be unwise - and contradictory - to then start
> specifying how UDA bits can/cannot be used. The whole point of UDA is that it is
> up to the user to decide what the bits mean.
> 
> You clearly have some ideas about how you want to use them - but it is not the
> role of any specification to comment on your ideas any more than anyone else's
> ideas.
> 
> _________________________________________________________________
> ________________________________________________________
> 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou
> copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le
> signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration, Orange decline toute
> information that may be protected by law; they should not be distributed, used
> or copied without authorisation.

---

From: <[email-masked]>
Date: Mon, 26 Jun 2017 10:03:41 +0000

Honestly, telling nothing leaves ambiguity.
Here is an example:
"A second bit mask is for non-
   standard User Defined Applications(UDAs)."

This could mean that UDA are only for non-standard apps which is not the case.

I do not see any trouble in adding a sentence that states clearly that standard apps MAY use UDA bits.

Brgds,

-----Original Message-----
From: Les Ginsberg (ginsberg) [mailto:[email-masked]] 
Sent: Friday, June 23, 2017 09:11
To: LITKOWSKI Stephane OBS/OINIS; Peter Psenak (ppsenak); [email-masked]
Subject: RE: [Isis-wg] New Version Notification for draft-ginsberg-isis-te-app-03.txt

Stephane -

   Les

> My point is not to tell what to do with UDAs. It is to tell that 
> standard applications MAY not use standard bits.
> 
> 
> > > - As mentioned earlier, please precise that LFA means any flavor 
> > > of LFA
> [Les:] The draft explicitly states that the use of UDA bits is outside 
> the purview of any standards body. It would be unwise - and 
> contradictory - to then start specifying how UDA bits can/cannot be 
> used. The whole point of UDA is that it is up to the user to decide what the bits mean.
> 
> You clearly have some ideas about how you want to use them - but it is 
> not the role of any specification to comment on your ideas any more 
> than anyone else's ideas.
> 
> > detruire ainsi que les pieces jointes. Les messages electroniques 
> > etant susceptibles d'alteration, Orange decline toute responsabilite 
> > si ce message a ete altere,
> deforme ou falsifie. Merci.
> >
> > and delete this message and its attachments.
> > have been modified, changed or falsified.
> > Thank you.
> 
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 28 Jun 2017 07:23:36 +0000

Stephane -

> Sent: Monday, June 26, 2017 3:04 AM

[Les:] Actually, this IS exactly the case. :-)

Something which is standardized MUST follow all of the normative statements defined for that application. In this case that includes use of the application bit assigned for it by IANA.

Having a user defined application which looks and acts like a standardized application EXCEPT for ... isn't something which falls under the IETF purview.
It is either a buggy/non-interoperable implementation of a standardized application - or it is something else - take your pick.

   Les

> If something is outside the scope of the specification then the specification
> MUST NOT: infer, recommend, suggest, imply, or otherwise comment...
> 
> The specification has provided support for advertising User Defined Apps -
> you can use this space as you wish without violating the specification. And
> someone else can use the space in a way different than you choose to do -
> and they also will not be violating the specification.
> 
>    Les
> 
> 
> > > > Htmlized:       https://datatracker.ietf.org/doc/html/draft-ginsberg-isis-
> te-
> > > app-03