Subject: Re: [Isis-wg] I-D Action: draft-ietf-isis-segment-routing-extensions-13.txt

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 30 Jun 2017 12:05:49 +0000

Hi Chris, 

There was a protracted discussion on what SR sub-TLVs are actually
implemented. Did you and colleagues familiar with the usage you describe
below miss this entirely???

Here is the first E-mail from the IS-IS list archive:
https://mailarchive.ietf.org/arch/msg/isis-wg/KPMgDBoOek0LI-wFFupSFnWrbbo

Thanks,
Acee

On 6/30/17, 7:51 AM, "Isis-wg on behalf of Chris Bowers"
<[email-masked] on behalf of [email-masked]> wrote:

>Stefano,
> 
>Among the changes between draft-ietf-isis-segment-routing-extensions-12
>and -13 is the removal of the SID/Label sub-TLV from the SID/Label
>Binding TLV.
> 
>I don't agree with this change.  The SID/Label sub-TLV is used in the
>SID/Label Binding TLV when the Mirror Context flag is set in the
>SID/Label Binding TLV.  The use of the Mirroring Context Segment is
>described in section 5 of draft-ietf-spring-segment-routing-12.  There is
>at least one implementation using the encoding described in the versions
>of the draft up to and including
>draft-ietf-isis-segment-routing-extensions-12, where the SID/Label
>sub-TLV carries the label information for the mirror context in the
>SID/Label Binding TLV.  The SID/Label sub-TLV has the appropriate
>characteristics for this application.
> 
>I also noticed a separate issue in that the IANA considerations section
>(both before and after the changes in -13) does not capture the use of
>the SID/Label Sub-TLV in the SR Local Block Sub-TLV.  Presumably when the
>SID/Label Sub-TLV is used in the SR Local Block Sub-TLV, its type is the
>same as when it is used in the SID/Label Binding TLV and the
>Multi-Topology Segment Identifier / Label Binding TLV.  If so, this
>should be reflected in the definition of the new sub-TLV registry.
> 
>Thanks,
>Chris
>
>
>-----Original Message-----
>From: Isis-wg [mailto:[email-masked]] On Behalf Of Stefano
>Previdi (sprevidi)
>Sent: Monday, June 19, 2017 10:27 PM
>To: [email-masked] list <[email-masked]>
>Subject: Re: [Isis-wg] I-D Action:
>draft-ietf-isis-segment-routing-extensions-13.txt
>
>All,
>
>in tis version we removed the ERO subTLVs of the Binding SID TLV and
>fixed some other minor inconsistencies.
>
>Thanks.
>s.
>
>
>> On Jun 19, 2017, at 10:25 PM, [email-masked] wrote:
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts
>>directories.
>> This draft is a work item of the IS-IS for IP Internets of the IETF.
>> 
>>        Title           : IS-IS Extensions for Segment Routing
>>        Authors         : Stefano Previdi
>>                          Clarence Filsfils
>>                          Ahmed Bashandy
>>                          Hannes Gredler
>>                          Stephane Litkowski
>>                          Bruno Decraene
>>                          Jeff Tantsura
>> 	Filename        : draft-ietf-isis-segment-routing-extensions-13.txt
>> 	Pages           : 33
>> 	Date            : 2017-06-19
>> 
>> Abstract:
>>   Segment Routing (SR) allows for a flexible definition of end-to-end
>>   paths within IGP topologies by encoding paths as sequences of
>>   topological sub-paths, called "segments".  These segments are
>>   advertised by the link-state routing protocols (IS-IS and OSPF).
>> 
>>   This draft describes the necessary IS-IS extensions that need to be
>>   introduced for Segment Routing operating on an MPLS data-plane.
>> 
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-isis-segment-routing-exten
>> sions/
>> 
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions
>> -13
>> https://datatracker.ietf.org/doc/html/draft-ietf-isis-segment-routing-
>> extensions-13
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-isis-segment-routing-exte
>> nsions-13
>> 
>> 
>> Please note that it may take a couple of minutes from the time of
>> submission until the htmlized version and diff are available at
>>tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> I-D-Announce mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce
>> Internet-Draft directories: http://www.ietf.org/shadow.html or
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>_______________________________________________
>Isis-wg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/isis-wg
>
>_______________________________________________
>Isis-wg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Chris Bowers <[email-masked]>
Date: Fri, 30 Jun 2017 14:03:24 +0000

Acee,

The thread you cite from June 9th started out as a discussion of removing ERO related extensions from draft-ietf-spring-segment-routing. 
The discussion went in a lot of different directions from that point.  There was initially a great deal
of confusion about what was actually being proposed.  On June 12th, Stefano provided clarification of what was being proposed in the form of:

https://mailarchive.ietf.org/arch/msg/isis-wg/qPLdIvJARO8oK2ROtGxxQxiCZwY

This clarification only proposed removing ERO-related sub-TLVs.  

The changes in draft-ietf-isis-segment-routing-extensions-13 go beyond what was proposed there.

Chris

-----Original Message-----
From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Friday, June 30, 2017 2:06 PM
To: Chris Bowers <[email-masked]>; Stefano Previdi (sprevidi) <[email-masked]>; [email-masked] list <[email-masked]>
Subject: Re: [Isis-wg] I-D Action: draft-ietf-isis-segment-routing-extensions-13.txt

Hi Chris, 

There was a protracted discussion on what SR sub-TLVs are actually implemented. Did you and colleagues familiar with the usage you describe below miss this entirely???

Thanks,
Acee

On 6/30/17, 7:51 AM, "Isis-wg on behalf of Chris Bowers"
<[email-masked] on behalf of [email-masked]> wrote:

>described in section 5 of draft-ietf-spring-segment-routing-12.  There 
>is at least one implementation using the encoding described in the 
>versions of the draft up to and including 
>the SID/Label Sub-TLV in the SR Local Block Sub-TLV.  Presumably when 
>the SID/Label Sub-TLV is used in the SR Local Block Sub-TLV, its type 
>is the same as when it is used in the SID/Label Binding TLV and the