Subject: Re: [Isis-wg] WG Adoption poll for draft-hegde-isis-advertising-te- protocols

From: Sami Boutros <[email-masked]>
Date: Thu, 12 Oct 2017 21:57:50 +0000

Given the revised text in https://www.ietf.org/id/draft-ietf-isis-te-app-01.txt section 6, is this draft still needed?

Thanks,

Sami
-----Original Message-----
From: Isis-wg [mailto:[email-masked]] On Behalf Of Christian
Hopps
Sent: Friday, October 06, 2017 7:43 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>;
draft-hegde-isis-advertising-te- [email-masked]<mailto:[email-masked]>
Subject: [Isis-wg] WG Adoption poll for
draft-hegde-isis-advertising-te- protocols
Hi Folks,
The authors have requested the IS-IS WG adopt

https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
org_doc_draft-2Dhegde-2Disis-2Dadvertising-2Dte-2Dprotocols_&d=DwICAg&
c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEW
H-s_xXXup3HzvBSMRj5VE&m=pi7-8Xzsmi8d3us4xv6ifujYP0pPLIcRTajhGlNZ8is&s=
Mnizs5neSNoKSzC8H0U29uTdEqyFGiOCAMNdGzpJ9YY&e=
as a working group document. Please indicate your support or
no-support for taking on this work.
Authors: Please indicate your knowledge of any IPR related to this
work to the list as well.
Thanks,
Chris & Hannes.

_______________________________________________
Isis-wg mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_isis-2Dwg&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=CRB2tJiQePk0cT-h5LGhEWH-s_xXXup3HzvBSMRj5VE&m=pi7-8Xzsmi8d3us4xv6ifujYP0pPLIcRTajhGlNZ8is&s=ms8T3YVKNmWpf9pwJn-a2IpHf66ygk8T2VV7Fbi6Wys&e=

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 13 Oct 2017 01:36:36 -0700

I have got exactly the same question?

Thanks,

Jeff

From: Isis-wg <[email-masked]> on behalf of Sami Boutros <[email-masked]>
Date: Thursday, October 12, 2017 at 14:58
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Isis-wg] WG Adoption poll for draft-hegde-isis-advertising-te- protocols

Thanks,

Sami

-----Original Message-----

Hopps

To: [email-masked]

Cc: [email-masked]; [email-masked]; 

draft-hegde-isis-advertising-te- [email-masked]

Hi Folks,

Thanks,

Chris & Hannes.

Isis-wg mailing list

[email-masked]

_______________________________________________ Isis-wg mailing list [email-masked] https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Shraddha Hegde <[email-masked]>
Date: Fri, 13 Oct 2017 13:27:08 +0000

Hi Sami,

Its better to keep protocol enabled/disabled information decoupled from the

“Application Specific Link Attributes sub-TLV”

Its useful to advertise RSVP enabled/disabled on a link so the head-end nodes/controllers can use this

Information instead of depending on non-standard mechanisms. IMO, this was needed many years ago.

It’s not a good idea to couple protocol enablement with application specific attribute because application specific link attribute sub-tlv may not be generated in
Deployments which do not need the feature.

Rgds
Shraddha

From: Isis-wg [mailto:[email-masked]] On Behalf Of Sami Boutros
Sent: Friday, October 13, 2017 3:28 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Isis-wg] WG Adoption poll for draft-hegde-isis-advertising-te- protocols

Given the revised text in https://www.ietf.org/id/draft-ietf-isis-te-app-01.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_id_draft-2Dietf-2Disis-2Dte-2Dapp-2D01.txt&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=NyjLsr7JA7mvpCJa0YmPdVKcmMXJ31bpbBaNqzCNrng&m=O3GcMwU3QHS_s751vPoxv6s2QIFlHDtuCKgDkkLm1Ww&s=CF38fJHuqwjP1LD6okjaSYbMcohxwD8LDuiyYCR-sO8&e=> section 6, is this draft still needed?

Thanks,

Sami

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 13 Oct 2017 21:08:35 +0000

Shraddha –

RSVP-TE has been deployed for many years and the separation of RSVP enablement from link attribute advertisements has never been required or done.

What is true today is that implementations use the presence of link attribute advertisements to infer that RSVP is enabled on a link. The problem detailed in Figure 1 of your draft demonstrates that implementations do not agree on what specific sub-TLV is required to indicate RSVP enablement. The TE-APP draft resolves this issue by indicating whether link attribute advertisements are to be used by RSVP-TE – but it deliberately does NOT change the existing model of requiring at least one link attribute advertisement in order to infer RSVP enablement. This resolves the interoperability issue but does so in a way which is far less disruptive than what you propose.

You are suggesting that there is a use case for RSVP in the absence of any link attribute advertisements and that the lack of this separate signaling is causing a significant problem in networks today. This flies in the face of existing deployments – and is certainly not backwards compatible with anyone’s shipping code today.  I have discussed this issue with several RSVP-TE experts over the last several months and none of them has identified this as a problem which needs to be solved.

     Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Shraddha Hegde
Sent: Friday, October 13, 2017 6:27 AM
To: Sami Boutros <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Isis-wg] WG Adoption poll for draft-hegde-isis-advertising-te- protocols

Hi Sami,

Rgds
Shraddha

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Thanks,

Sami

---

From: "Naiming Shen (naiming)" <[email-masked]>
Date: Fri, 13 Oct 2017 21:12:40 +0000

Agreed. Whatever the additional capabilities this working group wants to do
with that should be consolidated into one mechanism I would think.

thanks.
- Naiming

On Oct 13, 2017, at 1:36 AM, Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Jeff
From: Isis-wg <[email-masked]<mailto:[email-masked]>> on behalf of Sami Boutros <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 12, 2017 at 14:58
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Isis-wg] WG Adoption poll for draft-hegde-isis-advertising-te- protocols

Thanks,

Sami
-----Original Message-----

_______________________________________________ Isis-wg mailing list [email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/isis-wg
_______________________________________________
Isis-wg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/isis-wg