Subject: [Isis-wg] ISIS SR Flexible Algorithm (Resending with alias correction)

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 20 Nov 2017 18:19:18 +0000

Hi Shraddha, Peter, et al,

The comment on the draft I had was that the conflict case where two ISIS routers advertise the same multi-homed prefix with a different algorithm needs to be covered. I wouldn’t try and optimize for this and would just do whatever is simplest but avoids loops (e.g., log the situation and prefer the path computed with the lowest numbered algorithm).

Thanks,
Acee

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 20 Nov 2017 13:11:05 -0800

So, it seems that there will be a new draft with 242 covering all
algorithms (i.e. no MT specific algo advertisement anymore).

Then I thought each MT advertises which Flex it supports. Is the assumption
that you can run multiple algorithms per MT? How would you otherwise have a
two-algorithms-to-same-prefix problem?

Is there some kind of conceptual model of FlexAlgo, i.e. how many of what
associated with how  many of the other (MT to algo, algo to protocol
instance etc) ...

-- tony

On Mon, Nov 20, 2017 at 10:19 AM, Acee Lindem (acee) <[email-masked]> wrote:

> The comment on the draft I had was that the conflict case where two ISIS
> routers advertise the same multi-homed prefix with a different algorithm
> needs to be covered. I wouldn’t try and optimize for this and would just do
> whatever is simplest but avoids loops (e.g., log the situation and prefer
> the path computed with the lowest numbered algorithm).
>
> Thanks,
> Acee
>
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 20 Nov 2017 21:40:16 +0000

Tony –

My understanding is that algorithm definitions are topology independent. This is consistent with the two algorithms defined today (standard SPF and strict-spf).
Using an algorithm in a particular topology would require topology/algorithm specific SIDs and the advertisement of topology specific link attributes (i.e., in an MT specific IS Neighbor).

   Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Tony Przygienda
Sent: Monday, November 20, 2017 1:11 PM
To: Acee Lindem (acee) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Isis-wg] ISIS SR Flexible Algorithm (Resending with alias correction)

So, it seems that there will be a new draft with 242 covering all algorithms (i.e. no MT specific algo advertisement anymore).

Then I thought each MT advertises which Flex it supports. Is the assumption that you can run multiple algorithms per MT? How would you otherwise have a two-algorithms-to-same-prefix problem?

Is there some kind of conceptual model of FlexAlgo, i.e. how many of what associated with how  many of the other (MT to algo, algo to protocol instance etc) ...

-- tony

On Mon, Nov 20, 2017 at 10:19 AM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Shraddha, Peter, et al,

Thanks,
Acee

_______________________________________________
Isis-wg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Peter Psenak <[email-masked]>
Date: Mon, 20 Nov 2017 23:04:44 +0100

Hi Acee,

On 20/11/17 19:19 , Acee Lindem (acee) wrote:
> needs to be covered. I wouldn’t try and optimize for this and would just
> do whatever is simplest but avoids loops (e.g., log the situation and
> prefer the path computed with the lowest numbered algorithm).

prefix can have SIDs for many algorithms. Prefix-SID for one algorithm 
is independent and orthogonal to prefix-SID for any other algorithm.

There is no need for all sources of the multi-homed prefix to include 
the same set of Algo-SIDs. Each source can advertise an independent set.

The case is similar to Alg-0 SID, where prefix is advertised from two 
different sources and one source advertise the Alg-0 SID and other does 
not.

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Mon, 20 Nov 2017 23:30:51 +0100

Hi Tony,

> algorithms (i.e. no MT specific algo advertisement anymore).

there is no MT specific algo advertisement in the current flex-algo 
draft. MTs are independent to flex-algos.

>
> Then I thought each MT advertises which Flex it supports. Is the
> assumption that you can run multiple algorithms per MT? How would you
> otherwise have a two-algorithms-to-same-prefix problem?
>
> Is there some kind of conceptual model of FlexAlgo, i.e. how many of
> what associated with how  many of the other (MT to algo, algo to
> protocol instance etc) ...

There is many to many relationship between MT and Flex-Algo. Single MT 
can use many Flex-Algos and single Flex-Algo can be used on many MTs.

thanks,
Peter

>     The comment on the draft I had was that the conflict case where two
>     ISIS routers advertise the same multi-homed prefix with a different
>     algorithm needs to be covered. I wouldn’t try and optimize for this
>     and would just do whatever is simplest but avoids loops (e.g., log
>     the situation and prefer the path computed with the lowest numbered
>     algorithm).
>
>     Thanks,
>     Acee
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/isis-wg>
>
>
>
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 20 Nov 2017 22:31:07 +0000

Hi Peter, 
At the edge of the SR domain, how does the ingress decide which
algorithm’s prefix SID to use? I guess it is a local matter. However, I
would call this out in the document.
Thanks,
Acee

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 20 Nov 2017 15:02:21 -0800

understood.

So you compute ALL algorithms in all topologies then? Or just the ones
which have prefix-sid with algorithm attached or something ? Is there a
draft for that yet ?  I only see
https://tools.ietf.org/html/draft-hegdeppsenak-isis-sr-flex-algo-01

--- tony

On Mon, Nov 20, 2017 at 1:40 PM, Les Ginsberg (ginsberg) <[email-masked]
> wrote:

> Tony –
>
>
>
> My understanding is that algorithm definitions are topology independent.
> This is consistent with the two algorithms defined today (standard SPF and
> strict-spf).
>
> Using an algorithm in a particular topology would require
> topology/algorithm specific SIDs and the advertisement of topology specific
> link attributes (i.e., in an MT specific IS Neighbor).
>
>
>
>    Les
>
>
>
>
>
> *From:* Isis-wg [mailto:[email-masked]] *On Behalf Of *Tony
> Przygienda
> *Sent:* Monday, November 20, 2017 1:11 PM
> *To:* Acee Lindem (acee) <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [Isis-wg] ISIS SR Flexible Algorithm (Resending with alias
> correction)
>
>
>

---

From: Shraddha Hegde <[email-masked]>
Date: Tue, 21 Nov 2017 04:12:12 +0000

Peter/Acee,

Lets assume 1.1.1.1 is advertised by two nodes A and B.
A assigns a SID 10 :algo 200
B assigns SID 10: algo 201

According to conflict resolution draft section 3.4 SID conflicts
Will be examined for algorithms and smallest algo wins
So remote nodes will program nexthops for SID 10 based on algo 200.

I think this case is addressed in conflict resolution draft. 
It would be better to handle all the conflict situation in conflict resolution draft
Rather than putting different pieces in different drafts.

Rgds
Shraddha

-----Original Message-----
From: Peter Psenak [mailto:[email-masked]] 
Sent: Tuesday, November 21, 2017 3:35 AM
To: Acee Lindem (acee) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: ISIS SR Flexible Algorithm (Resending with alias correction)

Hi Acee,

On 20/11/17 19:19 , Acee Lindem (acee) wrote:
> and would just do whatever is simplest but avoids loops (e.g., log the 
> situation and prefer the path computed with the lowest numbered algorithm).

prefix can have SIDs for many algorithms. Prefix-SID for one algorithm is independent and orthogonal to prefix-SID for any other algorithm.

There is no need for all sources of the multi-homed prefix to include the same set of Algo-SIDs. Each source can advertise an independent set.

The case is similar to Alg-0 SID, where prefix is advertised from two different sources and one source advertise the Alg-0 SID and other does not.

thanks,
Peter

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 21 Nov 2017 11:39:10 +0000

Hi Shraddha, 

The situation I’m talking about is not when the same SID is advertised. It
is simpler since the two IS-IS routers advertise different SIDs but use
different algorithms. In this case, SR-domain ingress router local policy
would dictate which topology and/or algorithm is selected.

Thanks, 
Acee

On 11/20/17, 11:12 PM, "Shraddha Hegde" <[email-masked]> wrote:

>To: Acee Lindem (acee) <[email-masked]>;
>[email-masked]
>Cc: [email-masked]
>prefix can have SIDs for many algorithms. Prefix-SID for one algorithm is
>independent and orthogonal to prefix-SID for any other algorithm.
>
>There is no need for all sources of the multi-homed prefix to include the
>same set of Algo-SIDs. Each source can advertise an independent set.
>