Subject: [Isis-wg] I-D Action: draft-ietf-isis-segment-routing-msd-05.txt

From: [email-masked]
Date: Wed, 29 Nov 2017 04:29:36 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IS-IS for IP Internets WG of the IETF.

        Title           : Signaling  MSD (Maximum SID Depth) using IS-IS
        Authors         : Jeff Tantsura
                          Uma Chunduri
                          Sam Aldrin
                          Les Ginsberg
	Filename        : draft-ietf-isis-segment-routing-msd-05.txt
	Pages           : 8
	Date            : 2017-11-29

Abstract:
   This document proposes a way to signal Maximum SID Depth (MSD)
   supported by a node at node and/or link granularity by an IS-IS
   Router.  In a Segment Routing (SR) enabled network a centralized
   controller that programs SR tunnels needs to know the MSD supported
   by the head-end at node and/or link granularity to impose the SID
   stack of an appropriate depth.  MSD is relevant to the head-end of a
   SR tunnel or Binding-SID anchor node where Binding-SID expansions
   might result in creation of a new SID stack.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-isis-segment-routing-msd/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-isis-segment-routing-msd-05
https://datatracker.ietf.org/doc/html/draft-ietf-isis-segment-routing-msd-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-isis-segment-routing-msd-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 29 Nov 2017 15:48:59 +0000

Jeff -

The editorial revisions to the IANA section in V5 of the document seem very confusing to me.

<snip>
This document includes a request to IANA to allocate sub-TLV type
   codes for the new sub TLV proposed in Section 3 of this document from
   IS-IS Router Capability TLV Registry as defined by [RFC7981].

   Following values have been allocated by IANA:

      Value     Description                      Reference
      -----     ---------------                  -------------
      23        Node MSD                         This document
      15        Link MSD                         This document

                            Figure 3: MSD Types

   For the Link MSD, we request IANA to allocate new sub-TLV codes as
   defined in Section 4 from Sub-TLVs for TLVs 22, 23, 141, 222 and 223
   registry.

   Per TLV information where LINK MSD sub-TLV can be part of:

                     TLV  22 23 25 141 222 223
                          --------------------
                          y  y  y  y   y   y

           Figure 4: TLVs where LINK MSD Sub-TLV can be present
<end snip>

The revisions make it seem like both code points are associated with the Router Capability TLV. 
Here is a suggested revision:

<begin>
This document includes a request to IANA to allocate a sub-TLV type
   code for the Node MSD sub TLV proposed in Section 3 of this document from
   IS-IS Router Capability TLV Registry as defined by [RFC7981].

   The following value has been allocated by IANA:

      Value     Description                      Reference
      -----     ---------------                  -------------
      23        Node MSD                         This document

   This document also includes a request to IANA to allocate a sub-TLV type code
  for the Link MSD sub-TLV proposed in Section 4 of this document from the
  Sub-TLVs for TLVs 22, 23, 141, 222 and 223  registry.

   The following value has been allocated by IANA:

      Value     Description                      Reference
      -----     ---------------                  -------------
      15        Link MSD                         This document

   Per TLV information where LINK MSD sub-TLV can be part of:

                     TLV  22 23 25 141 222 223
                          --------------------
                          y  y  y  y   y   y

           Figure 3: TLVs where LINK MSD Sub-TLV can be present

<end>

   Les

> -----Original Message-----
> From: Isis-wg [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Wednesday, November 29, 2017 4:30 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Isis-wg] I-D Action: draft-ietf-isis-segment-routing-msd-05.txt
> 
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 29 Nov 2017 08:02:38 -0800

Thanks Les, agreed, update on the way.

Cheers,
Jeff

-----Original Message-----
From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wednesday, November 29, 2017 at 07:49
To: "Jeff Tantsura ([email-masked])" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Isis-wg] I-D Action: draft-ietf-isis-segment-routing-msd-05.txt

    Jeff -

    <snip>

    
                                Figure 3: MSD Types

                         TLV  22 23 25 141 222 223
                              --------------------
                              y  y  y  y   y   y

    
    <begin>

    

                         TLV  22 23 25 141 222 223
                              --------------------
                              y  y  y  y   y   y

    <end>
    
       Les

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 29 Nov 2017 17:46:06 +0000

Thanx Jeff - Rev 6 looks good.

   Les

> From: Jeff Tantsura [mailto:[email-masked]]
> Sent: Wednesday, November 29, 2017 8:03 AM
> To: Les Ginsberg (ginsberg) <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Isis-wg] I-D Action: draft-ietf-isis-segment-routing-msd-05.txt
> 
>     > https://datatracker.ietf.org/doc/html/draft-ietf-isis-segment-routing-
> msd-
>     > 05
>     >