Subject: Re: [Isis-wg] 答复: WG Last Call for draft-ietf-isis-segment-routing-msd-07

From: Jeff Tantsura <[email-masked]>
Date: Wed, 20 Dec 2017 16:48:08 -0800

Xiaohu,

The applicability of *elc drafts is entropy labels, *msd drafts provide more generic way to advertise capabilities (initial focus on SID imposition AKA type 1), they are not mutually exclusive and provide different functionality. 

Cheers,
Jeff

-----Original Message-----
From: Xuxiaohu <[email-masked]>
Date: Wednesday, December 20, 2017 at 16:32
To: "Ketan Talaulikar (ketant)" <[email-masked]>, Christian Hopps <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: 答复: [Isis-wg] WG Last Call for draft-ietf-isis-segment-routing-msd-07
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Wed, 20 Dec 2017 16:32:52 -0800 (PST)

    As for the maximum label stack depth reading capability, it has been defined in https://tools.ietf.org/html/draft-ietf-ospf-mpls-elc and https://tools.ietf.org/html/draft-ietf-isis-mpls-elc. Once the WGLC for https://tools.ietf.org/html/draft-ietf-mpls-spring-entropy-label is finished, we will request the WGLC for the above two drafts.
    
    Best regards,
    Xiaohu
    
    > -----邮件原件-----
    > 发件人: Isis-wg [mailto:[email-masked]] 代表 Ketan Talaulikar (ketant)
    > 发送时间: 2017年12月20日 17:51
    > 收件人: Christian Hopps; [email-masked]
    > 抄送: [email-masked]; [email-masked]
    > 主题: Re: [Isis-wg] WG Last Call for draft-ietf-isis-segment-routing-msd-07
    > 
    > Hello,
    > 
    > I support this document and would like to ask the authors and WG to consider if
    > we can expand the scope of this draft to not just "imposition" of the SID stack
    > but also other similar limits related to other actions (e.g. reading, processing,
    > etc.). With Segment Routing, we are coming across various actions that nodes
    > need to do with the SID stack for different purposes and IMHO it would be
    > useful to extend the MSD ability to cover those as they arise.
    > 
    > Thanks,
    > Ketan
    > 
    > -----Original Message-----
    > From: Isis-wg [mailto:[email-masked]] On Behalf Of Christian Hopps
    > Sent: 20 December 2017 14:03
    > To: [email-masked]
    > Cc: [email-masked]; [email-masked]
    > Subject: [Isis-wg] WG Last Call for draft-ietf-isis-segment-routing-msd-07
    > 
    > 
    > The authors have asked for and we are starting a WG Last Call on
    > 
    >  https://datatracker.ietf.org/doc/draft-ietf-isis-segment-routing-msd/
    > 
    > which will last an extended 4 weeks to allow for year-end PTO patterns.
    > 
    > An IPR statement exists:
    > 
    > 
    > https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-isis-segment-
    > routing-msd
    > 
    > Authors please reply to the list indicating whether you are aware of any
    > *new* IPR.
    > 
    > Thanks,
    > Chris.
    > 
    > _______________________________________________
    > Isis-wg mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/isis-wg
    > 
    > _______________________________________________
    > Isis-wg mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 21 Dec 2017 01:31:14 +0000

Jeff,

It said in the draft that "
   ... In addition, in the cases where stacked LSPs are used for
   whatever reasons (e.g., SPRING-MPLS
   [I-D.ietf-spring-segment-routing-mpls]), it would be useful for
   ingress LSRs to know each LSR's capability of reading the maximum
   label stack depth. ..."

The RLD capability may be applicable in other scenarios than the EL-based load-balancing. It just happens that the EL-based load-balancing is the first concrete use case for that capability:)

Best regards,
Xiaohu

> -----邮件原件-----
> 发件人: Jeff Tantsura [mailto:[email-masked]]
> 发送时间: 2017年12月21日 8:48
> 收件人: Xuxiaohu; Ketan Talaulikar (ketant); Christian Hopps; [email-masked]
> 主题: Re: 答复: [Isis-wg] WG Last Call for draft-ietf-isis-segment-routing-msd-07
> 
> Xiaohu,
> 
> The applicability of *elc drafts is entropy labels, *msd drafts provide more
> generic way to advertise capabilities (initial focus on SID imposition AKA type 1),
> they are not mutually exclusive and provide different functionality.
> 
> Cheers,
> Jeff
> 
> To: "Ketan Talaulikar (ketant)" <[email-masked]>, Christian Hopps
> <[email-masked]>, "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>,
> "[email-masked]"
> <[email-masked]>
> Resent-To: <[email-masked]>, <[email-masked]>,
> <[email-masked]>, <[email-masked]>
>     As for the maximum label stack depth reading capability, it has been
> defined in https://tools.ietf.org/html/draft-ietf-ospf-mpls-elc and
> https://tools.ietf.org/html/draft-ietf-isis-mpls-elc. Once the WGLC for
> https://tools.ietf.org/html/draft-ietf-mpls-spring-entropy-label is finished, we
> will request the WGLC for the above two drafts.
> 
>     Best regards,
>     Xiaohu
> 
>     > -----邮件原件-----