Subject: [Isis-wg] TLV conflict

From: Harish R Prabhu <[email-masked]>
Date: Thu, 14 Dec 2017 20:11:11 +0530

While going through the I-Ds pertaining to SR attributes, it was found
that the following 2 TLVs have been assigned the same Type number

SRMS Preference Sub-TLV :
https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions-13#section-3.4

Node MSD Advertisement :
https://tools.ietf.org/html/draft-ietf-isis-segment-routing-msd-02#page-4

 Both these sections talk about different sub tlvs under
router_capabilities TLV, but type value assigned is 23 for both.

Request to address this.

Thanks,
--
Harish R Prabhu
Bangalore, India.
mailtp:[email-masked]

---

From: Alia Atlas <[email-masked]>
Date: Thu, 14 Dec 2017 10:00:31 -0500

Hi Harish,

Please take a look at
https://www.iana.org/assignments/isis-tlv-codepoints/isis-tlv-codepoints.xhtml#isis-tlv-codepoints-242
where it is clear that draft-ietf-isis-segment-routing-msd has an early
temporary registration for type 23.

draft-ietf-isis-segment-routing-msd-02 should be updated to clearly state
the IANA allocations that have already happened.

draft-ietf-isis-segment-routing-extensions-13 MUST be updated to clearly
state the IANA allocations
that have already happened for it (e.g. values 2 & 19) and to STOP
SQUATTING on already allocated
code-points.

Thank you for bringing this to our attention!

Regards,
Alia

On Thu, Dec 14, 2017 at 9:41 AM, Harish R Prabhu <[email-masked]>
wrote:

> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 14 Dec 2017 15:37:06 +0000

Folks –

The conflict for SRMS Preference sub-TLV in https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions-13#section-3.4 has already been noted and has been eliminated in the new version of the IS-IS SR draft which I expect to publish tomorrow. Note that although the IS-IS SR draft was given early allocation of some code points, a couple more sub-TLVs have been defined since then and these values have not yet been assigned by IANA. SRMS preference was one of them – though at the time of the writing of the version which added this the early allocation for MSD had not yet happened.

Alia - I believe the MSD draft already is using the code points which have been assigned by early allocation – so I do not know what further update you believe is required in that document.
???

   Les

From: Isis-wg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Thursday, December 14, 2017 7:01 AM
To: Harish R Prabhu <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Isis-wg] TLV conflict

Hi Harish,

Please take a look at
https://www.iana.org/assignments/isis-tlv-codepoints/isis-tlv-codepoints.xhtml#isis-tlv-codepoints-242
where it is clear that draft-ietf-isis-segment-routing-msd has an early temporary registration for type 23.

draft-ietf-isis-segment-routing-msd-02 should be updated to clearly state the IANA allocations that have already happened.

draft-ietf-isis-segment-routing-extensions-13 MUST be updated to clearly state the IANA allocations
that have already happened for it (e.g. values 2 & 19) and to STOP SQUATTING on already allocated
code-points.

Regards,
Alia

On Thu, Dec 14, 2017 at 9:41 AM, Harish R Prabhu <[email-masked]<mailto:[email-masked]>> wrote:
While going through the I-Ds pertaining to SR attributes, it was found
that the following 2 TLVs have been assigned the same Type number

Node MSD Advertisement :

Request to address this.

Thanks,
--
Harish R Prabhu
Bangalore, India.
mailtp:[email-masked]<mailto:[email-masked]>

_______________________________________________
Isis-wg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Alia Atlas <[email-masked]>
Date: Thu, 14 Dec 2017 11:10:54 -0500

Hi Les,

On Thu, Dec 14, 2017 at 10:37 AM, Les Ginsberg (ginsberg) <
[email-masked]> wrote:

> Folks –
>
>
>
>
>
> The conflict for SRMS Preference sub-TLV in https://tools.ietf.org/html/
> draft-ietf-isis-segment-routing-extensions-13#section-3.4 has already
> been noted and has been eliminated in the new version of the IS-IS SR draft
> which I expect to publish tomorrow. Note that although the IS-IS SR draft
> was given early allocation of some code points, a couple more sub-TLVs have
> been defined since then and these values have not yet been assigned by
> IANA. SRMS preference was one of them – though at the time of the writing
> of the version which added this the early allocation for MSD had not yet
> happened.
>

Fine - but this is the exact issue with having "suggested" values that
aren't allocated in drafts.
I am really not happy with such text.  I have been pushing and happy to
approve early allocations.

> Alia - I believe the MSD draft already is using the code points which have
> been assigned by early allocation – so I do not know what further update
> you believe is required in that document.
>
> ???
>

In the IANA section, it should refer to the values as allocated - not
suggested or potential.

>    Les
>
>
>
>
>
> *From:* Isis-wg [mailto:[email-masked]] *On Behalf Of *Alia
> Atlas
> *Sent:* Thursday, December 14, 2017 7:01 AM
> *To:* Harish R Prabhu <[email-masked]>
> *Cc:* [email-masked];
> [email-masked]; [email-masked]
> *Subject:* Re: [Isis-wg] TLV conflict
>
>
>
> Hi Harish,
>
>
>
> Please take a look at
>
> On Thu, Dec 14, 2017 at 9:41 AM, Harish R Prabhu <
> [email-masked]> wrote:
>

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 14 Dec 2017 19:47:42 +0000

Hi,

07 version of MSD draft published about 2 weeks ago states IANA allocations:

Following values have been allocated by IANA:
Value Description       Reference
----- --------------- -------------
23      Node MSD        This document

Value Description       Reference
----- --------------- -------------
15      Link MSD          This document

Hope this clarifies

Thanks,
Jeff
On Thu, Dec 14, 2017 at 08:11 Alia Atlas <[email-masked]> wrote:

>> The conflict for SRMS Preference sub-TLV in
>> has already been noted and has been eliminated in the new version of the
>> IS-IS SR draft which I expect to publish tomorrow. Note that although the
>> IS-IS SR draft was given early allocation of some code points, a couple
>> more sub-TLVs have been defined since then and these values have not yet
>> been assigned by IANA. SRMS preference was one of them – though at the time
>> of the writing of the version which added this the early allocation for MSD
>> had not yet happened.
>>
>
>> Alia - I believe the MSD draft already is using the code points which
>> have been assigned by early allocation – so I do not know what further
>> update you believe is required in that document.
>>
>> ???
>>
>

---

From: Alia Atlas <[email-masked]>
Date: Thu, 14 Dec 2017 14:50:09 -0500

Hi Jeff,

Thanks!  I was looking at the version that Harish mentioned - and didn't
verify that it was the most recent version.

On Thu, Dec 14, 2017 at 2:47 PM, Jeff Tantsura <[email-masked]>
wrote:

>>> draft-ietf-isis-segment-routing-msd-02 should be updated to clearly
>>> state the IANA allocations that have already happened.
>>>
>>>
>>>