Subject: Re: [Isis-wg] WG Last Call for draft-ietf-isis-segment-routing-msd-07

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 8 Jan 2018 08:13:06 +0000

Xiaohu -

Work on a revision to the MSD draft to make the names and text consistent with the goal that multiple types of "MSD" will be advertised using the same sub-TLV is in progress. Once authors have agreed on the changes you will see a new revision.

Can I assume that once this is done you are open to changing the mpls-elc drafts to use the more generic encoding for advertising RLD?

I think this is important to make judicious use of sub-TLV code points.
As written, https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-03 requires a distinct sub-TLV from the set of sub-TLVs defined for TLV 242 to advertise RLD. If this model were to be applied for other types of "MSD", I can foresee consumption of a significant number of sub-TLV codepoints just for all the flavors of "MSD". This is one reason we defined the generic MSD sub-TLV format in draft-ietf-isis-segment-routing-msd. A single sub-TLV can be used to advertise as many different MSD types as necessary.

There are also other benefits:

An IGP agnostic registry is defined to assign MSD types. This means the same type value can be used in OSPF, IS-IS, and in BGP-LS.

In IS-IS there is a small efficiency gain in that we do not have to advertise a length for each MSD type.

I look forward to feedback from you once the new revision of the MSD draft is published.

Thanx.

   Les

> -----Original Message-----
> From: Xuxiaohu [mailto:[email-masked]]
> Sent: Wednesday, December 20, 2017 6:40 PM
> To: Les Ginsberg (ginsberg) <[email-masked]>; Ketan Talaulikar (ketant)
> <[email-masked]>; Christian Hopps <[email-masked]>; isis-
> [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: 答复: [Isis-wg] WG Last Call for draft-ietf-isis-segment-routing-msd-
> 07
> 
> Hi Les,
> 
> If I understand it correctly, the MSD concept was originated from
> (https://tools.ietf.org/html/draft-ietf-pce-segment-routing-11#page-7) as
> described below:
> 
> "The "Maximum SID Depth" (1
>    octet) field (MSD) specifies the maximum number of SIDs (MPLS label
>    stack depth in the context of this document) that a PCC is capable of
>    imposing on a packet."
> 
> Before considering expanding the semantics of the MSD concept as defined
> in the above PCE-SR draft, how about first considering renaming the
> capability of imposing the maximum number of labels so as to eliminate
> possible confusions, e.g., Writable Label-stack Depth (WLD) as opposed to
> the Readable Label-stack Depth (RLD) as defined in
> (https://tools.ietf.org/html/draft-ietf-ospf-mpls-elc) and
> (https://tools.ietf.org/html/draft-ietf-isis-mpls-elc) ?
> 
> Best regards,
> Xiaohu
> 
> > -----邮件原件-----
> > 发件人: Isis-wg [mailto:[email-masked]] 代表 Les Ginsberg
> > (ginsberg)
> > 发送时间: 2017年12月21日 4:02
> > 收件人: Ketan Talaulikar (ketant); Christian Hopps; [email-masked]
> > 抄送: [email-masked]; [email-masked]
> > 主题: Re: [Isis-wg] WG Last Call for
> > draft-ietf-isis-segment-routing-msd-07
> >
> > Ketan -
> >
> > Thanx for the comments.
> > I think we do want to allow MSD support for values other than
> > imposition values. We will revise the text so we are not restricted to only
> imposition cases.
> >
> >   Les
> >
> >
> > > -----Original Message-----
> > > From: Ketan Talaulikar (ketant)
> > > Sent: Wednesday, December 20, 2017 1:51 AM
> > > To: Christian Hopps <[email-masked]>; [email-masked]
> > > Cc: [email-masked]; [email-masked]
> > > Subject: RE: [Isis-wg] WG Last Call for
> > > draft-ietf-isis-segment-routing-msd-07
> > >
> > > Hello,
> > >
> > > I support this document and would like to ask the authors and WG to
> > > consider if we can expand the scope of this draft to not just
> > > "imposition" of the SID stack but also other similar limits related
> > > to other
> > actions (e.g.
> > > reading, processing, etc.). With Segment Routing, we are coming
> > > across various actions that nodes need to do with the SID stack for
> > > different purposes and IMHO it would be useful to extend the MSD
> > > ability to cover those as they arise.
> > >
> > > Thanks,
> > > Ketan
> > >
> > > -----Original Message-----
> > > From: Isis-wg [mailto:[email-masked]] On Behalf Of
> > > Christian Hopps
> > > Sent: 20 December 2017 14:03
> > > To: [email-masked]
> > > Cc: [email-masked]; [email-masked]
> > > Subject: [Isis-wg] WG Last Call for
> > > draft-ietf-isis-segment-routing-msd-07
> > >
> > >
> > > The authors have asked for and we are starting a WG Last Call on
> > >
> > >
> > > https://datatracker.ietf.org/doc/draft-ietf-isis-segment-routing-msd
> > > /
> > >
> > > which will last an extended 4 weeks to allow for year-end PTO patterns.
> > >
> > > An IPR statement exists:
> > >
> > >
> > > https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-
> > > is
> > > is-
> > > segment-routing-msd
> > >
> > > Authors please reply to the list indicating whether you are aware of
> > > any
> > > *new* IPR.
> > >
> > > Thanks,
> > > Chris.
> > >
> > > _______________________________________________
> > > Isis-wg mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/isis-wg
> >
> > _______________________________________________
> > Isis-wg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 10 Jan 2018 18:44:56 +0000

Xiaohu -

V9 of the MSD draft has been posted with the promised changes.
Please review. I hope this leads to you revising https://datatracker.ietf.org/doc/draft-ietf-isis-mpls-elc/ to make use of the MSD sub-TLV to advertise RLD.

   Les

> From: Les Ginsberg (ginsberg)
> Sent: Monday, January 08, 2018 12:13 AM
> To: Xuxiaohu <[email-masked]>; Ketan Talaulikar (ketant)
> Subject: RE: [Isis-wg] WG Last Call for draft-ietf-isis-segment-routing-msd-07
> 
> Xiaohu -
> 
> Work on a revision to the MSD draft to make the names and text consistent
> with the goal that multiple types of "MSD" will be advertised using the same
> sub-TLV is in progress. Once authors have agreed on the changes you will see
> a new revision.
> 
> Can I assume that once this is done you are open to changing the mpls-elc
> drafts to use the more generic encoding for advertising RLD?
> 
> As written, https://tools.ietf.org/html/draft-ietf-isis-mpls-elc-03 requires a
> distinct sub-TLV from the set of sub-TLVs defined for TLV 242 to advertise
> RLD. If this model were to be applied for other types of "MSD", I can foresee
> consumption of a significant number of sub-TLV codepoints just for all the
> flavors of "MSD". This is one reason we defined the generic MSD sub-TLV
> format in draft-ietf-isis-segment-routing-msd. A single sub-TLV can be used
> to advertise as many different MSD types as necessary.
> 
> An IGP agnostic registry is defined to assign MSD types. This means the same
> type value can be used in OSPF, IS-IS, and in BGP-LS.
> 
> > To: Les Ginsberg (ginsberg) <[email-masked]>; Ketan Talaulikar
> > (ketant) <[email-masked]>; Christian Hopps <[email-masked]>;
> > isis- [email-masked]
> > (https://tools.ietf.org/html/draft-ietf-pce-segment-routing-11#page-7)
> > as described below:
> >
> > Before considering expanding the semantics of the MSD concept as
> > defined in the above PCE-SR draft, how about first considering
> > renaming the capability of imposing the maximum number of labels so as
> > to eliminate possible confusions, e.g., Writable Label-stack Depth
> > (WLD) as opposed to the Readable Label-stack Depth (RLD) as defined in
> > > > Cc: [email-masked];
> > > > [email-masked]
> > > > I support this document and would like to ask the authors and WG
> > > > to consider if we can expand the scope of this draft to not just
> > > > "imposition" of the SID stack but also other similar limits
> > > > related to other
> > > actions (e.g.
> > > > across various actions that nodes need to do with the SID stack
> > > > for different purposes and IMHO it would be useful to extend the
> > > > MSD ability to cover those as they arise.
> > > >
> > > > Thanks,
> > > > Ketan
> > > >
> > > > Cc: [email-masked];
> > > > [email-masked]
> > > > Authors please reply to the list indicating whether you are aware
> > > > of any
> > > > *new* IPR.
> > > >
> > > > Thanks,
> > > > Chris.
> > > >

---

From: Xiaohu <[email-masked]>
Date: Thu, 11 Jan 2018 08:35:24 +0800

Les，

Thanks for this email. I will review this doc and then determine how to update the ISIS-ELC and OSPF-ELC drafts according.

Xiaohu 

发自我的 iPhone

> 在 2018年1月11日，02:44，Les Ginsberg (ginsberg) <[email-masked]> 写道：
> 
> Xiaohu -
>