Subject: ISIS and BGP MED

From: Rajesh Saluja <[email-masked]>
Date: Mon, 05 Apr 1999 14:25:02 -0400

In the last IETF meeting, there were two proposals for
L1/L2 optimization. Both the proposals state that one of
the motivations behind L1/L2 optimization is to support
BGP MED when using ISIS as an IGP.  Can somebody
explain how is "BGP MED  support "an issue
if L2 routes are not propagated into L1 domain?

BGP MED is used by a BGP router to give some hint to the
peer about the IGP metric to reach a particular destination.
In case of ISIS, BGP router is going to be in L2 domain
only ( there can not be any ASBR in L1 domain of ISIS )
and L2 routers have the complete information about the
reachable networks.

The problem of incorrect or misleading IGP metric could come
with an L1 router but L1 only router can never be a BGP router.
Hence there is no issue.

Please correct me if I am missing something here.

Thanks,
Rajesh

---

From: Tony Li <[email-masked]>
Date: Mon, 5 Apr 1999 11:32:37 -0700 (PDT)

|  In the last IETF meeting, there were two proposals for
|  L1/L2 optimization. Both the proposals state that one of
|  the motivations behind L1/L2 optimization is to support
|  BGP MED when using ISIS as an IGP.  Can somebody
|  explain how is "BGP MED  support "an issue
|  if L2 routes are not propagated into L1 domain?

If L2 routes are not propagated into an L1 domain, then the EBGP speaker
does not have an accurate metric to the IBGP speaker on the other side of
the domain.  Instead, it would probably only have a default route pointing
into L2.

This would leave us filling the MED as being equal across all EBGP
speakers, which defeats the purpose of the MED in the first place.

|  In case of ISIS, BGP router is going to be in L2 domain
|  only ( there can not be any ASBR in L1 domain of ISIS )
|  and L2 routers have the complete information about the
|  reachable networks.

What's an ASBR?  ;-)

There's no reason to not have an EBGP speaker in L1.  I know of no reasons
to not support this and many millions of reasons ($$$) to support it.

Tony