Subject: RE: comment on 3-way handshake proposal

From: Andrew Smith <[email-masked]>
Date: Fri, 23 Jul 1999 10:40:19 -0700

Well, since we already seem to be redefining the link-layer in this WG
anyway, why not just build reliable transport into Ethernet too :-)

Andrew

> -----Original Message-----
> From: Dave Katz [mailto:[email-masked]]
> Sent: Friday, July 23, 1999 9:53 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: comment on 3-way handshake proposal
> 
> 
> An interesting catch--in all the years I've been looking at 
> this I never
> noticed that it does in fact seem to require a reliable data 
> link layer.
> 
> The amusing part is, of course, that *nobody* runs this over LAPB or
> 802.2/II (or even a simple sequencing protocol that would blow up if
> there was ever an unexpected sequence number, which would be
> sufficient), not even DEC in the old days, and that the requirement
> for a reliable data link is utter overkill for anything except the
> startup gotchas that are fixed here.
> 
> I'll give a nod to this issue in the abstract, though the 
> "requirement"
> has obviously been completely ignored because it is broken, and thus
> the protocol is still broken.  One thing I don't want to do is to give
> the impression that every implementation on the planet is broken for
> using the wrong subnetwork technology.
> 
> The "proper fix" would be to require 802.2/II but I don't think we
> want to go down that road...
> 
> --Dave
> 
>    X-Sender: [email-masked]
>    X-Mailer: Windows Eudora Pro Version 3.0.1 (32)
>    Date: Fri, 23 Jul 1999 12:35:18 -0400
>    From: Jeff Learman <[email-masked]>
>    Mime-Version: 1.0
>    Content-Type: text/plain; charset="us-ascii"
>    Sender: [email-masked]
>    Precedence: bulk
> 
> 
>    The three-way handshake proposal should point out that
>    all of the deficiencies result from failure to follow
>    6.7.2, Required subnetwork guarantees for point-to-point
>    links.
> 
>    Please correct me if I'm wrong, but I believe that the
>    problems identified in the proposal are all caused by
>    using Frame Relay or some other unreliable link protocol,
>    or else implementation problems whereby a router can
>    restart IS-IS without resetting the link connection.
> 
>    Of course, the three-way handshake proposal adds value
>    because it is great to be able to operate the protocol
>    over an efficient, unreliable link layer protocol.
> 
>    I recommend the following changes to the text for the Abstract,
>    from:
> 
>       The IS-IS routing protocol (ISO 10589) does not use a three-way
>       handshake when establishing adjacencies on point-to-point media.
>       This paper defines an backward-compatible extension to 
> the protocol
>       that provides for a three-way handshake.  It is fully 
> interoperable
>       with systems that do not support the extension.
> 
>    to:
> 
>       The IS-IS routing protocol requires reliable protocols 
> at the link
>       layer for point-to-point links.  As a result, it does 
> not use a three-
>       way handshake when establishing adjacencies on 
> point-to-point media.
>       This paper defines an backward-compatible extension to 
> the protocol
>       that provides for a three-way handshake, and permits IS-IS to be
>       operated over an unreliable link layer protocol such as 
> Frame Relay
>       or PPP.  It is fully interoperable with systems that do 
> not support
>       the extension.
> 
>    In addition, text should be added for edits to section 
> 6.7.2, indicating
>    the relaxed requirements for systems that implement the recommended
>    option.  I'm not sure just what these new relaxed requirements
>    should be.
> 
>    Regards,
>    Jeff
>    
> ____________________________________________________________________
> 
>      Jeff Learman                           Internet:     [email-masked]
>      Engineering Manager                    Voice:     (734)-975-7323
>      ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
>      2725 South Industrial Pkwy, Suite 100
>      Ann Arbor, MI  48104  USA
>    
> ____________________________________________________________________
>

---

From: Andrew Smith <[email-masked]>
Date: Fri, 23 Jul 1999 11:12:18 -0700

Although Ethernet is often used in point-to-point "WAN-like" deployments
these days ...

But the proposed wording is fine.

Andrew

> From: Radia Perlman - Boston Center for Networking
> [mailto:[email-masked]]
> Sent: Friday, July 23, 1999 10:27 AM
> To: [email-masked]
> The requirement for a reliable layer 2 protocol is ONLY for 
> point-to-point
> links. The IS-IS LAN stuff is designed to work over unreliable links.
> So there's no reason to worry about LLC type 2, since that's 
> only on LANs.
> 
> I like Jeff Learman's proposed wording change.
> 
> Radia
>