Subject: [Isis-wg] integrated is-is question

From: "He, James" <[email-masked]>
Date: Wed, 17 Nov 1999 14:41:22 -0500

To IS-IS fellows:

I was reading the book "CCIE Professional Development: Routing TCP/IP,
Volume 1" by Jeff Doyle from ciscopress. 
In the Integrated IS-IS chapter, there is an example which discusses IS-IS
adjacency issues. 
The following is the illustration from the book:

There are six L1/L2 routers in two areas, area1 and area2, and we assume
area2 is a level 2 area (IS-IS backbone).
The illustration is as follows:

Subnet1--------R1---------------Subnet2-------------R2------------Subnet3
		  |			           |
		  |			           |
		 R3                                        R4
		  |			           |	
 
|---------------------------------------------------------------------------
|
				|
				|
			           R5
				|
				|
	          Subnet4-------------R6------------Subnet5

The top section which consists of R1-R2-R3-R4 is area1 and the lower section
which has R5-R6 constitutes area2.
All routers are L1/L2 routers (the default configguration in cisco routers).

On page 655 of the book,  it says that R6 will form level 1 adjacency with
R5 as R5 is the only router in area2. 
However, R6 will form level 2 adjacency with every other router including R1
to R4.  

Is this statement true? R6 is not physically connected to R1 or R2. How can
it form level 2 adjacenct to them.
Why can't R6 be level 1 adjacenct to R1 if we adopt the same logic.  

Many thanks in advance. Please forward answer to [email-masked].

James He

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Henk Smit <[email-masked]>
Date: Wed, 17 Nov 1999 21:45:19 +0100 (MET)

> Volume 1" by Jeff Doyle from ciscopress.

  Maybe ask the author ?

> area2 is a level 2 area (IS-IS backbone).

  I don't think that sentence is correct.
 Areas are level-1 thingies.
 Level-2 is the backbone, and consists of "Level-2 capable routers".
 All routers have an area-address, and thus all routers are part of
 a level-1 area.

  The algorithms (SPF and flooding) that are used in Level-2 are very
 similar to what is used in Level-1. Therefor we can sometimes talk
 about "the level-2 backbone area". That would refer to the set of
 "level-2 capable routers".

   But you can not say that one R1, R2, R3 and R4 are in one area,
 and say that R5 and R6 are in another area, and call that area
 the "level-2 area".

  Hope I could explain this to you.

> Subnet1--------R1---------------Subnet2-------------R2------------Subnet3

  In this case, all 6 routers take part in Level-2 routing, and thus the
 "backbone" or "level-2 area" consists of all 6 routers.

> Is this statement true?

  No.

> R6 is not physically connected to R1 or R2. How can

  Exactly. Only directly connected routers can form adjacencies.

> Why can't R6 be level 1 adjacenct to R1 if we adopt the same logic.  

  Well, R1 and R6 are in different areas. They are configured to be in
 different areas. So they will never form a level-1 adjacency. Routers
 are only allowed to form level-1 adjacencies when they have at least
 one configured area-address in common.

  So in the above picture, these adjacencies are formed:

       R1    R2    R3    R4    R5    R6
  R1   -     L1L2  L1L2  -     -     -
  R2   L1L2  -     -     L1L2  -     -
  R3   L1L2  -     -     L1L2  L2    -
  R4   -     L1L2  L1L2  -     L2    -
  R5   -     -     L2    L2    -     L1L2
  R6   -     -     -     -     L1L2  -

  For a good design, if the above picture would be the full
 network, it would probably make sense to configure R1, R2
 and R6 to be level-1-only routers.

     Hope this helps,

        Henk.