Subject: Re: [Isis-wg] New version of draft-ietf-isis-domain-wide-02.txt

From: [email-masked] (Christian E. Hopps)
Date: 27 Nov 1999 13:31:12 -0500

Henk Smit <[email-masked]> writes:

>   Here is the new draft for route-leaking with old-style TLVs.
[...]
>    Based on these assumptions, this document defines the following route
>    preferences.
> 
>     1) L1 intra-area routes with internal metric
>        L1 external routes with internal metric
>     2) L2 intra-area routes with internal metric
>        L2 external routes with internal metric
>        L1->L2 inter-area routes with internal metric
>        L1->L2 inter-area external routes with internal metric
>     3) L2->L1 inter-area routes with internal metric
>        L2->L1 inter-area external routes with internal metric
>     4) L1 external routes with external metric
>     5) L2 external routes with external metric
>        L1->L2 inter-area external routes with external metric
>     6) L2->L1 inter-area external routes with external metric

I believe that currently the draft doesn't specify how to leak routes
derived from both types of reachability.  Since the reachability doesn't 
play a part in route selection this could conceivably happen.

This is not described in rfc 1195 because level 1 wasn't defined to have 
external reachability and level 2 didn't leak into level 1.

I think a perfectly reasonable action would be to always choose internal
(i.e., TLV 128) if the route was derived in full or in part from a TLV
128 prefix.

Does this sound reasonable?

Thanks,
Chris.

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Henk Smit <[email-masked]>
Date: Mon, 29 Nov 1999 17:02:37 +0100 (MET)

> Does this sound reasonable?

  Yes, this sounds reasonable.
 I will add some text to describe this.

  Note, if you see the same prefixes as both internal and external,
 your network already seems to be experiencing redistribution feedback.
 Not a good thing to begin with.

     Henk.