Subject: RE: [Isis-wg] comment on draft-parker-short-isis-hold-times-00.tx t

From: Les Ginsberg <[email-masked]>
Date: Tue, 27 Feb 2001 17:47:19 -0800

The requirements seem to me to actually be more complex than that. Not only
do you have to track when you sent/received data, but also presumably the
protocol i.e. it has to be the protocol(s) IS-IS is supporting - assuming
you still care about CLNP at all. Further, if the IS-IS engine crashes on
one end but the forwarding plane keeps working, then the adjacency is
maintained until the much slower hello timer expires - which means you don't
have fast detection any more.

This linkage of control and data plane seems conceptually flawed. It is
certainly ugly to implement in a distributed architecture - and not all that
wonderful in a non-distributed architecture.

There must be better ways to solve this problem than adding this baggage to
the forwarding plane.

   Les

> -----Original Message-----
> From: Jeff Learman [mailto:[email-masked]]
> Sent: Tuesday, February 27, 2001 3:08 PM
> To: Radia Perlman - Boston Center for Networking
> Cc: [email-masked]
> Subject: Re: [Isis-wg] comment on
> draft-parker-short-isis-hold-times-00.txt
> 
> 
> 
> Perhaps I'm missing something, but ...
> 
> >So to implement this: need an option in the Hello to say "I'm cool
> >with receipt of data messages instead of Hellos". If your neighbor
> >says that, then you don't have to send hellos in a timely way if
> >you're sending traffic.
> 
>   ... you don't have to send hellos in a timely way if you're sending
>   traffic *via that adjacency*.  So you'd need to
>   keep a new timer per adjacency of when you last sent data, and send
>   a Hello (either to that adjacency, or a broadcast) on timeout.
>   [Sorry, I don't remember whether the original proposal indicated
>   whether the hellos were direct or broadcast.]
> 
> Is that what you mean?
> 
> Thanks,
> Jeff
> 
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg
> 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: mike shand <[email-masked]>
Date: Wed, 28 Feb 2001 11:05:48 +0000

I agree. This worked very well in DECnet PhaseIV, but it may be somewhat 
ugly in modern system architectures.

However can it be done by accessing the counter which the forwarding plane 
presumably already keeps for "management" purposes? I guess that depends on 
whether the counter can be polled every few hundred milliseconds.

         Mike