Subject: RE: [Isis-wg] Question about a ISIS MIB variable

From: Jeff Parker <[email-masked]>
Date: Thu, 15 Feb 2001 09:04:06 -0500

>     isisCircOutCtrlPDUs OBJECT-TYPE
>         SYNTAX Counter32
>         MAX-ACCESS read-only
>         STATUS current
>         DESCRIPTION
>           "The number of IS-IS control PDUs sent on this circuit."
>              REFERENCE "{ISIS.aoi iSISControlPDUsSent (43)}"
>          ::= { isisCircEntry 17 }
> 
> What exactly in the isis protocol make up the control PDUs ? Are they
> CSNP, PSNP and the Hello PDUs ? 
> 
> Does control PDUs include the LSPs too but I think LSP would be mostly
> categorized as data PDUs ?
> 
> -Radhika

Radhika -
	Good question.  I would argue that user traffic makes up the Data
PDUs, and the control traffic is what is used to control the forwarding.  

The reference is circular...

iSISControlPDUsReceived ATTRIBUTE
   DERIVED FROM "Rec. X.723 | ISO/IEC 10165-5":nonWrappingCounter;
   BEHAVIOUR iSISControlPDUsReceived-B BEHAVIOUR
     DEFINED AS Number of control PDUs received on this circuit;;
   REGISTERED AS {ISIS.aoi iSISControlPDUsReceived (44)};

But there is a reference in 7.4.4 that says 

	"Control traffic (LSPs, Sequence Numbers PDUs)...."

which would indicate everything except the Hellos.  

	This clearly need clarification, and perhaps modification.  
I would prefer to see more counters: in the past, I have found 
it helpful to see explicit packet protocol counts for the levels.  
The counters above would not help: if the Rx count is zero, is it because

	o No Hellos have been seen?
	o I've seen hellos, but we couldn't agree on an area or password?

Further, the levels are mashed together, making it hard to debug
problems where the protocol is working at one level but not the other.

I could
	a) clarify what is being described by these counters, or
	b) split into two sets of counters for the levels,
	c) split into 4 set of counters for hello, LSP, CSNP, and PSNP,
	d) split into Hello and control,
	e) some combination of these

Any comments from the list?  I would vote for c) & b).  

- jeff parker
- axiowave networks
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Serge Maskalik <[email-masked]>
Date: Thu, 15 Feb 2001 10:32:45 -0800

> Any comments from the list?  I would vote for c) & b).  

   I agree, it would be useful to see counters at level and 
  PDU type granularity. 

	- Serge