Subject: [Isis-wg] improper LSP no. Sequence

From: "Sivakumar A" <[email-masked]>
Date: Mon, 28 May 2001 17:38:16 +0530

Hello all,

all IS adjacencies should preceed ES adjacencies according to ISO 10589. if  an LSP with LSP no. 5 containing all ES adjacencies is received and later  LSP no. 8 with IS adjacencies is received, should an implementation discard this LSP(no. 8) or the Complete set of LSP's received by this source (i.e LSP no.0, 5, 8 ). any help regarding this is appretiated

Thanks in advance

sivakumar A

 
Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com

---

From: Henk Smit <[email-masked]>
Date: Tue, 29 May 2001 12:00:02 -0700 (PDT)

> all IS adjacencies should preceed ES adjacencies according to ISO 10589. if  an LSP with LSP no. 5 containing all ES adjacencies is received and later  LSP no. 8 with IS adjacencies is received, sh…

  This is an IETF WG. The most important rule in IETF protocols has
 always been:

   "Be strict in what you send, be liberal in what you accept".

  So, *IMHO*, you should never drop an LSP because it does the ordering
 of TLVs in the wrong way. As Mike Shand has explained, the ordering
 of IS TLVs at the beginning of an LSP (or set of LSP fragments), and
 ES TLVs at the end of an LSP (or set of LSP fragments), is a way to
 optimize and prevent unnecessary fragment changes. This is an optimization
 to try to minimize the amount of LSP fragments being flooded. There
 are no substantial reasons why you shouldn't accept those LSP fragments.
 Nothing in the routing will break if you do. So *IMHO* you should
 build your implementation in such a way that it will accept those
 LSPs, even if they don't have the TLVs in the right order.

  Hope this helps,

     henk.

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: mike shand <[email-masked]>
Date: Wed, 30 May 2001 08:42:25 +0100

At 12:00 29/05/2001 -0700, Henk Smit wrote:

> > all IS adjacencies should preceed ES adjacencies according to ISO 
> 10589. if  an LSP with LSP no. 5 containing all ES adjacencies is 
> received and later  LSP no. 8 with IS adjacencies is received, should an 
> implementation discard this LSP(no. 8) or the Complete set of LSP's 
> received by this source (i.e LSP no.0, 5, 8 ). any help regarding this is 
> appretiated
>

No need to be humble about it Henk :-) You should definitely accept those LSPs.

         Mike