Subject: [Isis-wg] interaction with other IGP

From: "Sachidananda K" <[email-masked]>
Date: Wed, 14 Nov 2001 11:40:09 +0000

Hello,

I'm not very familiar with ISIS. I have some doubts on dual ISIS.
If an intermediate system running other IGP (like ISOF, RIP) along with 
ISIS, receive a new route from the other routing protocols, then how do we 
advertise this routes to adjacent ISIS system.
Do we advertise them at all or not?
If we do how frequently and how?

Please clarify my doubts.

Thanking you in advance for all responses.
Sachi.

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Wed, 14 Nov 2001 08:31:41 -0500

There may be practical answers that contradict this, but the
academic answer is that you use only one routing protocol as
your IGP in a routing domain.  That's part of what makes it
a routing domain -- consistent routing policy & protocol.

There are likely to be a lot of exceptions that will work,
especially stub networks.  I would be very hesitant to use
any other IGP to represent a transit subnetwork (a path between
two parts of the area/domain that use IS-IS).

Regards,
Jeff

At 06:40 AM 11/14/2001, Sachidananda K wrote:
>If an intermediate system running other IGP (like ISOF, RIP) along with ISIS, receive a new route from the other routing protocols, then how do we advertise this routes to adjacent ISIS system.