Subject: [Isis-wg] Doubts on SPF execution on DUAL ISIS

From: "Sachidananda K" <[email-masked]>
Date: Mon, 12 Nov 2001 06:49:34 +0000

Hello,

In a dual ISIS implementation, is it required to execute the SPF algorithm 
twice (once for IP network topology and second for OSI network topolgy)? Or 
should it be executed without taking into consideration the protocol 
supported?

Although, I was told that this is very much specific to implementation, I 
would like to bring out the example and get myself clarified.

This question arised to me basically for the below example.

+--+	2	+--+	3      +--+
|c |------------| b|-----------| a |
+--+		+--+	       +-- +
  \			      /
   \	8		     / 4
    \			    /
   +---+	7	+---+
   | d | ---------------| e |
   +---+		+---+

If IS 'c', 'd', and 'e' are IP enabled and 'b' and 'a' are OSI only. If we 
donot consider the protocol supported then from 'c' to 'e' we have the route 
that doesnot suport IP at all. Therefore, with this for 'c', destination 'e' 
is not reachable in IP topology. Whereas there exists the route via 'd' 
(though expensive).

Please clarify me in this regards.
Thanks in advance.

Sachi.

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Mon, 12 Nov 2001 01:07:18 -0800

]Hello,
 ]
 ]In a dual ISIS implementation, is it required to execute the SPF algorithm 
 ]twice (once for IP network topology and second for OSI network topolgy)? Or 
 ]should it be executed without taking into consideration the protocol 
 ]supported?
 ]
 ]Although, I was told that this is very much specific to implementation, I 
 ]would like to bring out the example and get myself clarified.

yes, it's an implementation issue.

but regardless of running spf once or 10 times in this case, the
algorithm should not put an IP-only router onto the TENT while
using an OSI-only router as its nexthop.

also, mix clns and ip like this in the network is asking for trouble.
according to rfc1195, all the links of a router should announce the
identical set of NLPIDs. if not, routing loop may be formed.
a simple example:

                             2(clns)
          1              -------------
  A(ip) ----- B(ip,clns)               C(ip,clns)
  |                      ------------- |
  |                         25(ip)     |
  |                                    |
  +------------------------------------+
             12(ip)

  B has two parallel links to C, one has cost of 2 for clns circuit, the
  other has cost of 25 for ip only circuit.

  To reach C: A knows the cost is 3 (it does not know that link of 2
  is for clns only); B knows its 13. then the routing loop to reach C:

  A -> B -> C
  B -> A -> C

there must be some reason people want to try M-ISIS :-)

- Naiming

 ]
 ]This question arised to me basically for the below example.
 ]
 ]+--+	2	+--+	3      +--+
 ]|c |----------| b|-----------|a |
 ]+--+		+--+	       +--+
 ]  \			      /
 ]   \	8		     / 4
 ]    \			    /
 ]   +---+	7	+---+
 ]   | d | -------------| e |
 ]   +---+		+---+
 ]
 ]
 ]If IS 'c', 'd', and 'e' are IP enabled and 'b' and 'a' are OSI only. If we 
 ]donot consider the protocol supported then from 'c' to 'e' we have the route 
 ]that doesnot suport IP at all. Therefore, with this for 'c', destination 'e' 
 ]is not reachable in IP topology. Whereas there exists the route via 'd' 
 ](though expensive).
 ]
 ]Please clarify me in this regards.
 ]Thanks in advance.
 ]
 ]Sachi.
 ]
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg