Subject: FW: [Isis-wg] Overload & Attached bits

From: Nagasta Bagamba <[email-masked]>
Date: Wed, 14 Nov 2001 00:53:17 -0800 (PST)

Hello Erez and WG,
I want to make some comments about the 2 first issues
you brought up.

1. Can a router have both bits set at the same time?

I understand you agree the answer for that is Yes.
But, I know of at least one major vendor which doesn't
allow to set this 2 bits at the same time. The reason
for that is a kind of a mystery to me...
Does anyone have an idea what the reason for that may
be?

2. Should we consider overloaded routers in our search
for the nearest attached level-2 intermediate system?

You decided that the answer is No. But, I know of at
least 2 major vendors which consider overloaded
routers in the search for the nearest attached level-2
IS.
If vendors-mixture ISIS topology will be built,
routing loops may occure. Does anyone have an idea how
to avoid routing loops in such a topology?

10x,
Nagasta

__________________________________________________
Do You Yahoo!?
Find the one for you at Yahoo! Personals
http://personals.yahoo.com
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Erik Hietbrink <[email-masked]>
Date: Wed, 14 Nov 2001 20:25:53 +0100

> to avoid routing loops in such a topology?

Hi,

ISO10589-2001, section 9.8, says about the Overload bit:
"An LSP with this bit set will not be used by any decision process to
calculate routes to another IS through the originating system".

I would interpret this statement so that no default level 2 IS
route may be calculated to an IS with the overload bit set.

Regards,
Erik

---

From: Naiming Shen <[email-masked]>
Date: Wed, 14 Nov 2001 12:14:51 -0800

I would try to avoid picking the router with OL bit set if there are
multiple gateways available. But if all the L2/L1 gateways have the OL
bit set, then pick them anyway and send default traffic to them. Since
if not, those traffic will be dropped on the local L1 routers. Often
the OL bit these days indicate the BGP is not converged yet, at least
a subset of the traffic can still be delivered through the gateways
which is better than drop all of them. In the old days, routing and
forwarding compete for the same resource on routers, so doing the above
suggestion would not be a good behaviour, its hardly this case now.

 ]Nagasta Bagamba wrote:
 ]> 
 ]> 2. Should we consider overloaded routers in our search
 ]> for the nearest attached level-2 intermediate system?
 ]> 
 ]> You decided that the answer is No. But, I know of at
 ]> least 2 major vendors which consider overloaded
 ]> routers in the search for the nearest attached level-2
 ]> IS.
 ]> If vendors-mixture ISIS topology will be built,
 ]> routing loops may occure. Does anyone have an idea how
 ]> to avoid routing loops in such a topology?
 ]
 ]Hi,
 ]
 ]ISO10589-2001, section 9.8, says about the Overload bit:
 ]"An LSP with this bit set will not be used by any decision process to
 ]calculate routes to another IS through the originating system".
 ]
 ]I would interpret this statement so that no default level 2 IS
 ]route may be calculated to an IS with the overload bit set.
 ]
 ]Regards,
 ]Erik
 ]_______________________________________________
 ]Isis-wg mailing list  -  [email-masked]
 ]http://external.juniper.net/mailman/listinfo/isis-wg

- Naiming

---

From: Alan Hannan <[email-masked]>
Date: Wed, 14 Nov 2001 15:32:06 -0600

FWIW, in ISP routing topology design, often times a box with the
  IS-IS OL-bit set is used for carrying traffic.

  There are two situtaions where this occurs, and they are usually
  both where the router in question is used as part of an auxilliary or
  out-of-band networks.

  The first is where the router in question is used only as a gateway of last
  resort for certain kinds of traffic, with a default route back towards the 
  NMS or NOC area, only for the purpose of carrying a subset of
  traffic.  Note that typically this router is not meant to carry
  production traffic.

  The second is where the router in question is using other routing
  protocols to carry certain types of traffic/destinations.  i.e.
  Ships in the Night kind of stuff.  Also, this router is not meant to
  carry production traffic in this context, rather stats and
  management traffic (telnet to boxes, SNMP, etc..).

  I assert that common ISP usage of IS-IS OL-bit does not comply with
  ISO10589-2001, section 9.8, yet it does comply with the wording if
  the phrase "any decision process' is changed to 'the IS-IS routing
  algorithm".

  -alan

Thus spake Naiming Shen ([email-masked])

---

From: Naiming Shen <[email-masked]>
Date: Wed, 14 Nov 2001 15:18:52 -0800

Hi, Alan,
	Great to hear all the 10589 "vialations":-)
	I had personal experience of the similar vialation: routerA
and routerB were in a webfarm connected by GigEs running IS-IS, and
each had a OCx link to the backbone. It was nice to set OL bit on
both routerA and routerB so that those two routers didn't carry
transit traffic through the webfarm. My previous posting just
responded to the case when OL and ATT bits are both set in a L1 area.

 ]
 ]  FWIW, in ISP routing topology design, often times a box with the
 ]  IS-IS OL-bit set is used for carrying traffic.
 ]
 ]  There are two situtaions where this occurs, and they are usually
 ]  both where the router in question is used as part of an auxilliary or
 ]  out-of-band networks.
 ]
 ]  The first is where the router in question is used only as a gateway of last
 ]  resort for certain kinds of traffic, with a default route back towards the 
 ]  NMS or NOC area, only for the purpose of carrying a subset of
 ]  traffic.  Note that typically this router is not meant to carry
 ]  production traffic.
 ]
 ]  The second is where the router in question is using other routing
 ]  protocols to carry certain types of traffic/destinations.  i.e.
 ]  Ships in the Night kind of stuff.  Also, this router is not meant to
 ]  carry production traffic in this context, rather stats and
 ]  management traffic (telnet to boxes, SNMP, etc..).
 ]
 ]  I assert that common ISP usage of IS-IS OL-bit does not comply with
 ]  ISO10589-2001, section 9.8, yet it does comply with the wording if
 ]  the phrase "any decision process' is changed to 'the IS-IS routing
 ]  algorithm".
 ]
 ]  -alan
 ]
 ]Thus spake Naiming Shen ([email-masked])
 ] on or about Wed, Nov 14, 2001 at 12:14:51PM -0800:
 ]> 
 ]> I would try to avoid picking the router with OL bit set if there are
 ]> multiple gateways available. But if all the L2/L1 gateways have the OL
 ]> bit set, then pick them anyway and send default traffic to them. Since
 ]> if not, those traffic will be dropped on the local L1 routers. Often
 ]> the OL bit these days indicate the BGP is not converged yet, at least
 ]> a subset of the traffic can still be delivered through the gateways
 ]> which is better than drop all of them. In the old days, routing and
 ]> forwarding compete for the same resource on routers, so doing the above
 ]> suggestion would not be a good behaviour, its hardly this case now.
 ]> 
 ]>  ]Nagasta Bagamba wrote:
 ]>  ]> 
 ]>  ]> 2. Should we consider overloaded routers in our search
 ]>  ]> for the nearest attached level-2 intermediate system?
 ]>  ]> You decided that the answer is No. But, I know of at
 ]>  ]> least 2 major vendors which consider overloaded
 ]>  ]> routers in the search for the nearest attached level-2
 ]>  ]> IS.
 ]>  ]> If vendors-mixture ISIS topology will be built,
 ]>  ]> routing loops may occure. Does anyone have an idea how
 ]>  ]> to avoid routing loops in such a topology?
 ]>  ]
 ]>  ]Hi,
 ]>  ]
 ]>  ]ISO10589-2001, section 9.8, says about the Overload bit:
 ]>  ]"An LSP with this bit set will not be used by any decision process to
 ]>  ]calculate routes to another IS through the originating system".
 ]>  ]
 ]>  ]I would interpret this statement so that no default level 2 IS
 ]>  ]route may be calculated to an IS with the overload bit set.
 ]>  ]
 ]>  ]Regards,
 ]>  ]Erik
 ]>  ]_______________________________________________
 ]>  ]Isis-wg mailing list  -  [email-masked]
 ]>  ]http://external.juniper.net/mailman/listinfo/isis-wg
 ]> 
 ]> - Naiming
 ]> _______________________________________________
 ]> Isis-wg mailing list  -  [email-masked]
 ]> http://external.juniper.net/mailman/listinfo/isis-wg

- Naiming