Subject: [Isis-wg] IGP shortcuts

From: Nagasta Bagamba <[email-masked]>
Date: Thu, 27 Dec 2001 13:41:38 -0800 (PST)

Hi,

I have some wonders about several issues in the draft
"draft-hsmit-mpls-igp-spf-00.txt".

1. In secrion 6.1: "The relative metric is bounded by
minimum and maximum allowed metric values" 
Is there any use for maximum value higher than 1?
As I see it, any positive relative metric causes the
TE-tunnel not to be used by the IGP, so there is no
need for more than one positive value.

2. In section 4: "Traffic to nodes that are downstream
of the tail-end nodes will also flow over those
TE-tunnels"
I find the word "downstream" a little bit problematic.
It can be downstream to the node on the SPF tree OR
downstream to the node on the IGP topology graph.
I think it refers to the SPF tree, but is there any
prevention from using TE-tunnels, as shortcuts, on the

IGP topology graph instead of on the SPF tree? It
looks like it will give more functionality and meaning
to the word "shortcuts". Of course we have to be
careful form routing loops, but with some basic rules
it is possible... :)

Regards,
Nagi

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Fri, 28 Dec 2001 11:42:41 -0800

]Hi,
 ]
 ]I have some wonders about several issues in the draft
 ]"draft-hsmit-mpls-igp-spf-00.txt".
 ]
 ]1. In secrion 6.1: "The relative metric is bounded by
 ]minimum and maximum allowed metric values" 
 ]Is there any use for maximum value higher than 1?
 ]As I see it, any positive relative metric causes the
 ]TE-tunnel not to be used by the IGP, so there is no
 ]need for more than one positive value.

yes, it is not useful for relative metric > +1 if the igp
load sharing scheme is equal-cost.

but there is no need to restrict it as long as you know it will not
be used. if a paricular native path has metric of 10, and you set
absolute metric to 15, assume the native path does not change,
it's equivalent to setting the relative metric to +5 here.

 ]
 ]2. In section 4: "Traffic to nodes that are downstream
 ]of the tail-end nodes will also flow over those
 ]TE-tunnels"
 ]I find the word "downstream" a little bit problematic.
 ]It can be downstream to the node on the SPF tree OR
 ]downstream to the node on the IGP topology graph.
 ]I think it refers to the SPF tree, but is there any
 ]prevention from using TE-tunnels, as shortcuts, on the
 ]
 ]IGP topology graph instead of on the SPF tree? It
 ]looks like it will give more functionality and meaning
 ]to the word "shortcuts". Of course we have to be
 ]careful form routing loops, but with some basic rules
 ]it is possible... :)

i can't parse your sentence here, what is "downstream to SPF"
vs "downstream to IGP topology graph"?
how can you "form routing loops"? can you give an example
which actually causes routing loops?

- Naiming

---

From: Nagasta Bagamba <[email-masked]>
Date: Sat, 29 Dec 2001 13:24:54 -0800 (PST)

Hi,

I'm sorry, my second question wasn't clear enough.
I'll try to explain my question through examples.
There are 3 ways to use TE-tunnels as shortcuts. I'll
explain each one of them through examples. 
Topology A will be used for introducing case 1. This
case refers just to the nodes (ISs) in the topology,
not to the leafs (IPs).
Topology B will be used for introducing cases 2 and 3.
Those cases refers especially to the leafs (IPs) of
the tree.

Topology A:
      
      10
    A----B
  9 |    | 10
    C----D
      10

  TE-tunnel from A to B, relative -5.
  Source node - A.
  SPT (without TE-tunnels):
        A
    10 / \ 9
      B  C
         | 10
         D

Case 1: Using TE-tunnels as IGP links
If we use TE-tunnels after building the SPF tree, we
will get:
        A
     5 / \ 9
      B  C
         | 10
         D

But, if we look at the TE-tunnel as a link with cost 5
(10-5), and use it through the build of the SPT, we'll
get:

        A
     5 / \ 9
      B  C
   10 |
      D

Topology B:
      
      A
  10 / \ 9
    /   \
   B----C
     10

  TE-tunnel from A to B, relative -5.
  Source node - A.
  There is network X between B and C.
  SPT (without TE-tunnels):
        A
    10 / \ 9
      B  C
         | 10
         X
  
Case 2: Use TE-tunnels after building the nodes (ISs)
of the SPF tree, but before adding the leafs (IP
reachability).
The result:

        A
     5 / \ 9
      B  C
   10 |
      X

Case 3: Use TE-tunnels after building the whole SPF
tree (nodes and leafs).
The result:

        A
     5 / \ 9
      B  C
         | 10
         X

Case 3 is routing-loop-free.
Cases 1 and 2 can create routing-loops. To avoid it,
we must not allow negative links in the graph (it
seems impossible with the absolute metric type).

My question is - which of the above cases is the one
the draft refers to?

Nagi