Subject: [Isis-wg] IIHs Optional TLV

From: "Sachidananda K" <[email-masked]>
Date: Sat, 01 Dec 2001 10:08:50 +0000

Hi,

I have a doubt regarding the nubmer of times the below mentioned TLVs can 
appear in the IIH PDUs.
1. Area Address TLVs.
2. IP interface TLVs.
3. Protocol Supported TLVs.

Does the standard impose any restriction on the number of times these TLVs 
can appear in a IIH (LAN or P2P).

Pls help me understand ISIS better.
Thanking you in advance.
Sachi

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Sat, 1 Dec 2001 18:43:40 +0100

On Sat, Dec 01, 2001 at 10:08:50AM +0000, Sachidananda K wrote:
| Hi,
| 
| I have a doubt regarding the nubmer of times the below mentioned TLVs can 
| appear in the IIH PDUs.
| 1. Area Address TLVs.
| 2. IP interface TLVs.
| 3. Protocol Supported TLVs.
| 
| Does the standard impose any restriction on the number of times these TLVs 
| can appear in a IIH (LAN or P2P).

sachi, 

as long the number of total areas does not contratict the number of
areas in the is-is commmon header TLV #1 can occur more than one
time;

the IP interface TLV and the protcols supported TLV can occur also
several times;

however, practically speaking the most-common implementations support
upto three areas. given the max. NSAP size of 20 bytes and
assuming that the sys-len = 6 bytes there
are upto 13 bytes to carry; an additional byte is needed
for the area-adress length field; so this results in 
14*3 = 42 bytes which fit quite easily into a single TLV;

most systems today support IPv4 routing, some of them support additionally
IPv6; so the typical prot.supported TLV is filled with 2 bytes - again no
need for several occurences of TLV #129;

given that you do not have more than 21 IP adresses configured
on your physical interface you mostly find also just one occurence of
TLV #132;

/hannes

| Pls help me understand ISIS better.
| Thanking you in advance.
| Sachi
| 
| _________________________________________________________________
| Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
| 
| _______________________________________________
| Isis-wg mailing list  -  [email-masked]
| http://external.juniper.net/mailman/listinfo/isis-wg
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg