Subject: [Isis-wg] (no subject)

From: "aridaman kaushik" <[email-masked]>
Date: 4 Dec 2001 12:20:11 -0000

hi all,
    I hope, anyone would clarify my doubt regarding ipv6 route prefernece in isis.
in draft draft-isis-ipv6-02.txt, route preference is given like this(from best to worst).

1. level1  up
2. level2  up
3. level2  down
4. level1   down

What is meaning of up/down here.
we can assume that level2 down means l2 to l1 leaked route. but what is the meaning of l1 down
thanks in advance
ari

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 4 Dec 2001 09:09:15 -0500

> 1. level1  up
> 2. level2  up
> 3. level2  down
> 4. level1   down
> 
> What ... is the meaning of l1 down[?]

Take a look at RFC 2966, 
http://www.ietf.org/rfc/rfc2966.txt

- jeff parker
- axiowave networks

---

From: Jeff Parker <[email-masked]>
Date: Wed, 5 Dec 2001 10:57:56 -0500

> hi Jeff,
>       I have gone through rfc 2966. This is related L2to L1 leaking(L2
> down). It does not talk about L1 down.In draft 
> draft-ietf-isis-ipv6-02.txt section #3
> 
> 1. if a prefix is redistributed from an area to another area 
> at the same level then the up/down bit shall be set to one.

Isn't an L1 down a route that has been up to L2 and back?
 
> What is meaning of it. as there is no redistribution of 
> routes from one area
> to another area. Routes are learned through L2 routing only.

If they are leaked from L1 to L2 back down to L1, then it
is a different L1 area, as there would be no point in
returning it to the same area.  
 
> 2. in the next sentance,
> if the prefix was distributed into isis form another routing 
> protocol, the
> external bit shall be set to one. This information is useful while
> distributing routes from is-is other protocols.
> I am not getting how it is useful.

As routes slosh around from say BGP to IS-IS, information is lost,
esp. if you are sticking with 1195 metrics.  This bit could be
used, if you trusted it, to let you know that you are exporting
a genuine copy of a distorted metric, and to make adjustments 
accordingly: perhaps deciding not to use the route if there was
anything the looked more plausible.  

Mark Twain wrote a version of the "Jumping Frog of Calaveras 
County" that was a translation of a French translation of his
story.  I found it funnier than the original.  While much is
lost in translation, even more is lost in a second translation.  

- jeff parker
- axiowave networks