Subject: RE: [Isis-wg] Concerns with 3-way-handshake

From: "Philip Christian" <[email-masked]>
Date: Tue, 4 Dec 2001 19:53:59 -0000

I absolutely do not agree.
I said that it is acceptable for a pure IP implementation to ignore ISH, and
so these "current vendors implementations" need not have a problem with it.
We can even say this in the RFC, so for the first time ever, it will say in
an RFC "you can ignore ISH". I would have thought that this would be good
news for the implementations that you mention.
However the draft is useless for routers that do need to terminate CLNS
packets, and is therefore useless for sorting out the SONET protection
switching events that it claims to help.
Do we want RFCs that do not acheive what they claim to?
We can sort out one without affecting the other, and therefore should do so.

By the way, the draft has expired, but people can still read it at
http://www.watersprings.org/pub/id/draft-ietf-isis-3way-03.txt

Philip Christian

-----Original Message-----
From: Naiming Shen [mailto:[email-masked]]
Sent: 04 December 2001 19:42
To: Tony Li
Cc: Christian, Philip [HAL02:GI50:EXCH]; [email-masked]';
[email-masked]'; Saluja, Rajesh [BL60:432:EXCH]
Subject: Re: [Isis-wg] Concerns with 3-way-handshake

this draft reflects many vendors current implementation for the ip
routers, we should let this to go through to become an rfc(informational).
any need for ish probably should submit a seperate one, maybe a big
one to handle all other clns cases where the ip portion has already
advanced.

 ]
 ] | This draft specifically declares itself to be useful in SONET networks
 ] | (presumably in the embedded DCC channels, although this is not stated).
 ]
 ]
 ]Actually, most of the IP routers running IS-IS do so over POS links, and
 ]thus, IS-IS is running in-band.
 ]
 ]I agree with your comments.  Other opinions?
 ]
 ]Tony
 ]
 ]_______________________________________________
 ]Isis-wg mailing list  -  [email-masked]
 ]http://external.juniper.net/mailman/listinfo/isis-wg

- Naiming

---

From: Naiming Shen <[email-masked]>
Date: Tue, 04 Dec 2001 12:33:00 -0800

I don't think the draft claims to work during the sonet switch level,
the sonet switching portion this draft talking about has nothing to
do with ISIS. this draft only claims to solve the problem after the
sonet switching happened(with some lower layer signalling), how to
make sure from layer 3 this link has changed circuit from ISIS point
of view.

 ]
 ]I absolutely do not agree.
 ]I said that it is acceptable for a pure IP implementation to ignore ISH, and
 ]so these "current vendors implementations" need not have a problem with it.
 ]We can even say this in the RFC, so for the first time ever, it will say in
 ]an RFC "you can ignore ISH". I would have thought that this would be good
 ]news for the implementations that you mention.
 ]However the draft is useless for routers that do need to terminate CLNS
 ]packets, and is therefore useless for sorting out the SONET protection
 ]switching events that it claims to help.
 ]Do we want RFCs that do not acheive what they claim to?
 ]We can sort out one without affecting the other, and therefore should do so.
 ]
 ]By the way, the draft has expired, but people can still read it at
 ]http://www.watersprings.org/pub/id/draft-ietf-isis-3way-03.txt
 ]
 ]Philip Christian
 ]
 ]-----Original Message-----
 ]From: Naiming Shen [mailto:[email-masked]]
 ]Sent: 04 December 2001 19:42
 ]To: Tony Li
 ]Cc: Christian, Philip [HAL02:GI50:EXCH]; [email-masked]';
 ][email-masked]'; Saluja, Rajesh [BL60:432:EXCH]
 ]Subject: Re: [Isis-wg] Concerns with 3-way-handshake
 ]
 ]
 ]
 ]this draft reflects many vendors current implementation for the ip
 ]routers, we should let this to go through to become an rfc(informational).
 ]any need for ish probably should submit a seperate one, maybe a big
 ]one to handle all other clns cases where the ip portion has already
 ]advanced.
 ]
 ]
 ] ]
 ] ] | This draft specifically declares itself to be useful in SONET networks
 ] ] | (presumably in the embedded DCC channels, although this is not stated).
 ] ]
 ] ]
 ] ]Actually, most of the IP routers running IS-IS do so over POS links, and
 ] ]thus, IS-IS is running in-band.
 ] ]
 ] ]I agree with your comments.  Other opinions?
 ] ]
 ] ]Tony
 ] ]
 ] ]_______________________________________________
 ] ]Isis-wg mailing list  -  [email-masked]
 ] ]http://external.juniper.net/mailman/listinfo/isis-wg
 ]
 ]- Naiming
 ]

- Naiming
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg