Subject: [Isis-wg] isis route preference

From: "aridaman kaushik" <[email-masked]>
Date: 5 Dec 2001 04:38:28 -0000

I have gone through rfc 2966. This is related L2to L1 leaking(L2 down). It does not talk about L1 down.In draft draft-ietf-isis-ipv6-02.txt section #3

1. if a prefix is redistributed from an area to another area at the same level then the up/down bit shall be set to one.

What is meaning of it. as there is no redistribution of routes from one area to another area. Routes are learned through L2 routing only.

2. in the next sentance, 
if the prefix was distributed into isis form another routing protocol, the external bit shall be set to one. This information is useful while distributing routes from is-is other protocols.
I am not getting how it is useful. 

Please Confirm This. 
3. when ipv6 routes will be leaked from L2 to l1. How should these routes should be distributed, my mean to say, as external reachiablity information or internal reachiablity information.

if it is to be sent as external reachiability information, then external bit the ipv6 prefix TLV should be set to one. But in draft, while leaking routes from L2 to L1, set up/down bit to one. External bit is set only when route is being redisributed from other routing protocol. So leaked route from L2 to L1 should be sent as internal reachiablity information.
thanks in advance

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Li <[email-masked]>
Date: Wed, 5 Dec 2001 00:36:01 -0800

|   I have gone through rfc 2966. This is related L2to L1 leaking(L2
 |   down). It does not talk about L1 down.In draft
 |   draft-ietf-isis-ipv6-02.txt section #3
 | 
 | 1. if a prefix is redistributed from an area to another area at the same
 | level then the up/down bit shall be set to one.
 | 
 | What is meaning of it. as there is no redistribution of routes from one
 | area to another area. Routes are learned through L2 routing only.

Certain implementations allow a router to participate in multiple different
L1 areas and interchange routes between the different L1 areas.  Clearly
this is way past the spirit of ISO 10589, but is also not impossible.  It
seems like a reasonable condition to add.

 | 2. in the next sentance,
 | if the prefix was distributed into isis form another routing protocol,
 | the external bit shall be set to one. This information is useful while
 | distributing routes from is-is other protocols.  I am not getting how it
 | is useful.

An obvious benefit is the ability to subsequently write policy about those
external routes when injecting routes from IS-IS into another routing
protocol.

Example: suppose that I have a domain that is routed with both IS-IS and
OSPF [possibly as the result of an acquistion].  As a migration aid, I wish
to interconnect the domain at multiple points yet not convert to one or the
other IGP in a flash manner.  If I leak OSPF non-externals into IS-IS and
mark them external and then I leak IS-IS non-externals into OSPF, I have
full connectivity without a feedback loop.

 | Please Confirm This.  3. when ipv6 routes will be leaked from L2 to
 | l1. How should these routes should be distributed, my mean to say, as
 | external reachiablity information or internal reachiablity information.

It's still internal.

Tony