Subject: RE: [Isis-wg] Making the update reliable

From: Jeff Learman <[email-masked]>
Date: Thu, 24 Jan 2002 08:25:55 -0500

Keep in mind that in 10589, IS-IS requires reliable point-to-point links,
so the update reliability isn't there for PPP unless you also use the 3-way
handshake.  Fortunately, loss of the initial CNSP would only cause problems
until every router had regenerated its LSP -- within 20 minutes using default
LSP regen timer.  See the 3-way draft for other problems that can happen
because of running IS-IS over an unreliable link.

Jeff

At 02:12 AM 1/24/2002, Ramalingam, Swaminathan wrote:
>Keon,
> 
>Whenever an adjacency comes up (may be because of start/restart) , CSNPs are sent on p2p links.You can't send control packets without adjacency.
> 
>"Making the update reliable" means how the flooding made reliable using  periodic CSNPs in bcast network, ack to PSNPs in p2p networks and sending CSNPs on p2p network when it start/restarts.
> 
>- Swami  
>-----Original Message----- 
>From: Koen Vermeulen [mailto:[email-masked]] 
>Sent: Wednesday, January 23, 2002 11:55 PM 
>To: Isis-wg 
>Subject: [Isis-wg] Making the update reliable
>
>Hello, 
>
>I have a question concerning ISO/IEC 10589 7.3.17 'Making the  
>update reliable'. At the end of this section is written for  
>point-to-point circuits: 
>
>    When a point-to-point circuit (including non-DA DED circuits  
>    and virtual links) starts (or restarts), the IS shall 
>
>        a) set SRMflag for that circuit on all LSPs, and 
>
>        b) send a Complete set of Complete Sequence Numbers PDUs  
>           on that circuit. 
>
>My question is now: what is actually meant with this  
>'start' (or 'restart') of a circuit? Do they mean an  
>adjacency state change to 'up', or is it really the circuit  
>which physically gets ready to send l2-frames?  
>If the second answer is what is meant, then I don't  
>understand why a CSNP is sent. This PDU will  
>be thrown away anyhow by the receiving side if there is  
>no adjacency (see 7.3.15.2 7: 
>
>    If the SNP is received on a non-broadcast circuit and  
>    there is no adjacency of the same level (e.g. a level 1 SNP  
>    with a level 1 or level 1 & 2 adjacency) on the circuit  
>    over which the SNP was received, then the IS shall  
>    discard the SNP without generating a event. 
>
>).  
>So how can this mechanism make the update reliable? Or am I  
>missing something? 
>
>Regards,  
>Koen 
>

---

From: Jeff Learman <[email-masked]>
Date: Thu, 24 Jan 2002 08:56:19 -0500

Evidently I should have read Mike's reply before sending this, which
is evidently wrong about the consequences of losing the first CSNP.

---

From: Dave Katz <[email-masked]>
Date: Thu, 24 Jan 2002 08:52:00 -0800 (PST)

Additionally, some routers send periodic CSNPs on point-to-point links
by default.

   X-Sender: [email-masked]
   From: Jeff Learman <[email-masked]>
   Cc: "'Koen Vermeulen'" <[email-masked]>,
      Isis-wg <[email-masked]>
   Content-Type: multipart/alternative;
	   boundary="=====================_27549323==_.ALT"
   Sender: [email-masked]
   X-BeenThere: [email-masked]
   X-Mailman-Version: 2.0rc1
   Precedence: bulk
   List-Help: <mailto:[email-masked]?subject=help>
   List-Post: <mailto:[email-masked]>
   List-Subscribe: <http://external.juniper.net/mailman/listinfo/isis-wg>,
	   <mailto:[email-masked]?subject=subscribe>
   List-Id: IETF IS-IS working group <isis-wg.external.juniper.net>
   List-Unsubscribe: <http://external.juniper.net/mailman/listinfo/isis-wg>,
	   <mailto:[email-masked]?subject=unsubscribe>
   List-Archive: <http://external.juniper.net/pipermail/isis-wg/>
   Date: Thu, 24 Jan 2002 08:25:55 -0500

   --=====================_27549323==_.ALT
   Content-Type: text/plain; charset="us-ascii"

   Jeff

   >So how can this mechanism make the update reliable? Or am I  

   --=====================_27549323==_.ALT
   Content-Type: text/html; charset="us-ascii"

   <html>
   <br>
   Keep in mind that in 10589, IS-IS requires reliable point-to-point
   links,<br>
   so the update reliability isn't there for PPP unless you also use the
   3-way<br>
   handshake.&nbsp; Fortunately, loss of the initial CNSP would only cause
   problems<br>
   until every router had regenerated its LSP -- within 20 minutes using
   default<br>
   LSP regen timer.&nbsp; See the 3-way draft for other problems that can
   happen<br>
   because of running IS-IS over an unreliable link.<br>
   <br>
   Jeff<br>
   <br>
   At 02:12 AM 1/24/2002, Ramalingam, Swaminathan wrote:<br>
   <blockquote type=cite cite><font face="arial" size=2 color="#0000FF">Keon,</font><br>
   &nbsp;<br>
   <font face="arial" size=2 color="#0000FF">Whenever an adjacency comes up
   (may be because of start/restart) , CSNPs are sent on p2p links.You can't
   send control packets without adjacency.</font><br>
   &nbsp;<br>
   <font face="arial" size=2 color="#0000FF">&quot;Making the update
   reliable&quot; means how the flooding made reliable using&nbsp; periodic
   CSNPs in bcast network, ack to PSNPs in p2p networks and sending CSNPs on
   p2p network when it start/restarts.</font><br>
   &nbsp;<br>
   <font face="arial" size=2 color="#0000FF">- Swami</font>
   <dl><font face="tahoma" size=2>
   <dd>-----Original Message-----
   <dd>From:</b> Koen Vermeulen
   [<a href="mailto:[email-masked]" eudora="autourl">mailto:[email-masked]</a>]
   <dd>Sent:</b> Wednesday, January 23, 2002 11:55 PM
   <dd>To:</b> Isis-wg
   <dd>Subject:</b> [Isis-wg] Making the update reliable<br>
   <br>
   </font><tt>
   <dd>Hello,</tt> <br>
   <br>
   <tt>
   <dd>I have a question concerning ISO/IEC 10589 7.3.17 'Making the</tt>
   <tt>
   <dd>update reliable'. At the end of this section is written for</tt> <tt>
   <dd>point-to-point circuits:</tt> <br>
   <br>
   <tt>
   <dd>&nbsp;&nbsp;&nbsp; When a point-to-point circuit (including non-DA DED circuits</tt> <tt>
   <dd>&nbsp;&nbsp;&nbsp; and virtual links) starts (or restarts), the IS shall</tt> <br>
   <br>
   <tt>
   <dd>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; a) set SRMflag for that circuit on all LSPs, and</tt> <br>
   <br>
   <tt>
   <dd>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; b) send a Complete set of Complete Sequence Numbers PDUs</tt> <tt>
   <dd>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; on that circuit.</tt> <br>
   <br>
   <tt>
   <dd>My question is now: what is actually meant with this</tt> <tt>
   <dd>'start' (or 'restart') of a circuit? Do they mean an</tt> <tt>
   <dd>adjacency state change to 'up', or is it really the circuit</tt> <tt>
   <dd>which physically gets ready to send l2-frames?</tt> <tt>
   <dd>If the second answer is what is meant, then I don't</tt> <tt>
   <dd>understand why a CSNP is sent. This PDU will</tt> <tt>
   <dd>be thrown away anyhow by the receiving side if there is</tt> <tt>
   <dd>no adjacency (see 7.3.15.2 7:</tt> <br>
   <br>
   <tt>
   <dd>&nbsp;&nbsp;&nbsp; If the SNP is received on a non-broadcast circuit and</tt> <tt>
   <dd>&nbsp;&nbsp;&nbsp; there is no adjacency of the same level (e.g. a level 1 SNP</tt> <tt>
   <dd>&nbsp;&nbsp;&nbsp; with a level 1 or level 1 &amp; 2 adjacency) on the circuit</tt> <tt>
   <dd>&nbsp;&nbsp;&nbsp; over which the SNP was received, then the IS shall</tt> <tt>
   <dd>&nbsp;&nbsp;&nbsp; discard the SNP without generating a event.</tt> <br>
   <br>
   <tt>
   <dd>).</tt> <tt>
   <dd>So how can this mechanism make the update reliable? Or am I</tt> <tt>
   <dd>missing something?</tt> <br>
   <br>
   <tt>
   <dd>Regards,</tt> <tt>
   <dd>Koen</tt> 
   <dd>&nbsp; 
   </dl></blockquote></html>

   --=====================_27549323==_.ALT--

   _______________________________________________
   Isis-wg mailing list  -  [email-masked]
   http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg