Subject: [Isis-wg] When the next Seq. Number Exceeds Max. Sequence Number!

From: "Chan, Chung Ming" <[email-masked]>
Date: Thu, 17 Jan 2002 16:14:44 -1000

Hi,

When the next Seq. Number Exceeds Max. Sequence Number!

I'm reading to ISO/IEC10589, Section7.3.16.1 and not quite understand what
the text means when it talks about "... the IS Network entity shall be
disabled for a period of at least MaxAge + ZeroAgeLifetime, ..."

"...
If an Intermediate system needs to increment its sequence
number, but the sequence number is already equal to
SequenceModulus - 1, the event attemptToExceed-
MaximumSequenceNumber shall be generated and the IS
Network entity shall be disabled for a period of at least
MaxAge + ZeroAgeLifetime, in order to be sure that any ver-
sions of this LSP with the high sequence number have expired.
When it is re-enabled the IS shall start again with sequence
number 1.
..."

What is the IS supposed to do with the LSP in question?
What is the IS itself supposed to do?

Thanks,

Ming Chan 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Harish Balasubramaniam" <[email-masked]>
Date: Thu, 17 Jan 2002 19:30:08 -0800

Hi
 When the LSP sequence number reaches a max sequence value (say fffffff ) ,
the next sequence number that is allocated for a new LSP by an IS is 1 . But
since 1 < fffffff , the LSP with seq=1 will be discarded if transmitted
immediately.

So the IS waits  MaxAge (time for the Remaininglifetime/age field of the LSP
(seq=ffffff) to get to zero ) + ZeroAgeLifetime (for the zero age LSP to
timeout and be purged from all routers database) , before transmitting the
new LSP.

rgds
Harish

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Chan, Chung Ming
Sent: Thursday, January 17, 2002 6:15 PM
To: [email-masked]
Cc: Chan, Chung Ming
Subject: [Isis-wg] When the next Seq. Number Exceeds Max. Sequence
Number!

Hi,

"...

Thanks,

Ming Chan