Subject: RE: [Isis-wg] Point to point adjacency down.

From: Jeff Parker <[email-masked]>
Date: Fri, 11 Jan 2002 14:22:31 -0500

> > This strays into the area of creative implementation possibilities.
> > I suspect that a MIB variable with a scalar value that is expected
> > to be stable does not accurately represent either of the dominant
> > implementations.
> 
> It is superfluous, restricting and confusing to try to
> govern internal implementation details ...
> correct ISIS packets to the wire [is our only goal]
>
>     -- tony

Tony -
	I can accept that this is off task behavior, but I 
must ask a clarifying question.

	Don't we have more to do that generate and consume
IS-IS packets?  Don't we also need to produce consistent 
routing tables for the two letter protocol?  

	If we let SPF computations run without check, or 
delay SPF computations unduly, doesn't that effect 
convergence adversly, through slow flooding in the 
first case, and slow updates to our tables in the 
second.

- jeff parker
- axiowave networks
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Dave Katz <[email-masked]>
Date: Fri, 11 Jan 2002 12:05:20 -0800 (PST)

It is a distributed algorithm, so you are guaranteed to have
transient disagreements between machines given the protocol
design.  Guarantees of a loop-free, black-hole-free network are
outside the scope of the spec (and indeed are not possible.)

I think the best you can hope for in this case is a statement to the
effect that "reasonably synchronous route installation is a virtue"
and leave it at that.  Anything else will constrain implementation
in one direction or the other.

--Dave