Subject: RE: [Isis-wg] RE: Regarding draft-ietf-isis-wg-mib-06.txt

From: "Manral, Vishwas" <[email-masked]>
Date: Tue, 8 Jan 2002 00:22:40 -0500

Dave,

Right, but wouldn't it help new implementations if the default was the value
desired from implementations? I although agree that not all implementations
would follow the default as given in the MIB, and its a not a big issue what
the default in this case should be.

Thanks,
Vishwas

-----Original Message-----
From: Dave Katz [mailto:[email-masked]]
Sent: Tuesday, January 08, 2002 10:32 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Isis-wg] RE: Regarding draft-ietf-isis-wg-mib-06.txt

To put on my rude pragmatist's hat again, it doesn't really matter a
whole lot in practice what the MIB says the default is, since the
default is whatever the implementation already does (and defaults
in general are notoriously difficult to change in practice.)

   Jeff,

   My idea was that if the padded hellos aren't really of much use, and as
Dave
   put it "essentially useless and creates lots of unnecessary customer
   service" wouldn't it be wise not to make it the default value. We aren't
   strictly following the specs anyway.

   -Vishwas

   -----Original Message-----
   From: Jeff Parker [mailto:[email-masked]]
   Sent: Monday, January 07, 2002 8:23 PM
   To: 'Manral, Vishwas'
   Cc: IS-IS-WG (E-mail)
   Subject: RE: Regarding draft-ietf-isis-wg-mib-06.txt

   > Jeff,
   > 
   > The object
   >      isisCircSmallHellos OBJECT-TYPE
   >          SYNTAX AdminState
   >          MAX-ACCESS read-create
   >          STATUS current
   >          DESCRIPTION
   >              "Can we send unpadded hellos on LAN circuits?  Off means
   >              LAN Hellos must be padded."
   >           DEFVAL { off }
   >      ::= { isisCircEntry 26 }
   > 
   > says the DEFVAL should be such that we must send LAN Hellos 
   > padded. However
   > from the discussion 
   > http://people.juniper.net/pipermail/isis-wg/2000/000300.html
   > http://people.juniper.net/pipermail/isis-wg/2000/000305.html
   > it seems padding isn't of much help. Wouldn't it be better to 
   > change the
   > DEFVAL to not off(on)?
   > ...
   > Vishwas

   Vishwas -
	   The standard requires padded hellos.  The introduction
   of this variable is an admission that some people like to
   run without padded hellos, but I don't see any reason to make
   unpadded (small hellos) the default behavior.  

	   Strong feelings from the list?

   - jeff parker
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Dave Katz <[email-masked]>
Date: Mon, 7 Jan 2002 22:25:32 -0800 (PST)

Ruder pragmatist--I won't be writing another one.  ;-)

I guess it makes sense to try to mirror best practice (whatever that may
be) for these things.  When all else fails, default to the spec or flip
a coin.

--Dave

   X-JNPR-Received-From: outside
   From: "Manral, Vishwas" <[email-masked]>
   Cc: [email-masked], [email-masked]
   Date: Tue, 8 Jan 2002 00:22:40 -0500 
   Content-Type: text/plain
   X-OriginalArrivalTime: 08 Jan 2002 05:22:23.0671 (UTC) FILETIME=[7402B470:01C19804]

   Dave,

   Thanks,
   Vishwas

   -----Original Message-----
   From: Dave Katz [mailto:[email-masked]]
   Sent: Tuesday, January 08, 2002 10:32 AM
   To: [email-masked]
   Cc: [email-masked]; [email-masked]
   Subject: Re: [Isis-wg] RE: Regarding draft-ietf-isis-wg-mib-06.txt

      Jeff,

      -Vishwas

      -----Original Message-----
      From: Jeff Parker [mailto:[email-masked]]
      Sent: Monday, January 07, 2002 8:23 PM
      To: 'Manral, Vishwas'
      Cc: IS-IS-WG (E-mail)
      Subject: RE: Regarding draft-ietf-isis-wg-mib-06.txt

      Vishwas -

      - jeff parker