Subject: [Isis-wg] Reg: route preference

From: "Rayapureddi Ramesh" <[email-masked]>
Date: Mon, 28 Jan 2002 20:06:43 +0530

Hi,

In ISIS we  can add manual adjacencies also, they are nothing but static
routes.
We can add prefix addresses (reachable address)  also these also static
routes only.

When we want to send some data to some destination "DST"

if there three routes with different next hops with "same cost"

1. route learned by ISIS with next hop NH1
2. Static route (manual adjacency)   with next hop NH2
3. Reachable address with next hop NH3

Which route  I should take as a best route?

If any one knows pl tell me.

Regards,
Ramesh

---

From: "Ken Larmer" <[email-masked]>
Date: Mon, 28 Jan 2002 10:08:20 -0500

Hi Ramesh,

routes only.

 >2. Static route (manual adjacency)   with next hop NH 2

 >Which route  I should take as a best route?

This depends upon whether or not you have path splitting enabled? If you do,
then you follow the guidelines specified in ISO-10589v2-2001-07-04 section
"7.2.7 Removal of excess paths"

Cheers,
Ken Larmer
CommSense Networks

---

From: Jeff Learman <[email-masked]>
Date: Mon, 28 Jan 2002 10:29:14 -0500

See 10589:1992 section 7.2.7., Removal of excess paths.

Jeff

At 09:36 AM 1/28/2002, Rayapureddi Ramesh wrote:
>Hi,
> 
>In ISIS we  can add manual adjacencies also, they are nothing but static routes.
>We can add prefix addresses (reachable address) also these also static routes only.
>

---

From: Jeff Learman <[email-masked]>
Date: Mon, 28 Jan 2002 11:25:09 -0500

Ken, you need to follow those rules whenever the number of next hops
exceeds maximumPathSplits, so you need the logic regardless of what
an implementation supports.  One that doesn't support load balancing
would simply have maximumPathSplits set to 1.

Jeff

At 10:08 AM 1/28/2002, you wrote:
>This depends upon whether or not you have path splitting enabled? If you do, then you follow the guidelines specified in ISO-10589v2-2001-07-04 section "7.2.7 Removal of excess paths"
> 
>Cheers,
>Ken Larmer
>CommSense Networks<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

---

From: "Ken Larmer" <[email-masked]>
Date: Mon, 28 Jan 2002 11:58:47 -0500

Yes Jeff, you are quite right! This is not phase IV is it.

Cheers,
Ken Larmer
CommSense Networks
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jeff Learman
  Sent: Monday, January 28, 2002 11:25 AM
  To: Ken Larmer
  Cc: [email-masked]
  Subject: RE: [Isis-wg] Reg: route preference

  Jeff

    Hi Ramesh,

routes only.

     >Which route  I should take as a best route?

    This depends upon whether or not you have path splitting enabled? If you
do, then you follow the guidelines specified in ISO-10589v2-2001-07-04
section "7.2.7 Removal of excess paths"

    Cheers,
    Ken Larmer
    CommSense Networks<?xml:namespace prefix = o ns =
"urn:schemas-microsoft-com:office:office" />