Subject: [Isis-wg] Questions on cird IDs in isis mib

From: Laura Liu <[email-masked]>
Date: Wed, 23 Jan 2002 10:49:32 -0600

Hello,

I need some clarification on the three circuit Id related mib objects. 

1. isisCircIndex and isisCircIfIndex are defined as Integer32. My
understanding is isisCircIndex refers to a logical id, while isisCircIfIndex
are the physical id of the interface to which this circuit corresponds.

2. isisCircLocalID is Integer32(0..255), is the locally assigned one octet
Local Circuit ID used for "maintaining more than 255 circuits in IS-IS". 

Am I correct?

Another question, there is isisCircLevelDesIS object, it only report the
DR's system ID part. How can I retrieve the circuit ID part of DR's LAN ID?

please help, and thanks!

Laura

----------------------------------------- (on Chiaro SMTP Relay)

This e-mail and any files transmitted with it are the property
of Chiaro Networks, Ltd., and may contain confidential and 
privileged material for the sole use of the intended recipient(s)
to whom this e-mail is addressed. If you are not one of the named
recipient(s), or otherwise have reason to believe that you have 
received this message in error, please notify the sender and 
delete all copies from your system.  Any other use, retention, 
dissemination, forwarding, printing or copying of this e-mail is 
strictly prohibited.

---------------------------------------------------------

---

From: Jeff Parker <[email-masked]>
Date: Wed, 23 Jan 2002 14:32:54 -0500

> understanding is isisCircIndex refers to a logical id, while 

     isisCircIndex OBJECT-TYPE
         SYNTAX Integer32 (1..2000000000)
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "The identifier of this circuit, unique within the
              instance of the IS-IS protocol. This object follows
              the index behavior.  This is for SNMP Indexing
              purposes only and need not have any relation to
              any protocol value."
     ::= { isisCircEntry 1 }

So this can be an index into an array, a hash value, or
it could be the index of a port in your box.  
However, many devices allow multiple circuits to 
run over the same physical port, and would not 
be able to use a physical port number as the index.

In brief, it is whatever you would like it to be.
It could be the same as isisCircIfIndex.  

> isisCircIfIndex are the physical id of the 
> interface to which this circuit corresponds.

     isisCircIfIndex OBJECT-TYPE
         SYNTAX Integer32
         MAX-ACCESS read-create
         STATUS current
         DESCRIPTION
             "The value of ifIndex for the interface to which this
             circuit corresponds.   This object cannot be modified
             after creation"
     ::= { isisCircEntry 2 }

Nope, this is the MIB II IfIndex.  There are rules
about doling this out.  What we're trying to do here
is to have a value that lines up with the value of
the manager will see in the Interface table.

> Local Circuit ID used for "maintaining more than 255 circuits 

     isisCircLocalID OBJECT-TYPE
         SYNTAX Integer32(0..255)
         MAX-ACCESS read-create
         STATUS current
         DESCRIPTION
             "An identification that can be used in protocol packets
             to identify a circuit.  Values of isisCircLocalID do
             not need to be unique.  They are only required to differ
             on LANs where the Intermediate System is the Designated
             Intermediate System."
     ::=    { isisCircEntry 4 }

The MIB does not try to address the issue of how to 
maintain a presence as the DIS on more than 256 LANs.
Briefly, this is the octet that you use to augment
the system ID to provide a unique PNodeID.  This can
be related to one of the other indicies, or can be
independent.  The implementer gets to allocate this.

> DR's system ID part. How can I retrieve the circuit ID part 

Laura -
	I think that is an error: thanks for catching that.  
The syntax should be an octet string of length 7 or 0.  

     isisCircLevelDesIS OBJECT-TYPE
         SYNTAX OCTET STRING (SIZE(0..7))
         MAX-ACCESS read-only
         STATUS current
         DESCRIPTION
             "The ID of the LAN Designated Intermediate System
             on this circuit at this level. If, for any reason,
             this system is not partaking in the relevant
             Designated Intermediate System election process,
             then the value returned is the zero length OCTET STRING."
         REFERENCE "{ISIS.aoi l2DesignatedIntermediateSystem (75)}"
     ::= { isisCircLevelEntry 4 }

- jeff parker
- axiowave networks
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Laura Liu <[email-masked]>
Date: Thu, 24 Jan 2002 16:23:49 -0600

Hi Jeff,

I have another question on isis mib.

For those table index entries, they are defined as 

Does this mean, this entry cannot be access through snmp get command, are
they only used in part of oid?

thanks,

Laura

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]]
Sent: Wednesday, January 23, 2002 1:33 PM
To: 'Laura Liu'
Cc: IS-IS-WG (E-mail)
Subject: RE: [Isis-wg] Questions on cird IDs in isis mib

Laura -

- jeff parker
- axiowave networks

---

From: Jeff Parker <[email-masked]>
Date: Fri, 25 Jan 2002 09:49:43 -0500

> For those table index entries, [that] are defined as 
> 
> Does this mean, this entry cannot be access through 
> snmp get command, are they only used in part of oid?
> 
> Laura

I believe you are right.  They -can- be discovered 
through a get-next walk of the table.  

- jeff parker