Subject: RE: [Isis-wg] CSNP from Designated IS

From: "Sachidananda K" <[email-masked]>
Date: Mon, 28 Jan 2002 08:35:54 +0000

Thank you for the clarification.
I would like to know as to, whether is it permissible to keep the start LSP 
ID of the first CSNP as all 0's and the end LSP ID of the last CSNP packet 
as all 1's in a complete set of CSNP.

Thanking you in advance for the clarification.

Regards,
Sachi.

----Original Message Follows----
From: "Ramalingam, Swaminathan" <[email-masked]>
To: Sachidananda K <[email-masked]>
CC: [email-masked], "'Tony Li'" <[email-masked]>
Subject: RE: [Isis-wg] CSNP from Designated IS
Date: Fri, 25 Jan 2002 01:28:17 -0500

comments inlined

 > -----Original Message-----
 > From: Tony Li [mailto:[email-masked]]
 > Sent: Friday, January 25, 2002 11:17 AM
 > To: Sachidananda K
 > Cc: [email-masked]
 > Subject: [Isis-wg] CSNP from Designated IS
 >
 >
 >
 >
 >  | When an intermediate system just comes up on a broadcast
 > circuit it would
 >  | typically not be having any LSPs in its database.
 >
 >
 > It should generate at least its own, even if it doesn't have
 > any adjacencies.
 >
 >
 >  | Co-incidently, if this IS
 >  | happens to be the designated IS for that broadcast
 > circuit, then what start
 >  | LSP ID and the end LSP ID shall be put in the CSNP
 > constructed by this IS?
 >
 >
 > Then it should also generate a pseudo-node LSP.  The CSNP
 > should contain
 > the full range of the database from LSP ID 0 (zero) to the
 > all-ones LSP ID.
 >
 >
 >  | To be more generic, how can we ensure that this new IS's
 > database is
 >  | synchronised with that of all the othre IS's in the LAN?
 >
 >
 > It should send out CSNPs.  Anyone disagreeing should speak up.
 >
 >

Adding to Tony's reply, DIS sends out CSNPs. When the receiver finds DIS is
out of date, it will multicast the missing information (so that other IS
receiving CSNP will not send again).

If DIS has new information, the receiving IS multicast PSNP for missing
information.Here only DIS should send the missing info, others should not.

Hope this helps

~ Swami

 > Tony
 > _______________________________________________
 > Isis-wg mailing list  -  [email-masked]
 > http://external.juniper.net/mailman/listinfo/isis-wg
 >
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Li <[email-masked]>
Date: Mon, 28 Jan 2002 01:03:13 -0800

| I would like to know as to, whether is it permissible to keep the start LSP 
 | ID of the first CSNP as all 0's and the end LSP ID of the last CSNP packet 
 | as all 1's in a complete set of CSNP.

Not only is that permissible, but it is also required if you want true
database synchronization.  If a complete set of CSNPs does not completely
cover the LSP ID space, then the receiver could have an LSP in any space
that is not included and thereby it might not be synchronized with the DIS.

Tony