Subject: [Isis-wg] RE: Regarding draft-ietf-isis-wg-mib-06.txt

From: "Manral, Vishwas" <[email-masked]>
Date: Mon, 7 Jan 2002 23:27:39 -0500

Jeff,

My idea was that if the padded hellos aren't really of much use, and as Dave
put it "essentially useless and creates lots of unnecessary customer
service" wouldn't it be wise not to make it the default value. We aren't
strictly following the specs anyway.

-Vishwas

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]]
Sent: Monday, January 07, 2002 8:23 PM
To: 'Manral, Vishwas'
Cc: IS-IS-WG (E-mail)
Subject: RE: Regarding draft-ietf-isis-wg-mib-06.txt

> Jeff,
> 
> The object
>      isisCircSmallHellos OBJECT-TYPE
>          SYNTAX AdminState
>          MAX-ACCESS read-create
>          STATUS current
>          DESCRIPTION
>              "Can we send unpadded hellos on LAN circuits?  Off means
>              LAN Hellos must be padded."
>           DEFVAL { off }
>      ::= { isisCircEntry 26 }
> 
> says the DEFVAL should be such that we must send LAN Hellos 
> padded. However
> from the discussion 
> http://people.juniper.net/pipermail/isis-wg/2000/000300.html
> http://people.juniper.net/pipermail/isis-wg/2000/000305.html
> it seems padding isn't of much help. Wouldn't it be better to 
> change the
> DEFVAL to not off(on)?
> ...
> Vishwas

Vishwas -
	The standard requires padded hellos.  The introduction
of this variable is an admission that some people like to
run without padded hellos, but I don't see any reason to make
unpadded (small hellos) the default behavior.  

	Strong feelings from the list?

- jeff parker
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Dave Katz <[email-masked]>
Date: Mon, 7 Jan 2002 21:01:38 -0800 (PST)

To put on my rude pragmatist's hat again, it doesn't really matter a
whole lot in practice what the MIB says the default is, since the
default is whatever the implementation already does (and defaults
in general are notoriously difficult to change in practice.)

   Jeff,

   -Vishwas

   -----Original Message-----
   From: Jeff Parker [mailto:[email-masked]]
   Sent: Monday, January 07, 2002 8:23 PM
   To: 'Manral, Vishwas'
   Cc: IS-IS-WG (E-mail)
   Subject: RE: Regarding draft-ietf-isis-wg-mib-06.txt

   Vishwas -

   - jeff parker