Subject: [Isis-wg] Comment on draft-ietf-isis-traffic-04.txt

From: David Hudek <[email-masked]>
Date: Thu, 24 Jan 2002 18:20:58 -0500

I have a comment/concern about the current description of
subTLV 6 (IPv4 Iface Addr) in the new TLV type 22 
(Extended IS Reach) assuming that the doc is intended
to cover unnumbered point to point interfaces as well
as numbered interfaces (did not see any scope statement
which restricted it to numbered only?)

If one is supporting traffic engineering, the doc currently
specifies that subTLV6 is mandatory... but on an unnumbered 
interface by definition there is no IPv4 address, and 
one would not have a valid IPv4 Iface Addr to place 
in this mandatory subTLV. 

There is stuff in draft-ietf-isis-gmpls-extensions-04
which provides a means of exchanging interface IDs
(in the Hellos) applicable to unnumbered p2p's, and 
new subTLVs for TLV type 22 to convey iface IDs...
I presume that is the intended behavior for unnumbered p2p's.

It seems like the text for subTLV6 should state that
if one is supporting traffic engineering, subTLV 6
is only mandatory for numbered interfaces and must not
be used for unnumbered P2Ps (and possibly give a pointer to
the gmpls extensions doc).

Thanks,
dave hudek
[email-masked]
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Li <[email-masked]>
Date: Thu, 24 Jan 2002 18:53:36 -0800

We were only supporting numbered interfaces.

Tony

David Hudek writes:
 | 
 | I have a comment/concern about the current description of
 | subTLV 6 (IPv4 Iface Addr) in the new TLV type 22 
 | (Extended IS Reach) assuming that the doc is intended
 | to cover unnumbered point to point interfaces as well
 | as numbered interfaces (did not see any scope statement
 | which restricted it to numbered only?)
 | 
 | If one is supporting traffic engineering, the doc currently
 | specifies that subTLV6 is mandatory... but on an unnumbered 
 | interface by definition there is no IPv4 address, and 
 | one would not have a valid IPv4 Iface Addr to place 
 | in this mandatory subTLV. 
 | 
 | There is stuff in draft-ietf-isis-gmpls-extensions-04
 | which provides a means of exchanging interface IDs
 | (in the Hellos) applicable to unnumbered p2p's, and 
 | new subTLVs for TLV type 22 to convey iface IDs...
 | I presume that is the intended behavior for unnumbered p2p's.
 | 
 | It seems like the text for subTLV6 should state that
 | if one is supporting traffic engineering, subTLV 6
 | is only mandatory for numbered interfaces and must not
 | be used for unnumbered P2Ps (and possibly give a pointer to
 | the gmpls extensions doc).
 | 
 | Thanks,
 | dave hudek
 | [email-masked]
 | _______________________________________________
 | Isis-wg mailing list  -  [email-masked]
 | http://external.juniper.net/mailman/listinfo/isis-wg
 | _______________________________________________
 | Isis-wg-external mailing list
 | [email-masked]
 | http://mailist.procket.com/mailman/listinfo/isis-wg-external
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg