Subject: Re: [Isis-wg] Reg: route preference

From: "Rayapureddi Ramesh" <[email-masked]>
Date: Tue, 29 Jan 2002 13:13:29 +0530

Hello,

I think I asked question in a wrong way.
Actaully my doubt is

if we are maintaining three different databases for

1. routes learned from ISIS ---route information data base RDB1
2. manual adjacencies ( is-neighbors OR es-neighbors) -- route information
data base RDB2
3. reachable address (Prefix routes) -- route information data base RDB3

Is it maintaining three different data base correct?

if yes if we want a route to some destination "DST"  then

which database should I search first RDB1 or RDB2 or RDB3 ?
which is next   RDB1 or RDB2 or RDB3 ?  And which is last RDB1 or RDB2 or
RDB3?

regards,
Ramesh

  -----Original Message-----
  From: Jeff Learman [mailto:[email-masked]]
  Sent: Monday, January 28, 2002 9:12 PM
  To: [email-masked]
  Subject: Fwd: Re: [Isis-wg] Reg: route preference

  By the way, don't be confused by the inclusion of "metric sum"
  in this list.  It confused me at first, because we normally think of
  all of the paths having equal cost before reaching this point.  However,
  this item only relates to routers that, rather than computing the set
  of equal minimum cost paths (7.2.6.2-b), compute downstream paths
  (7.2.6.2-c).  I haven't ever heard of anyone using that method.

  Regards,
  Jeff

    Date: Mon, 28 Jan 2002 10:29:14 -0500
    To: <[email-masked]>
    From: Jeff Learman <[email-masked]>
    Subject: Re: [Isis-wg] Reg: route preference
    Cc: "ISIS (E-mail)" <[email-masked]>, "ISISWG
(E-mail)" <[email-masked]>

    See 10589:1992 section 7.2.7., Removal of excess paths.

    Jeff

    At 09:36 AM 1/28/2002, Rayapureddi Ramesh wrote:

      Hi,

      In ISIS we  can add manual adjacencies also, they are nothing but
static routes.
      We can add prefix addresses (reachable address) also these also static
routes only.

      When we want to send some data to some destination "DST"

      if there three routes with different next hops with "same cost"

      1. route learned by ISIS with next hop NH1
      2. Static route (manual adjacency)   with next hop NH2
      3. Reachable address with next hop NH3

      Which route  I should take as a best route?

      If any one knows pl tell me.

      Regards,
      Ramesh

---

From: Jeff Learman <[email-masked]>
Date: Tue, 29 Jan 2002 12:05:22 -0500

At 02:43 AM 1/29/2002, Rayapureddi Ramesh wrote:
>2. manual adjacencies ( is-neighbors OR es-neighbors) -- route information data base RDB2

By RDB, I assume you mean the result of running SPF -- called
a forwarding database (FDB) in 10589.  You can keep them separate
as long as you can follow the rules in section 7.2.7.  I think that
may be tricky.

>which is next   RDB1 or RDB2 or RDB3 ?  And which is last RDB1 or RDB2 or RDB3?

If the same destination can appear in all three RDBs with different
metric sums, which is likely the case, then you will have a little
trouble meeting the second criteria in 7.2.7 without consulting
all RDBs and keeping the metric sum in the RDB entries, and
choosing an entry with the minimum metric sum.

The thing to do here is to imagine the behavior of a system that
meets the criteria, and make sure that your system exhibits
indistinguishable behavior.  By the way, the requirement for
determinism seemed very important to the designers, and from my
point of view that was a very helpful property.  The fact that
the same routing decisions would always be made regardless of
the order in which systems or links came up made debugging problem
cases much easier -- as the problems would tend to be more reproducable.
This was especially the case when investigating problems in our
customers' customers' networks.  This was before I joined Cisco,
and we sold OSI middleware used in SONET network elements.

Regards,
Jeff

>>Cc: "ISIS (E-mail)" <[email-masked]>, "ISISWG (E-mail)" <[email-masked]>
>>
>>
>>
>>>In ISIS we  can add manual adjacencies also, they are nothing but static routes. 
>>>We can add prefix addresses (reachable address) also these also static routes only. 
>>>