Subject: [Isis-wg] Treatment of Zero checksum

From: "Chan, Chung Ming" <[email-masked]>
Date: Wed, 16 Jan 2002 09:46:10 -1000

>The 2001 revision of ISO 10589 has incorporated this change. Section
>7.3.14.2e now reads:
>
>
>	"An Intermediate system receiving a Link State PDU with an incorrect
>LSP Checksum or with an invalid PDU syntax shall
>
>	1)	generate a corruptedLSPReceived circuit event,
>
>	2)	discard the PDU."

Would zero checksum treated as invalid checksum?
In 10589, section 7.3.14.2, item-i, zero checksum shall be treated as if the
RLT is zero.

As described in 10589, section 7.3.16.4,
It will in turn means that the receiving router will purge the LSP if there
is an older LSP in the DB.

Thanks

Ming Chan
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Chan, Chung Ming" <[email-masked]>
Date: Wed, 16 Jan 2002 09:54:35 -1000

-----Original Message-----
From: Chan, Chung Ming 
Sent: Wednesday, January 16, 2002 2:46 PM
To: 'Les Ginsberg'; [email-masked]'
Cc: Chan, Chung Ming
Subject: Treatment of Zero checksum

Thanks

Ming Chan

---

From: Les Ginsberg <[email-masked]>
Date: Wed, 16 Jan 2002 17:22:13 -0800

Derek -

I agree with you i.e. in the case where you receive an LSP w zero checksum
and non-zero lifetime, this should be treated as "invalid" and subject to
the same (revised)handling as an LSP received with invalid non-zero checksum
- log it and discard it.

Note, however, that an LSP with zero checksum AND zero lifetime IS VALID and
should be handled as per 7.3.16.4.

   Les

> From: Derek Yeung [mailto:[email-masked]]
> Sent: Wednesday, January 16, 2002 3:17 PM
> To: Les Ginsberg
> Cc: 'Chan, Chung Ming'; [email-masked]'
> Subject: Re: [Isis-wg] RE: Treatment of Zero checksum
> 
> 
> 	Any reason the two events are treated differently ? IHMO,
> zero checksum could be caused by the same kind of corruption 
> which lead to 
> wrong checksum. And discarding the zero checksum LSP is less 
> destructive 
> then purging the LSP, which means more stable network.
> 
> - Derek
> 
> Les Ginsberg wrote:
> > 
> > Ming Chan -
> > 
> > A zero checksum is an indication that there is no checksum 
> (the Fletcher
> > algorithm guarantees that a non-zero checksum will always 
> be generated).
> > 7.3.14.2(i) is indicating that if an LSP is received w zero 
> checksum then we
> > should treat it as if it also has 0 lifetime => it is being 
> purged. We then
> > process the LSP based on the rules in 7.3.16.4.
> > 
> > An "invalid checksum" means we:
> > 
> >   a)Received a non-zero checksum in the PDU
> >   b)Performed checksum validation on the PDU contents and 
> came up w a
> > different checksum value
> >   c)Discard the PDU without further processing.
> > 
> > As you can see, the two cases are very different.
> > 
> >    Les
> > 
> > > From: Chan, Chung Ming [mailto:[email-masked]]
> > > Sent: Wednesday, January 16, 2002 11:46 AM