Subject: [Isis-wg] RE: Treatment of Zero checksum

From: Les Ginsberg <[email-masked]>
Date: Wed, 16 Jan 2002 12:52:46 -0800

Ming Chan -

A zero checksum is an indication that there is no checksum (the Fletcher
algorithm guarantees that a non-zero checksum will always be generated).
7.3.14.2(i) is indicating that if an LSP is received w zero checksum then we
should treat it as if it also has 0 lifetime => it is being purged. We then
process the LSP based on the rules in 7.3.16.4.

An "invalid checksum" means we:

  a)Received a non-zero checksum in the PDU
  b)Performed checksum validation on the PDU contents and came up w a
different checksum value
  c)Discard the PDU without further processing.

As you can see, the two cases are very different.

   Les

> -----Original Message-----
> From: Chan, Chung Ming [mailto:[email-masked]]
> Sent: Wednesday, January 16, 2002 11:46 AM
> To: 'Les Ginsberg'; [email-masked]'
> Cc: Chan, Chung Ming
> Subject: Treatment of Zero checksum
> 
> 
> 
> 
> >The 2001 revision of ISO 10589 has incorporated this change. Section
> >7.3.14.2e now reads:
> >
> >
> >	"An Intermediate system receiving a Link State PDU with 
> an incorrect
> >LSP Checksum or with an invalid PDU syntax shall
> >
> >	1)	generate a corruptedLSPReceived circuit event,
> >
> >	2)	discard the PDU."
> 
> 
> Would zero checksum treated as invalid checksum?
> In 10589, section 7.3.14.2, item-i, zero checksum shall be 
> treated as if the
> RLT is zero.
> 
> As described in 10589, section 7.3.16.4,
> It will in turn means that the receiving router will purge 
> the LSP if there
> is an older LSP in the DB.
> 
> 
> 
> Thanks
> 
> 
> Ming Chan
> 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Derek Yeung <[email-masked]>
Date: Wed, 16 Jan 2002 15:16:50 -0800

Any reason the two events are treated differently ? IHMO,
zero checksum could be caused by the same kind of corruption which lead to 
wrong checksum. And discarding the zero checksum LSP is less destructive 
then purging the LSP, which means more stable network.

- Derek