Subject: Re: [Isis-wg] IGP shortcuts

From: Naiming Shen <[email-masked]>
Date: Wed, 02 Jan 2002 01:53:13 -0800

A couple of points need to be emphasized on this "shortcut" draft,
it was authors fault not including those in the original draft.
I hope this will clear some of the confusions:

 (a) the igp shortcut is not a neighbor adjacency, it affects only
     how the routes being installed in the local routing table.
 (b) the decision to use the mpls tunnel is AFTER the node being put
     on the PATH list during the spf calculation, assume the node is
     the mpls tunnel tail-end.
 (c) the downstream nodes will inherit the mpls tunnel metric
     properties, so all the routes announced by the downstream nodes
     will inherit the mpls tunnel metric property, it varies depends
     on relative or absolute. the downstream nodes can be thought of
     as all the adjacent neighbors of the tail-end node, except for
     the nodes already on the PATH list; and their downstreams.
 (d) if there are multiple mpls tunnels to the same node, only the
     best(lowest) metric ones are being used, and only the ones
     better than or equal to the native metric are being used.
 (e) if a downstream node has multiple upstream paths, then the best
     metric paths win. this is no different from the "normal" spf.

looking at your examples, according to this draft, my answer is
just opposite to your picks:

topology A, case 1, it will be the second graph, routes advertised
by "D" will have metric of 15 plus whatever the cost from D to those
networks.

topology B, case 2, yes, A will install X with metric of 15 using
the tunnel towards B.

topology B, case 3, no, A will not install this X with metric of 19.

pls read (a) through (e) carefully, and see if you still think they
can create routing-loops. If still do, please give examples on
how the routing loops will exist.

thanks.

 ]Hi,
 ]
 ]I'm sorry, my second question wasn't clear enough.
 ]I'll try to explain my question through examples.
 ]There are 3 ways to use TE-tunnels as shortcuts. I'll
 ]explain each one of them through examples. 
 ]Topology A will be used for introducing case 1. This
 ]case refers just to the nodes (ISs) in the topology,
 ]not to the leafs (IPs).
 ]Topology B will be used for introducing cases 2 and 3.
 ]Those cases refers especially to the leafs (IPs) of
 ]the tree.
 ]
 ]Topology A:
 ]      
 ]      10
 ]    A----B
 ]  9 |    | 10
 ]    C----D
 ]      10
 ]
 ]  TE-tunnel from A to B, relative -5.
 ]  Source node - A.
 ]  SPT (without TE-tunnels):
 ]        A
 ]    10 / \ 9
 ]      B  C
 ]         | 10
 ]         D
 ]
 ]
 ]Case 1: Using TE-tunnels as IGP links
 ]If we use TE-tunnels after building the SPF tree, we
 ]will get:
 ]        A
 ]     5 / \ 9
 ]      B  C
 ]         | 10
 ]         D
 ]
 ]But, if we look at the TE-tunnel as a link with cost 5
 ](10-5), and use it through the build of the SPT, we'll
 ]get:
 ]
 ]        A
 ]     5 / \ 9
 ]      B  C
 ]   10 |
 ]      D
 ]
 ]
 ]Topology B:
 ]      
 ]      A
 ]  10 / \ 9
 ]    /   \
 ]   B----C
 ]     10
 ]
 ]  TE-tunnel from A to B, relative -5.
 ]  Source node - A.
 ]  There is network X between B and C.
 ]  SPT (without TE-tunnels):
 ]        A
 ]    10 / \ 9
 ]      B  C
 ]         | 10
 ]         X
 ]  
 ]Case 2: Use TE-tunnels after building the nodes (ISs)
 ]of the SPF tree, but before adding the leafs (IP
 ]reachability).
 ]The result:
 ]
 ]        A
 ]     5 / \ 9
 ]      B  C
 ]   10 |
 ]      X
 ]
 ]Case 3: Use TE-tunnels after building the whole SPF
 ]tree (nodes and leafs).
 ]The result:
 ]
 ]        A
 ]     5 / \ 9
 ]      B  C
 ]         | 10
 ]         X
 ]
 ]
 ]Case 3 is routing-loop-free.
 ]Cases 1 and 2 can create routing-loops. To avoid it,
 ]we must not allow negative links in the graph (it
 ]seems impossible with the absolute metric type).
 ]
 ]My question is - which of the above cases is the one
 ]the draft refers to?
 ]
 ]Nagi
 ]
 ]--- Naiming Shen <[email-masked]> wrote:
 ]>  ]Hi,
 ]>  ]
 ]>  ]I have some wonders about several issues in the
 ]> draft
 ]>  ]"draft-hsmit-mpls-igp-spf-00.txt".
 ]>  ]
 ]>  ]1. In secrion 6.1: "The relative metric is bounded
 ]> by
 ]>  ]minimum and maximum allowed metric values" 
 ]>  ]Is there any use for maximum value higher than 1?
 ]>  ]As I see it, any positive relative metric causes
 ]> the
 ]>  ]TE-tunnel not to be used by the IGP, so there is
 ]> no
 ]>  ]need for more than one positive value.
 ]> 
 ]> yes, it is not useful for relative metric > +1 if
 ]> the igp
 ]> load sharing scheme is equal-cost.
 ]> 
 ]> but there is no need to restrict it as long as you
 ]> know it will not
 ]> be used. if a paricular native path has metric of
 ]> 10, and you set
 ]> absolute metric to 15, assume the native path does
 ]> not change,
 ]> it's equivalent to setting the relative metric to +5
 ]> here.
 ]> 
 ]>  ]
 ]>  ]2. In section 4: "Traffic to nodes that are
 ]> downstream
 ]>  ]of the tail-end nodes will also flow over those
 ]>  ]TE-tunnels"
 ]>  ]I find the word "downstream" a little bit
 ]> problematic.
 ]>  ]It can be downstream to the node on the SPF tree
 ]> OR
 ]>  ]downstream to the node on the IGP topology graph.
 ]>  ]I think it refers to the SPF tree, but is there
 ]> any
 ]>  ]prevention from using TE-tunnels, as shortcuts, on
 ]> the
 ]>  ]
 ]>  ]IGP topology graph instead of on the SPF tree? It
 ]>  ]looks like it will give more functionality and
 ]> meaning
 ]>  ]to the word "shortcuts". Of course we have to be
 ]>  ]careful form routing loops, but with some basic
 ]> rules
 ]>  ]it is possible... :)
 ]> 
 ]> i can't parse your sentence here, what is
 ]> "downstream to SPF"
 ]> vs "downstream to IGP topology graph"?
 ]> how can you "form routing loops"? can you give an
 ]> example
 ]> which actually causes routing loops?
 ]> 
 ]> 
 ]> - Naiming
 ]> _______________________________________________
 ]> Isis-wg mailing list  - 
 ]> [email-masked]
 ]> http://external.juniper.net/mailman/listinfo/isis-wg
 ]
 ]
 ]
 ]
 ]
 ]
 ]__________________________________________________
 ]Do You Yahoo!?
 ]Send your FREE holiday greetings online!
 ]http://greetings.yahoo.com

- Naiming
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Nagasta Bagamba <[email-masked]>
Date: Wed, 2 Jan 2002 12:26:36 -0800 (PST)

Hi,

I understood from your answer that case 2 is the one
the draft refers to.

I'll give an example, which in my opinion causes
routing-loops.

The topology:

    10  5   30  60      
  A---B---C---D---E
  |               |
  +---------------+
        10

Description in words: A through E are connected in a
line. E is also connected to A (creating kind of a
circle). The metrics: A-B is 10, B-C is 5, C-D is 30,
D-E is 60, E-A is 10. There is TE-tunnel from A to C.
A is the source node. X is the network between D and
E.

SPT (without TE-tunnels):
     A
10  / \ 10
   B  E
 5 |  | 60
   C  X
30 |  
   D

You wrote in (c): "the downstream nodes will inherit
the mpls tunnel metric properties, so all the routes
announced by the downstream nodes will inherit the
mpls tunnel metric property, it varies depends on
relative or absolute."

Section 6.1 in the draft: "When using an absolute
metric on a TE-tunnel, the cost of the IP routes in
the routing table does not depend on the topology of
the network. Note that this fixed metric is not only
used to compute the cost of IP routes advertised by
the router that is the tail-end of the TE-tunnel, but
also for all the routes that are downstream of this
tail-end router."

The following example is based on the above.

Example: TE-tunnel with absolute metric 1.

If we'll use the TE-tunnel in the SPF, node C will use
the TE-tunnel because it is the tail-end node. Node D
will use it as well, because it is downstream to C and
though inherits its TE-tunnel metric property.
Therefore, the cost to C and D are both 1. So, A will
install route to X with metric 1 and the TE-tunnel as
its next-hop.
Let's take a look at B and C. B and C know nothing
about TE-tunnels. They compute normal SPF. B will
install route to X with metric 80 (10+10+60) and with
next-hop A. C will install route to X with metric 85
(5+10+10+60) and with next-hop B.
Now, suppose a packet reach A, and its destination is
network X. A will forward the packet to C, through the
TE-tunnel. C will forward it to B. B will farward it
back to A, and we have a routing-loop...

Similar scenario can happen with relative metrics.

Regards,
Nagi

>  ]Those cases refers especially to the leafs (IPs)
=== message truncated ===

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Wed, 02 Jan 2002 14:43:15 -0800

]Hi,
 ]
 ]I understood from your answer that case 2 is the one
 ]the draft refers to.
 ]
 ]I'll give an example, which in my opinion causes
 ]routing-loops.
 ]
 ]The topology:
 ]
 ]    10  5   30  60      
 ]  A---B---C---D---E
 ]  |               |
 ]  +---------------+
 ]        10
 ]
 ]Description in words: A through E are connected in a
 ]line. E is also connected to A (creating kind of a
 ]circle). The metrics: A-B is 10, B-C is 5, C-D is 30,
 ]D-E is 60, E-A is 10. There is TE-tunnel from A to C.
 ]A is the source node. X is the network between D and
 ]E.
 ]
 ]SPT (without TE-tunnels):
 ]     A
 ]10  / \ 10
 ]   B  E
 ] 5 |  | 60
 ]   C  X
 ]30 |  
 ]   D
 ]
 ]You wrote in (c): "the downstream nodes will inherit
 ]the mpls tunnel metric properties, so all the routes
 ]announced by the downstream nodes will inherit the
 ]mpls tunnel metric property, it varies depends on
 ]relative or absolute."
 ]
 ]Section 6.1 in the draft: "When using an absolute
 ]metric on a TE-tunnel, the cost of the IP routes in
 ]the routing table does not depend on the topology of
 ]the network. Note that this fixed metric is not only
 ]used to compute the cost of IP routes advertised by
 ]the router that is the tail-end of the TE-tunnel, but
 ]also for all the routes that are downstream of this
 ]tail-end router."

i think i should add that the routes using the tunnel will
inherit the tunnel metric properties.

in your case, A first put B and E on path with cost of 10.
when C is on the PATH, it finds the C has a tunnel with metric
of 1. its like A to C has the metric of 1.
D is C's down stream, D will be on the PAH of metric of 31.
Since both D and E have the network X with metric of 60,
A->E path will set it to 70, and A->C->D will "set" it to 91.
So A will not use the tunnel as nexthop, so that the X can't
be set to 1.

there was lots of discussion on the absolute metric, should it
"float" after the tail-end node, or just set all the routes
using this tunnel to the fixed value. at that time, we decided
to set it fixed. but that does not affect the "normal" spf
procedure putting the nodes on the path.

thanks.

 ]
 ]The following example is based on the above.
 ]
 ]Example: TE-tunnel with absolute metric 1.
 ]
 ]If we'll use the TE-tunnel in the SPF, node C will use
 ]the TE-tunnel because it is the tail-end node. Node D
 ]will use it as well, because it is downstream to C and
 ]though inherits its TE-tunnel metric property.
 ]Therefore, the cost to C and D are both 1. So, A will
 ]install route to X with metric 1 and the TE-tunnel as
 ]its next-hop.
 ]Let's take a look at B and C. B and C know nothing
 ]about TE-tunnels. They compute normal SPF. B will
 ]install route to X with metric 80 (10+10+60) and with
 ]next-hop A. C will install route to X with metric 85
 ](5+10+10+60) and with next-hop B.
 ]Now, suppose a packet reach A, and its destination is
 ]network X. A will forward the packet to C, through the
 ]TE-tunnel. C will forward it to B. B will farward it
 ]back to A, and we have a routing-loop...
 ]
 ]Similar scenario can happen with relative metrics.
 ]
 ]Regards,
 ]Nagi
 ]
 ]--- Naiming Shen <[email-masked]> wrote:
 ]> 
 ]> 
 ]> A couple of points need to be emphasized on this
 ]> "shortcut" draft,
 ]> it was authors fault not including those in the
 ]> original draft.
 ]> I hope this will clear some of the confusions:
 ]> 
 ]>  (a) the igp shortcut is not a neighbor adjacency,
 ]> it affects only
 ]>      how the routes being installed in the local
 ]> routing table.
 ]>  (b) the decision to use the mpls tunnel is AFTER
 ]> the node being put
 ]>      on the PATH list during the spf calculation,
 ]> assume the node is
 ]>      the mpls tunnel tail-end.
 ]>  (c) the downstream nodes will inherit the mpls
 ]> tunnel metric
 ]>      properties, so all the routes announced by the
 ]> downstream nodes
 ]>      will inherit the mpls tunnel metric property,
 ]> it varies depends
 ]>      on relative or absolute. the downstream nodes
 ]> can be thought of
 ]>      as all the adjacent neighbors of the tail-end
 ]> node, except for
 ]>      the nodes already on the PATH list; and their
 ]> downstreams.
 ]>  (d) if there are multiple mpls tunnels to the same
 ]> node, only the
 ]>      best(lowest) metric ones are being used, and
 ]> only the ones
 ]>      better than or equal to the native metric are
 ]> being used.
 ]>  (e) if a downstream node has multiple upstream
 ]> paths, then the best
 ]>      metric paths win. this is no different from the
 ]> "normal" spf.
 ]> 
 ]> looking at your examples, according to this draft,
 ]> my answer is
 ]> just opposite to your picks:
 ]> 
 ]> topology A, case 1, it will be the second graph,
 ]> routes advertised
 ]> by "D" will have metric of 15 plus whatever the cost
 ]> from D to those
 ]> networks.
 ]> 
 ]> topology B, case 2, yes, A will install X with
 ]> metric of 15 using
 ]> the tunnel towards B.
 ]> 
 ]> topology B, case 3, no, A will not install this X
 ]> with metric of 19.
 ]> 
 ]> 
 ]> pls read (a) through (e) carefully, and see if you
 ]> still think they
 ]> can create routing-loops. If still do, please give
 ]> examples on
 ]> how the routing loops will exist.
 ]> 
 ]> thanks.
 ]> 
 ]>  ]Hi,
 ]>  ]
 ]>  ]I'm sorry, my second question wasn't clear enough.
 ]>  ]I'll try to explain my question through examples.
 ]>  ]There are 3 ways to use TE-tunnels as shortcuts.
 ]> I'll
 ]>  ]explain each one of them through examples. 
 ]>  ]Topology A will be used for introducing case 1.
 ]> This
 ]>  ]case refers just to the nodes (ISs) in the
 ]> topology,
 ]>  ]not to the leafs (IPs).
 ]>  ]Topology B will be used for introducing cases 2
 ]> and 3.
 ]>  ]Those cases refers especially to the leafs (IPs)
 ]> of
 ]>  ]the tree.
 ]>  ]
 ]>  ]Topology A:
 ]>  ]      
 ]>  ]      10
 ]>  ]    A----B
 ]>  ]  9 |    | 10
 ]>  ]    C----D
 ]>  ]      10
 ]>  ]
 ]>  ]  TE-tunnel from A to B, relative -5.
 ]>  ]  Source node - A.
 ]>  ]  SPT (without TE-tunnels):
 ]>  ]        A
 ]>  ]    10 / \ 9
 ]>  ]      B  C
 ]>  ]         | 10
 ]>  ]         D
 ]>  ]
 ]>  ]
 ]>  ]Case 1: Using TE-tunnels as IGP links
 ]>  ]If we use TE-tunnels after building the SPF tree,
 ]> we
 ]>  ]will get:
 ]>  ]        A
 ]>  ]     5 / \ 9
 ]>  ]      B  C
 ]>  ]         | 10
 ]>  ]         D
 ]>  ]
 ]>  ]But, if we look at the TE-tunnel as a link with
 ]> cost 5
 ]>  ](10-5), and use it through the build of the SPT,
 ]> we'll
 ]>  ]get:
 ]>  ]
 ]>  ]        A
 ]>  ]     5 / \ 9
 ]>  ]      B  C
 ]>  ]   10 |
 ]>  ]      D
 ]>  ]
 ]>  ]
 ]>  ]Topology B:
 ]>  ]      
 ]>  ]      A
 ]>  ]  10 / \ 9
 ]>  ]    /   \
 ]>  ]   B----C
 ]>  ]     10
 ]>  ]
 ]>  ]  TE-tunnel from A to B, relative -5.
 ]>  ]  Source node - A.
 ]>  ]  There is network X between B and C.
 ]>  ]  SPT (without TE-tunnels):
 ]>  ]        A
 ]>  ]    10 / \ 9
 ]>  ]      B  C
 ]>  ]         | 10
 ]>  ]         X
 ]>  ]  
 ]>  ]Case 2: Use TE-tunnels after building the nodes
 ]> (ISs)
 ]>  ]of the SPF tree, but before adding the leafs (IP
 ]>  ]reachability).
 ]>  ]The result:
 ]>  ]
 ]>  ]        A
 ]>  ]     5 / \ 9
 ]>  ]      B  C
 ]>  ]   10 |
 ]>  ]      X
 ]>  ]
 ]>  ]Case 3: Use TE-tunnels after building the whole
 ]> SPF
 ]>  ]tree (nodes and leafs).
 ]>  ]The result:
 ]>  ]
 ]>  ]        A
 ]>  ]     5 / \ 9
 ]>  ]      B  C
 ]>  ]         | 10
 ]>  ]         X
 ]>  ]
 ]>  ]
 ]>  ]Case 3 is routing-loop-free.
 ]>  ]Cases 1 and 2 can create routing-loops. To avoid
 ]> it,
 ]>  ]we must not allow negative links in the graph (it
 ]>  ]seems impossible with the absolute metric type).
 ]>  ]
 ]>  ]My question is - which of the above cases is the
 ]> one
 ]>  ]the draft refers to?
 ]>  ]
 ]>  ]Nagi
 ]>  ]
 ]>  ]--- Naiming Shen <[email-masked]> wrote:
 ]>  ]>  ]Hi,
 ]>  ]>  ]
 ]>  ]>  ]I have some wonders about several issues in
 ]> the
 ]>  ]> draft
 ]>  ]>  ]"draft-hsmit-mpls-igp-spf-00.txt".
 ]>  ]>  ]
 ]>  ]>  ]1. In secrion 6.1: "The relative metric is
 ]> bounded
 ]>  ]> by
 ]>  ]>  ]minimum and maximum allowed metric values" 
 ]>  ]>  ]Is there any use for maximum value higher than
 ]> 1?
 ]>  ]>  ]As I see it, any positive relative metric
 ]> causes
 ]>  ]> the
 ]>  ]>  ]TE-tunnel not to be used by the IGP, so there
 ]> is
 ]>  ]> no
 ]>  ]>  ]need for more than one positive value.
 ]>  ]> 
 ]> 
 ]=== message truncated ===
 ]
 ]
 ]
 ]__________________________________________________
 ]Do You Yahoo!?
 ]Send your FREE holiday greetings online!
 ]http://greetings.yahoo.com

- Naiming

---

From: Dong Ha <[email-masked]>
Date: Thu, 3 Jan 2002 12:15:16 -0800 (PST)

Hello everyone,

Sorry for this off topic but could anyone tell me some
mailing lists for BGP-4? Thanks.

Dong