Subject: [Isis-wg] ISIS Adjacency IP Address Table

From: Aravind Ravikumar <[email-masked]>
Date: Mon, 31 Dec 2001 02:28:11 -0800 (PST)

Hi,

Currently, the entry in the Adjacency IP Address Table is indexed as follows:

1. Instance    2. Circuit Index         3. isisIsAdjIpAddrAdjIndex

If a neighbor IS advertises more than One IP Interface Address in its HELLO Packets, then we may need some mapping mechanism

to know that these IP Addresses were advertised by this specific IS.  

In order to avoid such mechanisms, can't we have the Adjacency IP Address Table  as part of the Adjacency Table. 

( This will help in properly identifying each and all the Interfaces advertised by each IS).

Therefore is'nt it better to have the following Index:

1. Instance     2. Circuit Index      3. Adjacency Index       4. Adjacency IP Address Index  

Or can we have the following index:

1. Instance   2. Circuit Index       3. isisIsAdjIpAddrAdjIndex   4. Ip Address 

Is the above understanding correct ?

Please clear my doubt.

Thanking in advance.

---------------------------------
Do You Yahoo!?
Send your FREE holiday greetings online at Yahoo! Greetings.

---

From: Jeff Parker <[email-masked]>
Date: Wed, 2 Jan 2002 17:58:08 -0500

Aravind - 

Good point.  I will add a new index, isisISAdjIndex, to identify the
adjacency, and change the description of the remaining unique index.
The changes are included below.  

I will send you a current version of the mib by private mail.  

- jeff parker
- axiowave networks
- Cogito, ergo spud: I think, therefore I yam. 

     isisISAdjIPAddrTable OBJECT-TYPE
         SYNTAX SEQUENCE OF IsisISAdjIPAddrEntry
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "This table contains the set of IP Addresses of
             neighboring Intermediate Systems as reported in received
             IIH PDUs."
     ::= { isisISAdj 3 }

     isisISAdjIPAddrEntry OBJECT-TYPE
         SYNTAX IsisISAdjIPAddrEntry
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "Each entry contains one IP Address reported by a
             neighboring Intermediate System in its IIH PDUs."
         INDEX { isisSysInstance,
                 isisCircIndex,
                 isisISAdjIndex,			-- Added 
                 isisISAdjIPAddrAdjIndex
                 }
     ::= { isisISAdjIPAddrTable 1 }

     IsisISAdjIPAddrEntry ::=
         SEQUENCE {
             isisISAdjIPAddrAdjIndex
                 Integer32,
             isisISAdjIPAddressType
                  InetAddressType,
             isisISAdjIPAddress
                 InetAddress
         }

     isisISAdjIPAddrAdjIndex OBJECT-TYPE
         SYNTAX Integer32 (1..2000000000)
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "An index to this table which identifies the IP addresss 
              to which this entry belongs."
     ::= { isisISAdjIPAddrEntry 1 }

-----Original Message-----
From: Aravind Ravikumar [mailto:[email-masked]]
Sent: Monday, December 31, 2001 5:28 AM
To: [email-masked]
Subject: [Isis-wg] ISIS Adjacency IP Address Table

Hi,
Currently, the entry in the Adjacency IP Address Table is indexed as
follows:
1. Instance    2. Circuit Index         3. isisIsAdjIpAddrAdjIndex
If a neighbor IS advertises more than One IP Interface Address in its HELLO
Packets, then we may need some mapping mechanism
to know that these IP Addresses were advertised by this specific IS.  
In order to avoid such mechanisms, can't we have the Adjacency IP Address
Table  as part of the Adjacency Table. 
( This will help in properly identifying each and all the Interfaces
advertised by each IS).
Therefore is'nt it better to have the following Index:
1. Instance     2. Circuit Index      3. Adjacency Index       4. Adjacency
IP Address Index  
Or can we have the following index:
1. Instance   2. Circuit Index       3. isisIsAdjIpAddrAdjIndex   4. Ip
Address 
Is the above understanding correct ?
Please clear my doubt.
Thanking in advance.
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg