Subject: [Isis-wg] Making the update reliable

From: Koen Vermeulen <[email-masked]>
Date: Wed, 23 Jan 2002 19:24:42 +0100

Hello,

I have a question concerning ISO/IEC 10589 7.3.17 'Making the
update reliable'. At the end of this section is written for
point-to-point circuits:

    When a point-to-point circuit (including non-DA DED circuits
    and virtual links) starts (or restarts), the IS shall

        a) set SRMflag for that circuit on all LSPs, and

        b) send a Complete set of Complete Sequence Numbers PDUs
           on that circuit.

My question is now: what is actually meant with this
'start' (or 'restart') of a circuit? Do they mean an
adjacency state change to 'up', or is it really the circuit
which physically gets ready to send l2-frames?
If the second answer is what is meant, then I don't
understand why a CSNP is sent. This PDU will
be thrown away anyhow by the receiving side if there is
no adjacency (see 7.3.15.2 7:

    If the SNP is received on a non-broadcast circuit and
    there is no adjacency of the same level (e.g. a level 1 SNP
    with a level 1 or level 1 & 2 adjacency) on the circuit
    over which the SNP was received, then the IS shall
    discard the SNP without generating a event.

).
So how can this mechanism make the update reliable? Or am I
missing something?

Regards,
Koen

---

From: "Ramalingam, Swaminathan" <[email-masked]>
Date: Thu, 24 Jan 2002 02:12:15 -0500

Keon,
 
Whenever an adjacency comes up (may be because of start/restart) , CSNPs are
sent on p2p links.You can't send control packets without adjacency.
 
"Making the update reliable" means how the flooding made reliable using
periodic CSNPs in bcast network, ack to PSNPs in p2p networks and sending
CSNPs on p2p network when it start/restarts.
 
- Swami

-----Original Message-----
From: Koen Vermeulen [mailto:[email-masked]]
Sent: Wednesday, January 23, 2002 11:55 PM
To: Isis-wg
Subject: [Isis-wg] Making the update reliable

Hello, 

). 

Regards, 
Koen