Subject: RE: [Isis-wg] When the next Seq. Number Exceeds Max. Sequence Num ber!

From: Jeff Learman <[email-masked]>
Date: Fri, 18 Jan 2002 12:01:25 -0500

No IS will be sending any LSPs with an LSP ID greater than
0xFFFFFFFF, because it won't fit in the 32 bits provided.  So
an implementation does not have to deal with receiving an LSP
with too large a sequence number.

If a router finds it has generated an LSP 4 billion times and
is about to exceed the sequence number space, it just shuts down
for a while and starts over.

If a system is regenerating its LSP every second for 136 years this
would happen.  Most networks probably set their min lsp regen timer
to greater than 1 second, so it would take longer in those networks ;-)

Regards,
Jeff

Note: I do not work in IS-IS at Cisco and do not represent Cisco
in these discussions.

At 11:13 AM 1/18/2002, Chan, Chung Ming wrote:
>Harish,
>
>I was troubled with the word "Disabled." 
>
>Like in P2P circuit, should the IS Ack the received LSP with PSNP or just do
>nothing until the elapse of MaxAge + ZeroAgeLifetime seconds then send LSP
>with SN=1? 
>
>Should there be no action on the LSP be taken by the IS until MaxAge +
>ZeroAgeLifetime seconds have passed?
>
>Ming
>
>
>============================================================================
>====
>Hi
> When the LSP sequence number reaches a max sequence value (say fffffff ) ,
>the next sequence number that is allocated for a new LSP by an IS is 1 . But
>since 1 < fffffff , the LSP with seq=1 will be discarded if transmitted
>immediately.
>
>So the IS waits  MaxAge (time for the Remaininglifetime/age field of the LSP
>(seq=ffffff) to get to zero ) + ZeroAgeLifetime (for the zero age LSP to
>timeout and be purged from all routers database) , before transmitting the
>new LSP.
>
>rgds
>Harish
>
>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Chan, Chung Ming
>Sent: Thursday, January 17, 2002 6:15 PM
>To: [email-masked]
>Cc: Chan, Chung Ming
>Subject: [Isis-wg] When the next Seq. Number Exceeds Max. Sequence
>Number!
>
>
>Hi,
>
>When the next Seq. Number Exceeds Max. Sequence Number!
>
>I'm reading to ISO/IEC10589, Section7.3.16.1 and not quite understand what
>the text means when it talks about "... the IS Network entity shall be
>disabled for a period of at least MaxAge + ZeroAgeLifetime, ..."
>
>"...
>If an Intermediate system needs to increment its sequence
>number, but the sequence number is already equal to
>SequenceModulus - 1, the event attemptToExceed-
>MaximumSequenceNumber shall be generated and the IS
>Network entity shall be disabled for a period of at least
>MaxAge + ZeroAgeLifetime, in order to be sure that any ver-
>sions of this LSP with the high sequence number have expired.
>When it is re-enabled the IS shall start again with sequence
>number 1.
>..."
>
>What is the IS supposed to do with the LSP in question?
>What is the IS itself supposed to do?
>
>
>Thanks,
>
>
>Ming Chan
>_______________________________________________
>Isis-wg mailing list  -  [email-masked]
>http://external.juniper.net/mailman/listinfo/isis-wg
>_______________________________________________
>Isis-wg mailing list  -  [email-masked]
>http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Harish Balasubramaniam" <[email-masked]>
Date: Fri, 18 Jan 2002 10:59:35 -0800

Few queries
1) A bad/hacked router can intentionally exploit this scenario by changing
some LSPs sequence number to 0xffffffff and flooding it to the network.
If the original router(source of the hacked LSP) receives this LSP , then
what should it do?
2) Shouldnt the router send a zero age LSP to purge the LSP (seq=fffffff)
 instead of waiting (MaxAge + zeroagelifetime) , so that scenarios like 1
can be handled ?

rgds
Harish
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jeff Learman
Sent: Friday, January 18, 2002 9:01 AM
To: Chan, Chung Ming
Cc: 'Harish Balasubramaniam'; Chan, Chung Ming; [email-masked]
Subject: RE: [Isis-wg] When the next Seq. Number Exceeds Max. Sequence
Num ber!

Regards,
Jeff

---

From: Jeff Learman <[email-masked]>
Date: Fri, 18 Jan 2002 14:21:44 -0500

A hacked router could just as easily change some LSP sequence number
to 0xfffffffe, or 0xfffff000.  There is nothing special about the
value 0xffffffff, except that you won't ever generate its successor.
Where should one arbitrarily draw a line and assume that an LSP is
bad because its sequence number is "too high"?  The way to avoid
hacked routers is to use authentication.

A receiving router does not wait based on the sequence of an LSP.
A router that's about to generate its own LSP but finds it would need to
wrap the sequence number is the only one required to basically shut down
and wait.  And as I said earlier, this is unlikely to happen as I can't
imagine a system remaining up for a thousand years or more.  In any
case, we won't need to worry about it in our lifetimes!  Or our children's!

Regards,
Jeff

---

From: Dave Katz <[email-masked]>
Date: Fri, 18 Jan 2002 12:26:53 -0800 (PST)

Yes, but at least you can't packet-bomb from the outside like OSPF.  It
should do what the spec says.

No, because you can't guarantee that all remnants of the all-ones sequence
LSP are gone unless you wait the full time.  Easy scenario--the network
becomes partitioned while high-numbered LSPs are in existence but
before the purge takes place.  If the partition heals, the high-numbered
LSPs will be viewed as newer.  The only way to guarantee that everything
is cleaned up is to wait.
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg