Subject: RE: [Isis-wg] IS-IS on UPSR ring

From: "Philip Christian"<[email-masked]>
Date: Mon, 22 Apr 2002 15:26:27 +0100

Specifically (according to G.7712):-

IP-only Integrated IS-IS NEs use PPP over HDLC in DCC.
OSI-only IS-IS NEs use LAPD over DCC.
Dual Integrated IS-IS NEs need a switchable (PPP or LAPD) data link layer.

Philip

> -----Original Message-----
> From: Jeff Learman [mailto:[email-masked]]
> Sent: 22 April 2002 15:15
> To: Lawrence Mao
> Cc: [email-masked]
> Subject: Re: [Isis-wg] IS-IS on UPSR ring
> 
> 
> 
> Laurence,
> 
> This isn't really an IS-IS question, it's a SONET question.  For SONET
> DCC, you run IS-IS over LAP-B (or possibly PPP).  In either case, dual
> fiber counter-directional rings are required.  To the 
> software, you must
> make it look like there is a bidirectional link between A and B, using
> the clockwise ring for transmit and the counterclockwise ring for
> receive.
> 
> For single-fiber rings, you would need a proprietary solution.  You
> could try something like Token Ring at the link layer and make the
> ring look like a TR broadcast LAN.
> 
> Regards,
> Jeff
> 
> At 07:33 PM 4/19/2002, Lawrence Mao wrote:
> >Hi all,
> >
> >If the IS-IS needs to be supported on a SONET
> >UPSR ring, throught its DCC channel (note that
> >the ring is uni-directional), say, if I have 4
> >nodes on a ring:
> >
> >    A --> B --> C --> D -
> >    ^                    |
> >    |--------------------
> >
> >what kind of modifications need to be made in
> >order to let the protocol work properly (note
> >all interfaces are p2p type)?
> >
> >2nd question is, if the interface is unnumbered,
> >how is its routing table generated? Use routerID?
> >
> >Thanks,
> >--
> >Lawrence
> >
> >__________________________________________________
> >Do You Yahoo!?
> >Yahoo! Tax Center - online filing with TurboTax
> >http://taxes.yahoo.com/
> >_______________________________________________
> >Isis-wg mailing list  -  [email-masked]
> >http://spider.juniper.net/mailman/listinfo/isis-wg
> 
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://spider.juniper.net/mailman/listinfo/isis-wg
>

---

From: Mike Truskowski <[email-masked]>
Date: Mon, 22 Apr 2002 07:52:28 -0700 (PDT)

G.7712 also states that OSPF is an option.

:-)

Mike

Philip

Philip