Subject: [Isis-wg] Integrated IS-IS in distributed architecture

From: nabendu das <[email-masked]>
Date: Sat, 27 Apr 2002 01:08:27 -0700 (PDT)

hi all,
      I have few concerns regarding running IS-IS in
distributed architecture. 
      In case of distributed architecture, generally
we have several routing engines within a router, where
each of the routing engine act as an independent
router internally. So we need to run IS-IS internally
among the routing engines to make control information
consistent among the routing engines. We can make some
changes to run it or can add up new PDU type that will
be propagated only internally. But as each of the
routing engines are generating there own LSPs then how
can we synchronise the sequence no.s among the routing
engines because to the outside world, the router
should appear as a single entity. It should appear as
a single router only. So the sequnce nos also should
be kept synchronized because each routing engines can
not put there own MAC address in the LSPID, as in that
case all the routing engines will be treated as
independent router. this can be handled by putting the
same MAC address for all the LSPs generated by all the
routing engines. but then what about Sequence no. this
also should be synchronized.

PLz help in this regard.

__________________________________________________
Do You Yahoo!?
Yahoo! Health - your guide to health and wellness
http://health.yahoo.com
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Przygienda <[email-masked]>
Date: Sat, 27 Apr 2002 14:09:56 -0700

>also should be synchronized.
Nabendu,

First, this list is not the right forum to discuss this topic, we should 
be concerned
here with the interoperability aspects _between_ systems and not internal
implementation details like this one.

Second, you have or make a lot of assumptions of what your system looks
internally like. Many people solve the problem differently and their 
architectures
vary widely from yours. A distributed system is a vague concept in terms of
routing protocols and many people choose to replicate or partition the
functionality of the protocol very differently from what you suggest. I can
recommend some of the modern books on distributed operating systems or
databases to give you food for thoughts.

And, looks like your company (and I don't assume yahoo has this problem ;-)
may be in some need of a good system architect  ;-)

    -- tony

---

From: Tony Li <[email-masked]>
Date: Mon, 29 Apr 2002 17:31:43 -0700

Whatever you decide to do, the rest of the world shouldn't ever know about
it.  

;-)

Tony

nabendu das writes:
 | hi all,
 |       I have few concerns regarding running IS-IS in
 | distributed architecture. 
 |       In case of distributed architecture, generally
 | we have several routing engines within a router, where
 | each of the routing engine act as an independent
 | router internally. So we need to run IS-IS internally
 | among the routing engines to make control information
 | consistent among the routing engines. We can make some
 | changes to run it or can add up new PDU type that will
 | be propagated only internally. But as each of the
 | routing engines are generating there own LSPs then how
 | can we synchronise the sequence no.s among the routing
 | engines because to the outside world, the router
 | should appear as a single entity. It should appear as
 | a single router only. So the sequnce nos also should
 | be kept synchronized because each routing engines can
 | not put there own MAC address in the LSPID, as in that
 | case all the routing engines will be treated as
 | independent router. this can be handled by putting the
 | same MAC address for all the LSPs generated by all the
 | routing engines. but then what about Sequence no. this
 | also should be synchronized.
 | 
 | PLz help in this regard.
 | 
 | __________________________________________________
 | Do You Yahoo!?
 | Yahoo! Health - your guide to health and wellness
 | http://health.yahoo.com
 | _______________________________________________
 | Isis-wg mailing list  -  [email-masked]
 | http://spider.juniper.net/mailman/listinfo/isis-wg
 | _______________________________________________
 | Isis-wg-external mailing list
 | [email-masked]
 | http://mailist.procket.com/mailman/listinfo/isis-wg-external
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg