Subject: [Isis-wg] RE:draft-ietf-isis-ipv6-05.txt

From: "Jonnala, Nagi" <[email-masked]>
Date: Thu, 16 Jan 2003 07:29:34 -0500

Chris,

According to the draft, adjacency formation between IPv4-only 
and IPv6-only routers is not clear.

Do they form adjacency at all? If they don't form
we might need to specify it in Section.5 - IPV6 NLPID.

If we do form adjacency and we can't forward the traffic, 
we need to have a section similar to 4.5 of RFC1195 - 
"Forwarding to Incompatible Routers".

Thanks
Nagi.

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Thu, 16 Jan 2003 15:11:47 +0100

On Thu, Jan 16, 2003 at 07:29:34AM -0500, Jonnala, Nagi wrote:
| Chris,
| 
| According to the draft, adjacency formation between IPv4-only 
| and IPv6-only routers is not clear.
| 
| Do they form adjacency at all? If they don't form
| we might need to specify it in Section.5 - IPV6 NLPID.

what we have seen so far in the field is:
 if there is no matching subnet of the
 same adress family then the adjacency does not come up.
 i.e. IPv4-only and IPv6-only routers won't form an adjacency;

/hannes

---

From: Naiming Shen <[email-masked]>
Date: Tue, 21 Jan 2003 11:34:37 -0800

there is always a problem of DIS election on the LAN when multiple
address families involved. or the same address family but multiple
topologies exist such as in M-ISIS case.

i would think it's much simpler to ALWAYS establish IS adjacency
with neighbors regardless of their common NLPIDs. this way, we
guarantee that there will be a single DIS elected on the LAN for
isis. but locally, label each adjacency to be "usable" or "non-usable".
a router can only forward traffic to a "usable" adjacency. an
adjacency is "usable" if the neighbor has at least one common NLPID
(or topology id). we install the IS neighbor TLV in the LSP only if
there exist at least one "usable" adjacency on the LAN. the psedo-node
lsp should contain all the adacencies, "usable" and "non-usable".

thanks.

 ] On Thu, Jan 16, 2003 at 07:29:34AM -0500, Jonnala, Nagi wrote:
 ] | Chris,
 ] | 
 ] | According to the draft, adjacency formation between IPv4-only 
 ] | and IPv6-only routers is not clear.
 ] | 
 ] | Do they form adjacency at all? If they don't form
 ] | we might need to specify it in Section.5 - IPV6 NLPID.
 ] 
 ] what we have seen so far in the field is:
 ]  if there is no matching subnet of the
 ]  same adress family then the adjacency does not come up.
 ]  i.e. IPv4-only and IPv6-only routers won't form an adjacency;
 ] 
 ] /hannes
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming

---

From: Noguchi Kay <[email-masked]>
Date: Wed, 29 Jan 2003 11:22:31 -0800

Hi Naiming and all,

I wrote a draft which tackles this problem.

http://www.ietf.org/internet-drafts/draft-noguchi-isis-protocol-topology.txt

This draft introduces "Protocols Supported Sub-TLV" in Extended IS Reachability
TLV to keep the neighboring router's NLPID information and create protocol
specific SPF tree for each network layer protocol using that information.

In this way, IPv4 router, IPv6 router and IPv4/IPv6 dual router can co-exist
in a single routing domain.

Any comments?

Thank you,

								kay

At Tue, 21 Jan 2003 11:34:37 -0800,

---

From: Noguchi Kay <[email-masked]>
Date: Wed, 29 Jan 2003 20:12:44 -0800

Hi Nagi and all,

Sorry for the typo.
Correct URL is as below.

http://ietf.org/internet-drafts/draft-noguchi-isis-protocol-topology-00.txt

Thank you,

								kay

---

From: Koen Vermeulen <[email-masked]>
Date: Thu, 30 Jan 2003 08:15:28 +0100

Hello Noguchi,

I clicked on the link you specified, but it seems this one isn't correct (anymore).

Is there another way I can get this draft?

Thanks,
Koen