Subject: [Isis-wg] advertising P2P neighbors address in LSPs and IPv6

From: Saravana Kumar <[email-masked]>
Date: Tue, 28 Jan 2003 03:46:26 -0700

Hi,

Once an adjacency is extablished over a P2P link, we advertise the neighbors IP 
address in our LSP's as internal reachability info. Is it mandatory and if so, is 
there any specific reason for doing so ?

Because currently in IPv6 it is not possible to advertise the P2P's neighbors 
address in the LSP's, since the neighbor sends us only the link-local addresses 
for the circuit in its hello PDU's. 

Thanks,
sarav
 
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Tue, 28 Jan 2003 12:29:20 +0100

On Tue, Jan 28, 2003 at 03:46:26AM -0700, Saravana Kumar wrote:
| Hi,
| 
| Once an adjacency is extablished over a P2P link, we advertise the neighbors IP 
| address in our LSP's as internal reachability info. Is it mandatory and if so, is 
| there any specific reason for doing so ?

its not mandatory, the major implementations do not advertise it 
and i would be curious if it was somebody with an OSPF background
who did implement this ?

/hannes

| Because currently in IPv6 it is not possible to advertise the P2P's neighbors 
| address in the LSP's, since the neighbor sends us only the link-local addresses 
| for the circuit in its hello PDU's.