Subject: RE: [Isis-wg] advertising P2P neighbors address in LSPs and IPv6

From: "Manral, Vishwas" <[email-masked]>
Date: Tue, 28 Jan 2003 06:12:44 -0500

Hi Sarav,

If you advertize reachability information in your LSP, it is used by the SPF
process in the routers. If you do not advertize it(delay advertizing it) the
other routers will not take the path to the destination thru you, but take
an alternate path(if one exists). 

It would not create any routing loops.

Thanks,
Vishwas

-----Original Message-----
From: Saravana Kumar [mailto:[email-masked]]
Sent: Tuesday, January 28, 2003 4:16 PM
To: [email-masked]
Subject: [Isis-wg] advertising P2P neighbors address in LSPs and IPv6

Hi,

Once an adjacency is extablished over a P2P link, we advertise the neighbors
IP 
address in our LSP's as internal reachability info. Is it mandatory and if
so, is 
there any specific reason for doing so ?

Because currently in IPv6 it is not possible to advertise the P2P's
neighbors 
address in the LSP's, since the neighbor sends us only the link-local
addresses 
for the circuit in its hello PDU's. 

Thanks,
sarav
 
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "SelvarajR" <[email-masked]>
Date: Thu, 30 Jan 2003 17:23:06 +0530

Hi,
I've also observed some implementations advertising P2P Neighbors IP address
in their LSP. Also, if the neighbors P2P link goes down the same
implementation updates the IP table that the network is reachable via the
P2P link, that is currently Down. The route info stays their till the
adjacency comes Down !! Now the route is updated as ISIS route. Before this
updation it was as directly connected route.
Ofcourse, it might be a bug with that implementation.
But I wonder how does it is useful to advertise P2P neighbors IP address.
Does it is not wrong in the scope of ISIS ?

Selva.

| -----Original Message-----
| From: [email-masked]
| [mailto:[email-masked]]On Behalf Of
| Manral, Vishwas
| Sent: Tuesday, 28 January 2003 4:43 PM
| To: [email-masked]'; [email-masked]
| Subject: RE: [Isis-wg] advertising P2P neighbors address in LSPs and
| IPv6
|
|
| Hi Sarav,
|
| If you advertize reachability information in your LSP, it is
| used by the SPF
| process in the routers. If you do not advertize it(delay
| advertizing it) the
| other routers will not take the path to the destination thru
| you, but take
| an alternate path(if one exists).
|
| It would not create any routing loops.
|
| Thanks,
| Vishwas
|
| -----Original Message-----
| From: Saravana Kumar [mailto:[email-masked]]
| Sent: Tuesday, January 28, 2003 4:16 PM
| To: [email-masked]
| Subject: [Isis-wg] advertising P2P neighbors address in LSPs and IPv6
|
|
| Hi,
|
| Once an adjacency is extablished over a P2P link, we
| advertise the neighbors
| IP
| address in our LSP's as internal reachability info. Is it
| mandatory and if
| so, is
| there any specific reason for doing so ?
|
| Because currently in IPv6 it is not possible to advertise the P2P's
| neighbors
| address in the LSP's, since the neighbor sends us only the link-local
| addresses
| for the circuit in its hello PDU's.
|
| Thanks,
| sarav
|
| _______________________________________________
| Isis-wg mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/isis-wg
| _______________________________________________
| Isis-wg mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/isis-wg
|

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg