Subject: [Isis-wg] ipv6 prefix length.

From: "Jonnala, Nagi" <[email-masked]>
Date: Tue, 7 Jan 2003 02:28:12 -0500

Chris,

I'm not sure if this was dicussed before. 

In IPv6 Reachability TLV, The Prefix Length field consists of 6 bits. 
So we can store the maximum unsigned value of 63(2^6 - 1).

which means we cannot have more than prefixlen of 63 in ipv6. Right?

Don't we need to be able to store the maximum prefix length of 128?

Please enlighten me on this issue.

Thanks
Nagi.

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Micah Bartell <[email-masked]>
Date: Tue, 7 Jan 2003 09:27:32 -0600

I believe the Interface ID in an IPv6 address is 64 bits long, this 
does not get subnetted down....

/mpb