Subject: [Isis-wg] isisRedistributeAddrTable question

From: "Jonnala, Nagi" <[email-masked]>
Date: Tue, 25 Feb 2003 06:58:46 -0500

Jeff,

After reading the table description my understanding is:

"Unlike in summary address table, all addresses that fall in the range
specified 
would be announced as it is without being summarized".

My questions are:

1) I have a route which doesn't fall in that range, then does it need
    be thrown away? or what is the behavior?

2) Why should Redistribute table behavior be different from summary address
table 
    at the conceptual level. i.e., advertise the summary prefix for the
routes that fall in the range, 
    otherwise advertise the route as it is.

Quick reference:

-- The Redistribution table defines addresses that should be leaked from
-- L2 to L1 if isisSysL2toL1Leaking is enabled.

    isisRedistributeAddrTable OBJECT-TYPE
        SYNTAX SEQUENCE OF IsisRedistributeAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
 
           "This table provides criteria to decide if a route should
             be leaked from L2 to L1 when Domain Wide Prefix leaking is
             enabled.

             Addresses that match the summary mask in the table will
             be announced at L1 by routers when isisSysL2toL1Leaking
             is enabled.  Routes that fall into the ranges specified
             are are announced as is, without being summarized."
    ::= { isisSystem 6 }

Thanks
Nagi.
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 25 Feb 2003 10:40:59 -0500

> After reading the isisRedistributeAddrTable description 
> 
> "Unlike in summary address table, all addresses that fall 
> in the range specified would be announced as it is without 
> being summarized".
> 
> 1) I have a route which doesn't fall in that range:
>     what is the behavior?

Don't leak it.  

> 2) Why should Redistribute table behavior be different 
> from the summary address table?
 
Jonnala -

	My thought was that leaking up should be the default 
behavior, and leaking down should be the exception.  I 
would expect that we don't want to leak down most routes.  

	But what is the experience of the group on this point?

- jeff parker

PS The new draft is in the queue, but as I waited until
the last minute to send it in, it may not appear for some
time.  If you are interested in seeing version 11, drop
me a private note and I'll be happy to send it.  
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg