Subject: Re: [Isis-wg] draft-noguchi-isis-protocol-topology-00.txt

From: "Philip Christian" <[email-masked]>
Date: Wed, 05 Feb 2003 20:04:05 +0000

> 
> I disagree.  An implementation that runs multiple SPFs will interoperate
> perfectly with one that doesn't in any topology that meets 1195's
> deployment restrictions, so there is NO interoperability problem until
> you go BEYOND RFC-1195.

Jeff, if a network meets 1195 deployment restrictions, then you don't need multiple SPFs.  The whole justification of multiple SPFs is that it allows you to break the 1195 deployment restrictions.  Once you do this then you cannot install a legacy 1195 box in the network, because you can't stop a legacy v4 node plotted a shortest path through a v6 only box.  If you read the Noguchi draft then its whole justification is that it allows one to break 1195 restrictions.  What you say is technically true but no defense of the Noguchi draft.

> 
> I have long been a supporter of running multiple SPFs (personally, not
> as a spokesman for Cisco).  However, it is clear to me that there is
> little or no support for this idea among router vendors.
> 
There is more to the Noguchi draft than multiple SPFs.  It says that two ISs MUST form an adjacency irrespective of protocols supported.  Last time I looked Cisco's implementation looked for an overlap of at least one of NLPIDs, which also is exactly what G.7712 says to do.  It will not be possible for an implementation to conform to both G.7712 and to the Noguchi draft.

> My suspicion now is that many IPV4/IPV6 migration issues can be
> mitigated by use of MPLS, and new complex schemes to allow arbitrary
> topologies are unnecessary.
> 
True. I also believe that the MT draft will allow folks to define that a subset of their network can route IPv6.  This WILL interwork with legacy nodes.  The Noguchi draft simply isn't needed as MT already does it.  If one wants to have multiple SPFs then no new standard is necessary, just use the MT draft.

With a combination of MT and autoencap then you have something very powerful.  You can have a general IPv4 legacy network.  Then you can use MT to define some nodes to be IPv6 and limit v6 to them.  The legacy nodes won't understand the MT and so will route through them anyway.  Then you use autoencap to autotunnel IPv4 through any IPv6-only MT nodes that happen to get in the way.

Philip

-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Wed, 05 Feb 2003 17:30:27 -0500

>Jeff, if a network meets 1195 deployment restrictions, then you don't need multiple SPFs.  The whole justification of multiple SPFs is that it allows you to break the 1195 deployment restrictions.…

"Technically true" is important.

While the draft has interoperability problems with 1195, they are unrelated
to running multiple SPFs.  If these other problems were fixed, you could
drop that implementation into an 1195-compliant network and it would work.
This is a very important issue, and not just a technicality, because
we sell routers for different markets.  Some customers require multiprotocol
support, some don't.  Any solution should work well for both.

Regards,
Jeff