Subject: RE: [Isis-wg] Lack of I/E bit in TLV 135

From: "Tony Li" <[email-masked]>
Date: Fri, 9 May 2003 11:08:13 -0700

One might use an administrative tag...  this would allow you
to describe more semantics than simply I/E.

BTW, just because something is in an implementation doesn't
necessarily mean that the programmer thought it was a good idea.

Tony

|    -----Original Message-----
|    From: Ruth Civil [mailto:[email-masked]] 
|    Sent: Friday, May 09, 2003 6:10 AM
|    To: [email-masked]
|    Subject: [Isis-wg] Lack of I/E bit in TLV 135
|    
|    
|    There was a quick exchange on this mailing list a couple 
|    of days ago
|    where someone asked about the lack of an I/E bit in the Extended IP
|    Reachability TLV (type 135). 
|    
|    The response was that it wasn't included because it was 
|    more or less
|    useless.  
|    
|    What happens if an ISIS router using wide metrics needs to 
|    distinguish
|    between internal and external routes in order to apply 
|    different route
|    preferences to internal vs external routes ?
|    
|    I believe there are some routers (most notably Juniper) 
|    which offer the
|    ability to configure both a preference (for internal routes) and an
|    external-preference (for external routes). What method could such
|    routers be using to distinguish between internal and 
|    external routes in
|    order to apply those different preferences (when wide 
|    metrics are being
|    used) ?  
|    
|    
|    - Ruth
|    
|    -- 
|    Ruth Civil
|    Routing development
|    ESN 6 395 1142
|    [email-masked]
|    _______________________________________________
|    Isis-wg mailing list
|    [email-masked]
|    https://www1.ietf.org/mailman/listinfo/isis-wg
|    _______________________________________________
|    Isis-wg-external mailing list
|    [email-masked]
|    http://mailist.procket.com/mailman/listinfo/isis-wg-external
|    
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 12 May 2003 22:09:06 +0200

>to describe more semantics than simply I/E.
didn't christian write a while ago
 a draft on sub-TLV in 135 that carried the external/internal?
    - tony