Subject: [Isis-wg] RE: smicng output for draft-ietf-isis-wg-mib-16.txt

From: "Don Goodspeed" <[email-masked]>
Date: Tue, 27 Jul 2004 13:33:39 -0400 (EDT)

Jeff, Joan,

Joan is right and unfortunately, my MIB compilers tend to gloss over

issues in NOTIFICATION-TYPE objects since they are more concerned

with get-able and set-able objects.

What can be done is to create two new OBJECT-TYPE attributes

under isisNotificationEntry.  Call them something like

isisLevelIndex and isisAreaAddress and define them both as

accessible-for-notify.  isisLevelIndex can have a SYNTAX of ISLevel

and isisAreaAddress can have a SYNTAX of OSINSAddress.

I think that should take care of the compilation issues.

Cheers,

Don

===================================

Hi Jeff,

Thanks for your response.

I am fairly certain that there are issues

with the MIB because smiLint also gives

similar complaints.

For example, indices should be not-accessible

and some of these are read-only.

With regard to Notifications, the MIB review guidelines

http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-guidelines-03.

txt

specify:

"RFC 2578 Section 8 specifies the rules for notification definitions.

In particular:

- Inaccessible objects MUST NOT appear in the OBJECTS clause."

which is one of the complaints from these compilers.

Slightly different topic: what is the status of the MIB? Has it

gone through working group last call(s) and/or MIB Doctor review?

thanks,

-Joan

At 03:19 PM 7/26/04 -0400, Jeff Parker wrote:

>Joan -

>     Sorry, I have been out for a couple of weeks.

>     I believe this to be a problem with SMICNG, not with the MIB.

>- jeff parker

>> Hi Jeff,

>> The following is the smicng MIB compiler output

>> for version 16 of the MIB. smicng has the flags

>> specified by the mibtools

>> (see http://www.ops.ietf.org/mib-review-tools.html

>> for more details the flags).

>> Are these going to be fixed in the next version of

>> the MIB?

>> thanks,

>> -Joan

>> >W: f(ISIS-MIB), (3118,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisDatabaseOverload" is an index for a table

>> >E: f(ISIS-MIB), (3131,13) Variable "isisManAreaAddr" in notification

>> >"isisManualAddressDrops" has access of "not-accessible"

>> >W: f(ISIS-MIB), (3131,13) Variable "isisManAreaAddr" in notification

>> >"isisManualAddressDrops" is an index for a table

>> >W: f(ISIS-MIB), (3152,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisCorruptedLSPDetected" is an index for a table

>> >W: f(ISIS-MIB), (3171,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisAttemptToExceedMaxSequence" is an index for a table

>> >W: f(ISIS-MIB), (3190,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisIDLenMismatch" is an index for a table

>> >W: f(ISIS-MIB), (3212,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisMaxAreaAddressesMismatch" is an index for a table

>> >W: f(ISIS-MIB), (3234,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisOwnLSPPurge" is an index for a table

>> >W: f(ISIS-MIB), (3251,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisSequenceNumberSkip" is an index for a table

>> >W: f(ISIS-MIB), (3270,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisAuthenticationTypeFailure" is an index for a table

>> >W: f(ISIS-MIB), (3290,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisAuthenticationFailure" is an index for a table

>> >W: f(ISIS-MIB), (3309,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisVersionSkew" is an index for a table

>> >W: f(ISIS-MIB), (3351,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisRejectedAdjacency" is an index for a table

>> >W: f(ISIS-MIB), (3369,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisLSPTooLargeToPropagate" is an index for a table

>> >W: f(ISIS-MIB), (3387,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisOrigLSPBuffSizeMismatch" is an index for a table

>> >W: f(ISIS-MIB), (3411,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisProtocolsSupportedMismatch" is an index for a table

>> >W: f(ISIS-MIB), (3436,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisAdjacencyChange" is an index for a table

>> >W: f(ISIS-MIB), (3453,13) Variable "isisSysLevelIndex" in

>> notification

>> >"isisLSPErrorDetected" is an index for a table

>> >*** 1 error and 17 warnings in parsing

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: [email-masked]
Date: Tue, 27 Jul 2004 20:16:36 -0400

I am wondering if there is not a different way to
resolve these errors, such as putting an object in
the Notification.

Don and Jeff,

The object contains an index (which is one of the
motivations to make indices not-accessible from
smiv1 to smiv2).  I don't see the need to add more
objects to an already sizeable MIB, so think the solution
of adding an object (from the row) into the 
Notifications, would be simpler.  

  -Joan