Subject: RE: [Isis-wg] question on the relationship between isisSysType, i sisCircType and isisCircLevelIndex

From: Jonathan Harrison <[email-masked]>
Date: Thu, 19 Aug 2004 17:13:57 +0100

Joan, Jeff,

I suggest we clarify the isisCircLevel description text to read as follows.

"Indicates the configured level of the circuit.  The actual level at which
the circuit operates is taken from the overlap of the value of this object
and the value of isisSysType, and this overlap decides which type of packets
will be sent and accepted on this circuit.  This object follows the
replaceOnlyWhileDisabled behavior."

To answer your other points:

 - As described in my previous mail, this object should not affect the
existence of entries in the isisCircLevelTable.  

 - Since the indexing of the isisCircLevelTable already allows the circuit
to be configured separately at level 1 and level 2, there is no need to
allow an isisCircLevelTable entry to have an index of level1L2.

Jon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of [email-masked]
Sent: 19 August 2004 15:03
To: [email-masked]
Cc: [email-masked]
Subject: [Isis-wg] question on the relationship between isisSysType,
isisCircType and isisCircLevelIndex

Hi Jeff,
 
This is related to my question of yesterday on
how to populate the isisCircLevelTable....
 
In the isisCircTable, the object's description
below is unclear.  Since this object is a read-create,
it is set by an operator, what does the isisSysType scalar
object have to do with this object?

isisCircLevel OBJECT-TYPE
        SYNTAX INTEGER
            {
                level1(1),
                level2(2),
                level1L2(3)
            }
        MAX-ACCESS read-create
        STATUS current
        DESCRIPTION
            "Indicates which type of packets will be sent and
             accepted on this circuit. The values used will be
             modified by the settings of isisSysType. This
             object follows the replaceOnlyWhileDisabled behavior."
       DEFVAL { level1L2 }
    ::= { isisCircEntry 8 }

Also, with regard to the isisCircLevelTable, is  this object
supposed to indicate which Level needs to be populated by the agent?
In other words, does this object (above) denote what value the
isisCircLevelIndex (below) takes on?

If this is correct, then why are only leve1IS(1) and level2IS(2)
the only options for the isisCircLevelIndex?

isisCircLevelIndex OBJECT-TYPE
        SYNTAX INTEGER
            {
                level1IS (1),
                level2IS (2)
            }
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "The level that this entry describes."
    ::= { isisCircLevelEntry 1 }

Can these MIB descriptions be clarified?   There appears to
be some relationship between the isisSysType (scalar), the
isisCircType object, and how an agent creates rows in the
isisCircLevelTable (i.e. the value of the isisCircLevelIndex), 
but this is not documented anywhere in
the MIB and is very confusing from a developer's point of view.
 
  Thanks,
    -Joan

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Thu, 19 Aug 2004 14:25:54 -0400

>allow an isisCircLevelTable entry to have an index of level1L2.

Jon -
	That text is clearer than what I have, and I will adopt it.

- jeff parker