Subject: [Isis-wg] question on the relationship between isisSysType, isisCircType and isisCircLevelIndex

From: [email-masked]
Date: Thu, 19 Aug 2004 10:03:03 -0400 (GMT-04:00)

Hi Jeff,
 
This is related to my question of yesterday on
how to populate the isisCircLevelTable....
 
In the isisCircTable, the object's description
below is unclear.  Since this object is a read-create,
it is set by an operator, what does the isisSysType scalar
object have to do with this object?

isisCircLevel OBJECT-TYPE
        SYNTAX INTEGER
            {
                level1(1),
                level2(2),
                level1L2(3)
            }
        MAX-ACCESS read-create
        STATUS current
        DESCRIPTION
            "Indicates which type of packets will be sent and
             accepted on this circuit. The values used will be
             modified by the settings of isisSysType. This
             object follows the replaceOnlyWhileDisabled behavior."
       DEFVAL { level1L2 }
    ::= { isisCircEntry 8 }

Also, with regard to the isisCircLevelTable, is  this object
supposed to indicate which Level needs to be populated by the agent?
In other words, does this object (above) denote what value the
isisCircLevelIndex (below) takes on?

If this is correct, then why are only leve1IS(1) and level2IS(2)
the only options for the isisCircLevelIndex?

isisCircLevelIndex OBJECT-TYPE
        SYNTAX INTEGER
            {
                level1IS (1),
                level2IS (2)
            }
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "The level that this entry describes."
    ::= { isisCircLevelEntry 1 }

Can these MIB descriptions be clarified?   There appears to
be some relationship between the isisSysType (scalar), the
isisCircType object, and how an agent creates rows in the
isisCircLevelTable (i.e. the value of the isisCircLevelIndex), 
but this is not documented anywhere in
the MIB and is very confusing from a developer's point of view.
 
  Thanks,
    -Joan

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Thu, 19 Aug 2004 14:22:56 -0400

>              object follows the replaceOnlyWhileDisabled behavior."

If the router is running at Level 1, and the circuit is configured to 
be L1 and L2, only L1 packets will appear.  That is the imapct of 
isisSysType on the effectiveness of the circuit.

Different implementations could react differently: rejecting values 
of CircLevel that don't match SysLevel, or silently accepting them. 
But CircLevel cannot overrule SysLevel.

>the MIB and is very confusing from a developer's point of view.

The CircLevel is an index into a table for values that are specific 
to a level.  The MTU of a circuit is level independent, while the 
Hello Timers can have different values for different levels.

- jeff parker