Subject: [Isis-wg] RE: question on the isisSysProtSuppTable in draft-ietf-isis-wg-mi b-16.txt

From: Jeff Parker <[email-masked]>
Date: Tue, 3 Aug 2004 15:47:09 -0400

> Hi Jeff,
> 
> I have two question regarding the isisSysProtSuppTable:
> 
> 1)  Why can't this table be reduced to a  scalar, read-only 
> object with type BITS which 
> can be queried by an operator to see what the router supports?

Yup, that could be done
> 
> 2) How is the operator going to know what protocols the 
> router supports, because
>    there doesn't exist any object which tells the operator?

I assume that the operator will do a get-next walk over the table, and
retrieve the rows.  Each row represents a different supported protocol

    IsisSysProtSuppEntry ::=
        SEQUENCE {
            isisSysProtSuppProtocol
                IsisSupportedProtocol,
            isisSysProtSuppExistState
                RowStatus
            }

> The current table assumes that the operator "knows" what 
> protocols are supported and
> I don't see anything in the MIB that tells the operator this info.
> 
>    thanks, 
>      -Joan

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Don Goodspeed" <[email-masked]>
Date: Tue, 3 Aug 2004 14:43:01 -0700

Jeff, Joan,

If we are truly having this be a read-only table, then
it can just be a scalar object with BITS as the definition,
and each bit representing each protocol:

    isisSysProtSupported OBJECT-TYPE
        SYNTAX BITS {
                    iso8473 (0),
                    ipv4 (1),
                    ipv6 (2)
                  }
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "This attribute contains the set of protocols
             supported by this Intermediate System."
    ::= { isisSysObject 12 }

One could then get rid of the existing table and the TC
SupportedProtocol.

-don

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Jeff Parker
Sent: Tuesday, August 03, 2004 12:47 PM
To: [email-masked]'
Cc: [email-masked]; James Halpin
Subject: [Isis-wg] RE: question on the isisSysProtSuppTable
indraft-ietf-isis-wg-mi b-16.txt

Yup, that could be done

    IsisSysProtSuppEntry ::=
        SEQUENCE {
            isisSysProtSuppProtocol
                IsisSupportedProtocol,

---

From: [email-masked]
Date: Tue, 03 Aug 2004 21:20:50 -0400

Hi Don,

>             supported by this Intermediate System."

Awesome!

>One could then get rid of the existing table and the TC

I agree.

   -Joan