Subject: RE: [Isis-wg] RE: question on the isisSysProtSuppTable indraft-ie tf-isis-wg-mib-16.txt

From: Jonathan Harrison <[email-masked]>
Date: Wed, 4 Aug 2004 15:00:29 +0100

Don, Jeff, Joan,

I agree that a single scalar BITS object is simpler than the current
isisSysProtSupp table.  However, I think that operators may want to
configure the set of protocols (for example, to enable or disable IS-IS for
IPv6), and so the object should have read-write access.

Jon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Don Goodspeed
Sent: 03 August 2004 22:43
To: 'Jeff Parker'; [email-masked]
Cc: [email-masked]; 'James Halpin'
Subject: RE: [Isis-wg] RE: question on the isisSysProtSuppTable
indraft-ietf-isis-wg-mi b-16.txt

Jeff, Joan,

If we are truly having this be a read-only table, then
it can just be a scalar object with BITS as the definition,
and each bit representing each protocol:

    isisSysProtSupported OBJECT-TYPE
        SYNTAX BITS {
                    iso8473 (0),
                    ipv4 (1),
                    ipv6 (2)
                  }
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "This attribute contains the set of protocols
             supported by this Intermediate System."
    ::= { isisSysObject 12 }

One could then get rid of the existing table and the TC
SupportedProtocol.

-don

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Jeff Parker
Sent: Tuesday, August 03, 2004 12:47 PM
To: [email-masked]'
Cc: [email-masked]; James Halpin
Subject: [Isis-wg] RE: question on the isisSysProtSuppTable
indraft-ietf-isis-wg-mi b-16.txt

> Hi Jeff,
> 
> I have two question regarding the isisSysProtSuppTable:
> 
> 1)  Why can't this table be reduced to a  scalar, read-only 
> object with type BITS which 
> can be queried by an operator to see what the router supports?

Yup, that could be done
> 
> 2) How is the operator going to know what protocols the 
> router supports, because
>    there doesn't exist any object which tells the operator?

I assume that the operator will do a get-next walk over the table, and
retrieve the rows.  Each row represents a different supported protocol

    IsisSysProtSuppEntry ::=
        SEQUENCE {
            isisSysProtSuppProtocol
                IsisSupportedProtocol,
            isisSysProtSuppExistState
                RowStatus
            }

> The current table assumes that the operator "knows" what 
> protocols are supported and
> I don't see anything in the MIB that tells the operator this info.
> 
>    thanks, 
>      -Joan

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: [email-masked]
Date: Wed, 4 Aug 2004 10:11:35 -0400 (GMT-04:00)

Jon,

Perhaps 2 scalars are needed.

One which is read-only which Don outlined, because the operator is going
to need to know what protocols are supported by the router.  Even though
the MIB object specifies the possibility 3 different protocols, it might be that
a router vendor does NOT support all 3 of these to begin with.  It would be
very clear to an operator what is or is not supported with this read-only object.
This would be new to the MIB.

The  other object  is read-write would be for the reasons you state below, and would
replace the isisSysProtTable.

I would be in favor of removing the isisSysProtSuppTable and replacing this
with 2 scalars. 

   thanks, 
     - Joan

-----Original Message-----
From: Jonathan Harrison <[email-masked]>
Sent: Aug 4, 2004 10:00 AM
To: "[email-masked]'" <[email-masked]>, 
	'Jeff Parker' <[email-masked]>, [email-masked]
Cc: [email-masked]
Subject: RE: [Isis-wg] RE: question on the isisSysProtSuppTable indraft-ie	tf-isis-wg-mib-16.txt

Don, Jeff, Joan,

Jon

-----Original Message-----

Jeff, Joan,

-don

-----Original Message-----

Yup, that could be done

    IsisSysProtSuppEntry ::=
        SEQUENCE {
            isisSysProtSuppProtocol
                IsisSupportedProtocol,