Subject: RE: [Isis-wg] No MAC Address ..

From: "Ramalingam, Swaminathan (Swaminathan)" <[email-masked]>
Date: Tue, 26 Oct 2004 22:22:27 +0530

It is mentioned in 8.4.2.5.3 

8.4.2.5.3 If a Level n LAN IIH PDU is received from neighbour N, and this
system's lANAddress is no longer in N's IIH
PDU, the IS shall
a) set the adjacency's adjacencyState to "initialising", and
b) generate an adjacencyStateChange (Down) event.

- Swami

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On
>Behalf Of Jeff Learman
>Sent: Tuesday, October 26, 2004 10:04 PM
>To: Parker, Jeff; Abhishek Verma
>Cc: ISIS-WG (E-mail)
>Subject: Re: [Isis-wg] No MAC Address ..
>
>
>
>By George, I think he's right.  While it might be mentioned
>somewhere, it should be mentioned in Section 8.4.2.4, "Existing
>Adjacencies".
>
>Jeff
>
>At 11:38 AM 10/26/2004, Parker, Jeff wrote:
>>On 10/26/04 11:22 AM, "Abhishek Verma" 
><[email-masked]> wrote:
>>
>>> Hi Jeff,
>>> 
>>>>    o He had your MAC address in the past, but no longer does
>>> 
>>> He had the MAC and my adjacency was up. But then I receive a HELLO
>>> from him in which he doesnt list my HELLO!
>>> 
>>> And Yes, i am on a LAN. I believe in such cases, i should change my
>>> adjacency from the "UP" state to the "Init" state.
>>> 
>>> Dont think its mentioned anywhere in the ISIS docs.
>>> 
>>> Regards,
>>> Abhishek
>>
>>Abhishek -
>>    A serious charge indeed.
>>
>>    I take it that you are implementing your own version of 
>the protocol.
>>Does this happen time after time, or rarely?  Does his 
>adjacency move from
>>state init to full?  Who is the designated router on the LAN? 
> If it is you,
>>are you doing the right things?  What happens when you alter 
>the priority so
>>that the remote end is (or isn't) the DIS?
>>
>>    I would take a look at what the two of you are sending, 
>as suggested
>>before.  You might wish to compare your exchange with what 
>two other peers
>>are doing.  
>>
>>- jeff parker
>>
>>
>>
>>
>>_______________________________________________
>>Isis-wg mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/isis-wg
>
>
>_______________________________________________
>Isis-wg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/isis-wg
>

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Tue, 26 Oct 2004 13:08:17 -0400

>b) generate an adjacencyStateChange (Down) event.

Ah, yes.  There it is.  Thanks :)

Jeff