Subject: [Isis-wg] Overload Bit

From: Abhishek Verma <[email-masked]>
Date: Fri, 8 Oct 2004 20:09:23 +0530

Hi,

A -- B -- C

[1] A, B and C are 3 L1/L2 ISIS routers. B has its overload bit set.
This as per what i have read "ensures that no other router uses this
local router for transit traffic".

Now, here goes my problem(s):

ISIS adjacencies are up between these 3 routers. A is aware of C's
loopback and C is aware of A's loopback IP address. That could be say,
because we have added loopback interfaces to our areas.

Now if I try to ping A from C, should my ping go? 

IMO it shouldnt. Only the traffic destined to B's directly connected
interfaces should be allowed. Also does this technically mean that
when A receives an LSP from B with this bit set, it should not install
it?

If that is the case then why would B advertise its LSP in the first
place? When it knows that A and C are not going to use that?

Thanks,
Abhishek

--
Class of 2004
Institute of Technology, BHU
Varanasi, India

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Minto Jeyananth" <[email-masked]>
Date: Mon, 11 Oct 2004 10:06:24 +0530

Yes, I was wrong. its not based on implementation. 

Minto 
  
> -----Original Message-----
> From: Jeff Learman [mailto:[email-masked]]
> Sent: Saturday, October 09, 2004 8:57 PM
> To: Minto Jeyananth; Henk Smit; Suresh Boddapati
> Cc: [email-masked]
> Subject: RE: [Isis-wg] Overload Bit
> 
> At 08:09 AM 10/9/2004, Minto Jeyananth wrote:
> >
> > Need not to be. It's based on SPF implementation.
> 
> I disagree -- I agree with Henk.  Pinging C's loopback address should
> fail because it is advertised only by C, and is therefore transit
> routing.  Pinging any address that's directly connected to B
> (including an interface on C) should succeed.
> 
> Jeff
>