Subject: RE: [Isis-wg] Overload Bit

From: "Minto Jeyananth" <[email-masked]>
Date: Sat, 9 Oct 2004 17:39:25 +0530

> 
> > >Now if I try to ping A from C, should my ping go?
> >
> > Assuming B set the overload bit, no, your ping should not succeed
> because A
> > should ignore B's nbrs in its SPF calculation.
> 
>   It depends.
>  If A tries to ping the IP address of the loopback interface of C, it
> should
>  not succeed.
    
 Need not to be. It's based on SPF implementation. 

--Minto  

>  If A tries to ping the IP address of the p2p interface of C that is
>  connected to B, then the ping *will* succeed.
> 
> > >IMO it shouldnt. Only the traffic destined to B's directly
connected
> > >interfaces should be allowed.
> 
>   Agreed. But you should realize that the IP address of C's p2p
interface
>  is in fact in an IP range that is advertised by B, because B has an
IP
>  address in that same range configured on its p2p interface to C.
> 
>   Suresh already answered the other questions.
>  Hope this helps.
> 
>     Henk.
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Sat, 09 Oct 2004 11:26:42 -0400

> Need not to be. It's based on SPF implementation. 

I disagree -- I agree with Henk.  Pinging C's loopback address should
fail because it is advertised only by C, and is therefore transit
routing.  Pinging any address that's directly connected to B
(including an interface on C) should succeed.

Jeff

---

From: Marc Binderberger <[email-masked]>
Date: Sat, 9 Oct 2004 21:17:32 +0200

Minto,

>>> because A should ignore B's nbrs in its SPF calculation.
>>
>>   It depends.

do you mean a ping to C's loopback may happen, depending on the SPF 
implementation?

from the ISO 10589 document:

"7.2.8.1 Computing routes through overloaded Intermediate systems
The Decision Process shall not utilise a link to an Intermediate system 
neighbour from an IS whose LSPs have the LSP Database Overload 
indication set. Such paths may introduce loops since the overloaded IS 
does not have a complete routeing information base. The Decision 
Process shall, however utilise the link to reach End system neighbours 
since these paths are guaranteed to be non-looping."

Based on this C's loopback should not be routed via B.

Regards, Marc
--
Marc Binderberger    <[email-masked]>    Powered by *BSD ;-)