Subject: [Isis-wg] Strange p2p adjacencies

From: Abhishek Verma <[email-masked]>
Date: Tue, 28 Dec 2004 16:36:20 +0530

Hi,

In broadcast media by default we form both L1 and L2 adjacencies and
never one L1/L2 adjacency. So we can have 2 kinds of adjacencies in
broadcast media - L1 only and L2 only. Two routers can either have any
one of these or both of these.

But why in point-to-point do we have either (i) L1 only (ii) L2 only
and (iii) L1/L2.

Why dont we have two adjacencies L1 and L2 between two p2p links? Why
do we have just one L1/L2 adjacency?

Would love to get some idea!

Thanks,
Abhishek V. 
--
Class of 2004
Institute of Technology, BHU
Varanasi, India

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: hemanthbs <[email-masked]>
Date: Tue, 28 Dec 2004 17:51:29 +0530

Hi,

  To answer your question in the simplest way,
the ISIS protocol (10589) defines only one Hello PDU for P2P,
 ie  we have L1 LAN IIH(TYPE 15), L2 LAN IIH(TYPE 16) but only one P2P
IIH (TYPE 17).

 i.e we send only one type of hello on a P2P network

I hope this answers your question.

S.Hemanth Balaji.
Software Engineer.
Huawei Technologies India Pvt LTd, Bangalore.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Abhishek Verma
Sent: Tuesday, December 28, 2004 4:36 PM
To: ISIS-WG (E-mail)
Subject: [Isis-wg] Strange p2p adjacencies

Hi,

Thanks,
Abhishek V.

---

From: Abhishek Verma <[email-masked]>
Date: Tue, 28 Dec 2004 18:26:52 +0530

Hemanth,

This tells me why we can have only one kind of adjacency in P2P links.
And thanks for that!

But why is this so? Why has ISIS been so designed? Why do we then have
2 kinds of adjacencies in Broadcast media?

Any clues?

Thanks,
Abhishek.

--

---

From: hemanthbs <[email-masked]>
Date: Tue, 28 Dec 2004 18:53:50 +0530

Hi,

   On a Broad cast network(LAN), some routers can be only L1 or only L2.
Or you might want to form only L1 adj with some routers, only L2 with
some others and both L1L2 with some others, in which case the need for 2
separate IIH's (L1 & L2) is justified, instead of sending one single
L1L2 packet (which will be redundant).
   On  a P2P interface, since there is only one router(peer) connected
to you on that link, one can be sure that , the peer can be one of the 3
types only (either L1 , or L2 or L1L2), 
Hence only one type of packet would do the job for P2P link.

Hope this answers your questions,,,

Bye.
S.Hemanth Balaji.
Software Engineer.
Huawei Technologies India Pvt Ltd.
Bangalore, India.
 
-----Original Message-----
From: Abhishek Verma [mailto:[email-masked]] 
Sent: Tuesday, December 28, 2004 6:27 PM
To: [email-masked]
Cc: ISIS-WG (E-mail)
Subject: Re: [Isis-wg] Strange p2p adjacencies

Hemanth,

Any clues?

Thanks,
Abhishek.

--

---

From: Abhishek Verma <[email-masked]>
Date: Tue, 28 Dec 2004 19:02:29 +0530

Thanks Hemanth .. It certainly does!

Abhishek

--