Subject: [Isis-wg] Two Way Check in ISIS

From: Abhishek Verma <[email-masked]>
Date: Mon, 7 Feb 2005 01:52:02 +0530

Hi,

When running our SPF we do a 2 way neighbor check. So this is my
understanding of this. If I dont see myself listed in Router A's LSPs
then i assume that he cant reach me, or is not aware of me. In that
case, I dont consider any IP reachability advertised by that Router
and i just ignore it. OR we dont consider the neighbor in our TENT.

Now what should i do if i dont see Router A including Router B in its
LSPs. Is it possible for me to run any two way checks?

Thanks,
Abhishek

-- 

--
Class of 2004
Institute of Technology, BHU
Varanasi, India

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Mon, 07 Feb 2005 11:50:47 -0500

At 03:22 PM 2/6/2005, Abhishek Verma wrote:
>and i just ignore it.

If A is your neighbor, then you don't use the link between yourself
and A when running SPF.  But you don't ignore all of A's reachability
info.

> OR we dont consider the neighbor in our TENT.
>

If B lists A as a neighbor but A doesn't list B, don't use the link
between A and B (in either direction) when running SPF.

This is all quite clearly spelled out in ISO 10589.  In particular,
see the informative annex containing pseudocode for the SPF
algorithm.  This document is necessary to implement IS-IS or
to understand many technical details.

One situation where this check is necessary is when an area
is partitioned due to failed links between the two partitions.
For up to 20 minutes, your LSDB will still contain out-of-date
LSPs from systems in the other partition, including links to
their erstwhile neighbors in your partition.  You mustn't
use these links in SPF.  Fortunately, they get deleted from
the LSPs from their erstwhile neighbors (whose LSPs you're
still receiving).  The two-way check keeps you from having
a black hole while old LSPs time out.

Regards,
Jeff