Subject: [Isis-wg] question about the MIB

From: "Yossi Boaron" <[email-masked]>
Date: Wed, 9 Feb 2005 15:48:40 +0200

I have 3questions about controling LSP advertisement in IS-IS MIB.

first question :
===========

By default the circuits that enabled to run IS-IS are advertised in the LSP.

I also want to advertise the following :
	1. circuits that are not running IS-IS
	2. static routes.
	3. routes that added automatic by other routing protocol.

Where can I configure in the MIB wheater to enable or disable advertisement of each of the above?

Second question :
=============
Each router advertise in LSP his 'local' interfaces, each one of this LSPs is flooded to all routers in the domain.the result is that each router in the domain have the all LSPs database.
How from this information the router 'builds' the domain graph ?
 
Third question
==============

I tried to connect to CISCO router with the standard IS-IS mib with no success, does anyone connects to CISCO router with the IS-IS standard MIB?

Thanks

Yossi

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Parker, Jeff" <[email-masked]>
Date: Wed, 09 Feb 2005 09:31:15 -0500

Yossi -

3) The term ³Standard IS-IS MIB² is a misnomer: there is no standard IS-IS
MIB.  Should the stars align and the draft IS-IS MIB become a standard,
there will be a lag between standardization and implementation.  That lag
may be measured in months or years, but in many cases will be measured in
eons.  I do not speak for Cisco, and cannot comment about their development
schedule.  

2) This is not a matter for the MIB.  I think there was a recent pointer to
the appendix of 10589 or it¹s revision, which has a discussion of the SPF
algorithm.

1) a)    
     isisCircPassiveCircuit OBJECT-TYPE
        SYNTAX TruthValue
        MAX-ACCESS read-create
        STATUS current
        DESCRIPTION
            "Should we include this interface in LSPs, even if
             it is not running the IS-IS Protocol?"
        DEFVAL { false }
    ::= { isisCircEntry 9 }
   b, c) The IS-IS MIB does not control what routes other protocols select.
The proper redistribution of routes from other sources is specific to your
implementation, and not covered by the IS-IS MIB.

- jeff parker

On 2/9/05 8:48 AM, "Yossi Boaron" <[email-masked]> wrote:

> Each router advertise in LSP his 'local' interfaces, each one of this LSPs is
> flooded to all routers in the domain.the result is that each router in the
> domain have the all LSPs database.
> 
> I tried to connect to CISCO router with the standard IS-IS mib with no
> success, does anyone connects to CISCO router with the IS-IS standard MIB?
> 
> 
> 
> Thanks
> 
> Yossi
> 
>