Subject: RE: [Isis-wg] Wide Metric

From: hemanthbs <[email-masked]>
Date: Tue, 01 Feb 2005 19:47:00 +0530

Hi Nurit/Marc,

Though the draft doesn't clearly say on what basis can we decide if a
link is a TE link, we use the following selection criteria to select a
TE link.,

"We say that a link is TE link only if all TE sub-tlvs for eg: Maximum
link bandwidth, Maximum Reservable Bandwidth ,,etc are present.
Since the interface address sub-tlv can be present for non-TE
links.(wide metric)
If ,only this sub-tlv is present, then it can be considered for normal
wide metric computation and not TE computation."

i.e :-           

 if(Maximum link bandwidth && Maximum Reservable Bandwidth && Color
....all TE sub-tlvs)
 {
    TE Link
 
}
else
if(interface address sub-tlv)
{
    Normal wide metric link
}

I think this will solve the problem were are addressing.

-Hemanth

S.Hemanth Balaji.
Software Engineer.
Huawei Technologies India Pvt Ltd.
Bangalore, India.

-----Original Message-----
From: Nurit Sprecher [mailto:[email-masked]] 
Sent: Tuesday, February 01, 2005 4:21 PM
To: Marc Binderberger; [email-masked]
Cc: [email-masked]
Subject: RE: [Isis-wg] Wide Metric

Hi Marc,
Thanks for your response. 
" Maybe Nurit is asking why the TE extensions have been "integrated"
into 
extended IS reachability TLV type 22 instead of using a separate TLV. 
Nurit?" Right. I understand your answer.
However, as I wrote earlier to Hemanth, I still think that combining the
wide metric and the TE metric together is too confusing (if the TE
metric does not appear use the value of the wide metric also for the TE
metric.).
I would prefer to see them independently. However, if not, this 'must'
should be modified to something which is less obligating, like may.
Thanks,
Nurit.

-----Original Message-----
From: Marc Binderberger [mailto:[email-masked]] 
Sent: Monday, January 31, 2005 10:53 PM
To: [email-masked]
Cc: Nurit Sprecher; [email-masked]
Subject: Re: [Isis-wg] Wide Metric

Hello,

>> My doubt was why it is combined together with TE.
> The main urge for development of wide metrics was TE. Though we had
the
> problems of smaller metric range.

Maybe Nurit is asking why the TE extensions have been "integrated" into 
extended IS reachability TLV type 22 instead of using a separate TLV. 
Nurit?

(in this case: at the beginning of RFC3784 the authors are counting 
octets, so I assume they tried to avoid the additional 7 octets for 
system Id and pseudonode number in a separate TLV. Beside that 
integrating it seems logical, all new per-link information are in one 
place/TLV)

>> [...] This mandatory requirement does not
>> allow advertising a non-TE link. If for example, an IS supports TE on
>> some links but non-TE only on other links, this mandatory requirement
>> causes that even the Non-TE links will be considered in the CSPF
>> calculation. [...]
>
> The above concern may be answered as below, I guess.
> In an implementation where in the TE links are considered based on the
> following condition. "TE should be enabled for the ISIS process and 
> MPLS
> TE should be enabled on the interface"
> i.e for TE computation only those links be will be considered, for
> which MPLS TE is enabled on the interface and TE is enabled for that
> ISIS process running on that interface.

Hemanth, but how does a distance router _know_ what interfaces are 
enabled if not IS-IS is signaling this?

How does the IS-IS process running on A know that B's interface to C 
allows TE while the interface to D doesn't ?

   A--(te)--B--(te)--C
            |        |
            |       (te)
            |        |
            D--------E

(please switch on your fixed font ;-)

Or is there the implicit condition that all routers must be "TE-aware" 
and you simply put a very high TE metric on the links you don't want?

Or trial & error? (wasn't it named "cut back"? The RSVP will tell 
finally that a link is not TE/RSVP enabled).

What am I missing? :-)

Regards, Marc
--
Marc Binderberger    <[email-masked]>

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Nurit Sprecher" <[email-masked]>
Date: Tue, 1 Feb 2005 12:50:38 +0200

Hi Marc,

-----Original Message-----
From: Marc Binderberger [mailto:[email-masked]] 
Sent: Monday, January 31, 2005 10:53 PM
To: [email-masked]
Cc: Nurit Sprecher; [email-masked]
Subject: Re: [Isis-wg] Wide Metric

Hello,

the

   A--(te)--B--(te)--C
            |        |
            |       (te)
            |        |
            D--------E

What am I missing? :-)

Regards, Marc