Subject: Re: [Isis-wg] Running SPF

From: "Sugar, Sylvia" <[email-masked]>
Date: Thu, 24 Feb 2005 06:20:56 +0000 (GMT)

Hi Mike,

>>>When i run my SPF is it fair to add all my connected adjacencies directly 
>>>to the TENTs, without
>>>checking if they are already in the PATHs? Is it ever possible for a 
>>>directly connected neighbor
>>>to be in the PATHs already and us getting this information again?
>>>

[..]

> 
> I'm confused. Surely adding all your directly connected adjacencies to TENT 
> is exactly equivalent to processing you own LSP first and then adding the 
> contents to TENT. Or are you suggesting your own LSP may have a different 
> content than your adjacency set?

I am asking if this can *ever* happen. The reason why i ask this is because i was look at an ISIS
implementation and there they check before placing their own adjacency if its in PATHs. I could
not understand the reason for this and hence i put in the original mail.

IMO its not required. Is there a scenario where this would make any sense?

Thanks to Radia/Stefano and Mike for taking some time off and replying to me! 

Regards,
Sylvia

___________________________________________________________ 
ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Radia Perlman <[email-masked]>
Date: Thu, 24 Feb 2005 10:49:39 -0800

Aha. It was Mike Shand that interpreted your question correctly. Where I 
got confused
was not interpreting "my" as being "the node running SPF", and instead I 
interpreted
it as "the", as in, whenever running SPF, adding things to TENT without 
checking PATHs,
in the phrase "is it fair to add all my connected adjacencies directly 
to the TENT, without
checking if they are already in PATH". With that interpretation of the 
question, the
answer would have been "no, it's not safe", but that wasn't your question.

So Sylvia, I think you are correct in your hypothesis. What you are 
asking is whether
on the first iteration, when the node R running SPF looks at the first 
LSP (R's own adjacencies),
R can safely not bother checking PATH, and as Mike said, this is safe 
because nothing would
be in PATH at that point.

Radia

---

From: Radia Perlman <[email-masked]>
Date: Thu, 24 Feb 2005 10:49:58 -0800

Radia