Subject: [Isis-wg] Route Leaking

From: "Sugar, Sylvia" <[email-masked]>
Date: Thu, 5 May 2005 03:30:58 +0100 (BST)

Hi,

Please correct me if my understanding of the protocol is not correct.

A -- B ----- C ---- D
L1  L1/L2    L2     L1

A and B are in the same area, say X.
C and D are in a different area, say Y.

A and B have a L1 adjacency
B and C have an L2 adjacency
and C and D have an L1 adjacency

A has some routes with it, say 10/8 and 11/8. It advertises these routes to B in its L1 LSPs. B
would now advertise 10/8 and 11/8 in its L2 LSPs to C. Is this correct?

But only if route leaking from L2 to L1 is there will 10/8 and 11/8 figure in L1 LSPs issued by C
for D. By default, this will not happen.

Would appreciate if someone could confirm that my understanding of this matter is indeed correct.

Thanks,
Sylvia

___________________________________________________________ 
Yahoo! Messenger - want a free and easy way to contact your friends online? http://uk.messenger.yahoo.com

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: hemanthbs <[email-masked]>
Date: Thu, 05 May 2005 09:45:05 +0530

Hi Sylvia,

Presuming that C is an L1L2 router and it's a typing error that you have
made in the below diagram, your understanding is perfectly right.

bye

S.Hemanth Balaji.
Software Engineer.
Huawei Technologies India Pvt Ltd.
Bangalore, India.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sugar, Sylvia
Sent: Thursday, May 05, 2005 8:01 AM
To: [email-masked]
Subject: [Isis-wg] Route Leaking

Hi,

A -- B ----- C ---- D
L1  L1/L2    L2     L1

A has some routes with it, say 10/8 and 11/8. It advertises these routes
to B in its L1 LSPs. B
would now advertise 10/8 and 11/8 in its L2 LSPs to C. Is this correct?

But only if route leaking from L2 to L1 is there will 10/8 and 11/8
figure in L1 LSPs issued by C
for D. By default, this will not happen.

Would appreciate if someone could confirm that my understanding of this
matter is indeed correct.

Thanks,
Sylvia

___________________________________________________________ 
Yahoo! Messenger - want a free and easy way to contact your friends
online? http://uk.messenger.yahoo.com

---

From: Hannes Gredler <[email-masked]>
Date: Sun, 8 May 2005 09:38:37 +0200

in addition the length of prefixes that you would want
to leak from L2 to L1 is unlikely to be /8 but rather /32;

the whole point of route-leaking is to give the route-resolver
in the L1 an idea of distance to specific BGP NEXT_HOPS.
in order to give a _specific_ idea you also would advertise the
most _specific_ prefix which is for IPv4 a /32;

/hannes

On Thu, May 05, 2005 at 09:45:05AM +0530, hemanthbs wrote:
| Hi Sylvia,
| 
| Presuming that C is an L1L2 router and it's a typing error that you have
| made in the below diagram, your understanding is perfectly right.
| 
| bye
| 
| S.Hemanth Balaji.
| Software Engineer.
| Huawei Technologies India Pvt Ltd.
| Bangalore, India.
|  
| 
| -----Original Message-----
| From: [email-masked] [mailto:[email-masked]] On
| Behalf Of Sugar, Sylvia
| Sent: Thursday, May 05, 2005 8:01 AM
| To: [email-masked]
| Subject: [Isis-wg] Route Leaking
| 
| Hi,
| 
| Please correct me if my understanding of the protocol is not correct.
| 
| A -- B ----- C ---- D
| L1  L1/L2    L2     L1
| 
| A and B are in the same area, say X.
| C and D are in a different area, say Y.
| 
| A and B have a L1 adjacency
| B and C have an L2 adjacency
| and C and D have an L1 adjacency
| 
| A has some routes with it, say 10/8 and 11/8. It advertises these routes
| to B in its L1 LSPs. B
| would now advertise 10/8 and 11/8 in its L2 LSPs to C. Is this correct?
| 
| But only if route leaking from L2 to L1 is there will 10/8 and 11/8
| figure in L1 LSPs issued by C
| for D. By default, this will not happen.
| 
| Would appreciate if someone could confirm that my understanding of this
| matter is indeed correct.
| 
| Thanks,
| Sylvia
| 
| 
| 	
| 	
| 		
| ___________________________________________________________ 
| Yahoo! Messenger - want a free and easy way to contact your friends
| online? http://uk.messenger.yahoo.com
| 
| _______________________________________________
| Isis-wg mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/isis-wg
| 
| 
| _______________________________________________
| Isis-wg mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/isis-wg
| 

-- 
_____________________________________________________
hannes gredler             mobile: +43 676 9380638
network support engineer    email: [email-masked]
juniper networks inc.,      skype: hannesgredler9000