Subject: RE: [Isis-wg] Regarding ATT bit

From: "Paresh Khatri" <[email-masked]>
Date: Fri, 1 Jul 2005 14:53:42 +1000

Hi Hemanth,
 
I believe the ATT bit should only be set if the L1/2 router has an L2 link to another area.  In your case, despite the fact that all your routers have 2 NETs configured, they all still belong to the same area (since all of the routers are configured with the same 2 area addresses).  The 2 NETs serve to merge the logical areas described by each area address, and do not create two separate areas.  The system parameter 'areaAddresses' (as defined by ISO10589) would include both area addresses in each of your routers.  So neither R1 nor R4 should set the ATT bit.
 
HTH,
Paresh.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Balaji, Hemanth
Sent: Friday, 01 July 2005 02:41 PM
To: [email-masked]
Subject: [Isis-wg] Regarding ATT bit

Hi,

 I have doubt regarding the setting of ATT bit when multiple areas are involved. Consider the below situation,

      +----------------------------- R1 -------------------------+ 

       |                                               |                                          |

       |                                               |                                          |  

       |                                               |                                          |  

       |                                               |                                          |   

     R2 --------------------------- R4 ------------------------ R3

R2 is an L1 router, all others are L1L2 routers.

All routers belong to 2 areas 49 & 50.

Should R1 and R4 set the ATT bit in their L1 LSPs.???

It would be really helpful if anyone can explain this scenario.

Thanks,

Hemanth.

 

S.Hemanth Balaji.

Member-Technical Staff

Riverstone Networks India Pvt Ltd,

Ph: +91-80-51131932 extn 292

[email-masked]

"You and your Mind are disparate entities."

This communication, including any attachments, is confidential. If 
 you are not the intended recipient, you should not read it - please 
 contact me immediately, destroy it, and do not copy or use any part of 
 this communication or disclose anything about it.

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: stefano previdi <[email-masked]>
Date: Fri, 1 Jul 2005 14:51:16 +0200

On Jul 1, 2005, at 6:53 AM, Paresh Khatri wrote:
> Hi Hemanth,
>  
> I believe the ATT bit should only be set if the L1/2 router has an L2 
> link to another area. 

I wouldn't be so strict...

I would set the ATT bit if in the level-2 lsdb there
is at least one area other than the one(s) the router
is configured into (which is different from having a
link to another area).

Anyway, in the example below no ATT bit has to be set.

>  In your case, despite the fact that all your routers have 2 NETs 
> configured, they all still belong to the same area (since all of the 
> routers are configured with the same 2 area addresses).  The 2 NETs 
> serve to merge the logical areas described by each area address, and 
> do not create two separate areas. 

that is correct.

s.

>  The system parameter 'areaAddresses' (as defined by ISO10589) would 
> include both area addresses in each of your routers.  So neither R1 
> nor R4 should set the ATT bit.
>  
> HTH,
> Paresh.
>>  I have doubt regarding the setting of ATT bit when multiple areas 
>> are involved. Consider the below situation,
>>  
>>        |                                               |  
>>                                         |
>>        |                                               
>> |                                          | 
>>        |                                               | 
>>                                          |  
>>        |                                               |  
>>                                         |   
>> “You and your Mind are disparate entities.”

---

From: mike shand <[email-masked]>
Date: Fri, 01 Jul 2005 14:16:21 +0100

>is configured into (which is different from having a

Stefano is correct. It is perfectly clear in ISO/IEC 10589 (this clip from 
second edition) when you understand that areas are not the same thing as 
area addresses, and a single area can have multiple area addresses.

7.2.9.2 Setting the attached flag in level 2 intermediate systems
When executing the level 2 decision process for each supported metric, 
level 2 IS shall ascertain whether or not it can reach any destinations 
outside its area using that metric. The IS considers itself attached if either:
a) it can reach at least one other area using the coresponding routeing 
metric, or
b) it has at least one enabled reachable address prefix with the 
corresponding metric defined.
Otherwise the IS considers itself not attached.

Mike

>> serve to merge the logical areas described by each area address, and do 
>> not create two separate areas.
>
>that is correct.
>
>s.
>
>> include both area addresses in each of your routers.  So neither R1 nor 
>> R4 should set the ATT bit.
>>
>>HTH,
>>Paresh.