Subject: RE: [Isms] Late Surprise: EAP is not appropriate for ISMS (fwd)

From: "Salowey, Joe" <[email-masked]>
Date: Tue, 8 Mar 2005 09:49:13 -0800

> -----Original Message-----
> From: Ken Hornstein [mailto:[email-masked]] 
> Sent: Tuesday, March 08, 2005 7:28 AM
> To: [email-masked]
> Subject: Re: [Isms] Late Surprise: EAP is not appropriate for 
> ISMS (fwd) 
> 
> >EUSM does not tunnel EAP within SNMP. EAP is used as defined over
> >  UDP or Layer 2 (as and when SNMP is used in a non-IP environment).
> >EAP is used to setup Keys between two hosts running SNMP 
> engines based 
> >on authentication via credentials such as X.509 certs, 
> Kerberos, shared 
> >secrets or passwords stored on a RADIUS server.
> 
> Did you see my previous email on this subject?
> 
> Specifically, you seem to be relying on using Kerberos cipher 
> suites for TLS for the Kerberos authentication.  It's unclear 
> to me how these keys relate to EAP (in fact, I'm not even 
> sure what the purpose is of EAP in this mode). 
> The same is 
> true for X.509.  

[Joe] I'm not quite sure what your question is, but I think you're
asking what EAP-TLS does in addition to TLS.  EAP-TLS defines a way to
derive keys from the TLS master secret that can be exported from the TLS
layer for use elsewhere and it also provides fragmentation support
(which might not be too useful in this case). EAP also provides a way to
negotiate other authentication mechanism besides EAP-TLS.  If EAP were
not used in this mode some other way of exchanging keys would have to be
defined (perhaps by exchanging keys in the TLS session itself).  

> This is completely distinct from the fact 
> that Kerberos cipher suites for TLS is notoriously under-supported.
> 
> --Ken
> 
> _______________________________________________
> Isms mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isms
> 

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: Ken Hornstein <[email-masked]>
Date: Tue, 08 Mar 2005 13:08:36 -0500

>defined (perhaps by exchanging keys in the TLS session itself).  

I'm asking what EAP-TLS gets me if I'm using Kerberos (since presumably
I can simply derive keys directly from Kerberos).

--Ken

---

From: Kaushik Narayan <[email-masked]>
Date: Tue, 08 Mar 2005 14:24:46 -0600

Hi Ken,

>I can simply derive keys directly from Kerberos).

EAP provides an authentication framework to support multiple
authentication mechanisms. We can use Kerberos directly to
derive keys but using EAP provides us the ability to support
other authentication mechanisms as well.  Now specifically
with regards to use of EAP-TLS, TLS is being used for
Kerberos authentication using Kerberos cipher suites. There
are other EAP methods such as a EAP-GSS method that
might be used for Kerberos but EAP-GSS does not exist
right now.

regards,
   kaushik!

---

From: Ken Hornstein <[email-masked]>
Date: Tue, 08 Mar 2005 15:34:30 -0500

>other authentication mechanisms as well.

Here's my problem with that.  Let's say that I'm using Kerberos cipher
suites for TLS.  All of the authentication takes place using Kerberos
inside of TLS, before any EAP messages are exchanged.  What, exactly,
is EAP supposed to do over this TLS channel?  All of the authentication
is complete before EAP has sent a single message.

>Now specifically
>Kerberos authentication using Kerberos cipher suites.

I think I've raised my objection to this already.  My opinion is that
the support for Kerberos cipher suites for TLS is essentially
non-existant (I find that unfortunate, but it's the reality).  To
me this is not a practical way of providing support for Kerberos
authentication in EUSM.

--Ken

---

From: Kaushik Narayan <[email-masked]>
Date: Tue, 08 Mar 2005 15:11:04 -0600

Hi Ken,

Please find my reply inline.

>is complete before EAP has sent a single message.

[Kaushik]

All TLS messages will be encapsulated within EAP messages when
EAP-TLS is used.

>me this is not a practical way of providing support for Kerberos

[Kaushik] A better way to support Kerboros might be an EAP-GSS method.
  There was an EAP-GSS specification that was written to support
Kerberos but that has long expired. I think once the KITTEN folks
have defined a GSSAPIv3, we could define an EAP-GSS based
on GSSAPIv3.

regards,
   kaushik!