Subject: [Isms] RADIUS/VACM issue 6

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 25 Feb 2010 22:40:42 -0800

Hi -

Currently there is this issue in the list -

   6.  for session tracking use tlstmSessionID?

I propose closing it.  The current table organization does
have a session ID.  My working copy says:

extVacmTransportSessionID OBJECT-TYPE
    SYNTAX       Unsigned32
    MAX-ACCESS   not-accessible
    STATUS       current
    DESCRIPTION "A transport model-specific identifier of the
                 session.  This value MUST be unique among all
                 of a given transport model's currently open sessions.
                 The value has no particular significance other
                 to distinguish sessions."
    ::= { extVacmSecurityToGroupEntry 3 }

So this *could* be tlstmSessionID, and that would be the easiest thing
for an implementation to use, but there's no reason to require it,
as far as I know.

Randy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 26 Feb 2010 09:52:55 +0100

> for an implementation to use, but there's no reason to require it,

Would it make sense to spell out that this could be the tlstmSessionID
so that implementors do not have to wonder why tlstmSessionID was not
picked in the first place? It might be OK to allow other identifiers
but since the object name carries SessionID in its name, it might even
make sense to default this to tlstmSessionID, no?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 26 Feb 2010 01:12:48 -0800

Hi -

> From: "Juergen Schoenwaelder" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, February 26, 2010 12:52 AM
> Subject: Re: [Isms] RADIUS/VACM issue 6
...
> make sense to default this to tlstmSessionID, no?

How about this?

extVacmTransportSessionID OBJECT-TYPE
    SYNTAX       Unsigned32
    MAX-ACCESS   not-accessible
    STATUS       current
    DESCRIPTION "A transport model-specific identifier of the
                 session.  This value MUST be unique among all
                 of a given transport model's currently open sessions.
   The value has no particular significance other
   to distinguish sessions.  An example of a suitable
   value would be tlstmSessionID."
    ::= { extVacmSecurityToGroupEntry 3 }

Randy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 26 Feb 2010 10:43:00 +0100

>     ::= { extVacmSecurityToGroupEntry 3 }

I like this better, gives a clear hint that tlstmSessionID satisfies
the requirements.

/js