Subject: [Isms] RADIUS/VACM document structure

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 28 Feb 2010 21:16:08 -0800

Hi -

In draft-ietf-isms-radius-vacm-04.txt, the structure of section 6
seems a bit over-wrought:

   6.  Relationship to Other MIB Modules
     6.1.  Relationship to the VACM MIB
       6.1.1.  Extended VACM for RADIUS Authorization
       6.1.2.  VACM Extension for RADIUS Authorization
         6.1.2.1.  Dynamic Update of VACM and Extended VACM MIB
                   Module Objects
         6.1.2.2.  Purging Entries in the Extended VACM MIB Module
       6.1.3.  Elements of Procedure for Extended VACM
     6.2.  MIB modules required for IMPORTS

Furthermore, there is substantial redundancy between
6.1.1 through 6.1.2.2 and 6.1.3.

I'd like to propose a re-organization / collapse to something
like this:

   6.  Relationship to Other MIB Modules
     6.1.  Relationship to the VACM MIB
     6.2.  MIB modules required for IMPORTS

   7.  Elements of Procedure
     7.1. Sequencing Requirements
     7.2. Actions Upon Session Establishment Indication
       7.2.1. Creation of Entries in extVacmSecurityToGroupTable
       7.2.2. Creation of Entries in vacmSecurityToGroupTable
       7.2.3. Update of vacmGroupName
     7.3. Actions Upon Session Termination Indication
       7.3.1. Deletion of Entries from extVacmSecurityToGroupTable
       7.3.2. Deletion of Entries from vacmSecurityToGroupTable

I think this would make the document easier to read, understand, and
implement.  Comments?

Randy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 1 Mar 2010 07:00:00 +0100

> I think this would make the document easier to read, understand, and

Makes sense.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>