Subject: I-D ACTION:draft-ietf-issll-rsvp-aggr-01.txt

From: [email-masked]
Date: Tue, 07 Dec 1999 06:55:47 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Integrated Services over Specific Link Layers Working Group of the IETF.

	Title		: Aggregation of RSVP for IPv4 and IPv6 Reservations
	Author(s)	: F. Baker, C. Iturralde, F. Le Faucheur, B. Davie
	Filename	: draft-ietf-issll-rsvp-aggr-01.txt
	Pages		: 26
	Date		: 06-Dec-99
	
A key	problem	in the design of RSVP version 1	is, as noted in
its applicability statement, that it lacks facilities	for
aggregation of individual reserved sessions into a common
class. The use of such aggregation is	required for
scalability.
This document	describes the use of a single RSVP reservation
to aggregate other RSVP reservations across a	transit	routing
region, in a manner conceptually similar to the use of Virtual
Paths	in an ATM network. It proposes a way to	dynamically
create the aggregate reservation, classify the traffic for
which	the aggregate reservation applies, determine how much
bandwidth is needed to achieve the requirement, and recover
the bandwidth	when the sub-reservations are no longer
required. It also contains recommendations concerning
algorithms and policies for predictive reservations.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-issll-rsvp-aggr-01.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-issll-rsvp-aggr-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-issll-rsvp-aggr-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Juergen Ehrensberger <[email-masked]>
Date: Fri, 10 Dec 1999 18:05:25 +0100

Hi,

after having read the draft about aggregation of RSVP I still can't figure out
when an end-to-end flow becomes actually associated with an aggregate
reservation. 

The draft states on page 4, 1st paragraph:

  	"There may be several such aggregate reservations
	between the same two routers, representing different classes
	of traffic; the aggregate reservation is therefore for the
	traffic marked with a particular DSCP."

An aggregate reservation between two routers is therefore associated with a
single DSCP.

Section 2.3 says that the deaggregation router associates the end-to-end flow
with an aggregate reservation after having received an end-to-end PATH message
for that flow. 
However, section 2.5 says that the deaggregating router chooses a DSCP for the
end-to-end flow after having received its RESV message, possibly taking into
account the information carried in that message. How can the deaggregator
choose a DSCP when the association has already made before?

Thanks
Juergen