Subject: Re: RSVP Aggregation - cleanup of IANA considerations needed

From: Bob Braden <[email-masked]>
Date: Fri, 6 Apr 2001 14:40:32 -0700 (PDT)

I don't think this is the right model for an IANA Considerations
section.  When an RFC assigns particular values to existing
parameter series, it just does it.  The RFC Editor and IANA
make it right.  The IANA Considerations section is used (only)
when an RFC defines a NEW parameter series, and exists to program
the IANA on how to assign FUTURE values in that series.

Apologies if I am misunderstanding...

Bob

---

From: Fred Baker <[email-masked]>
Date: Fri, 06 Apr 2001 14:47:11 -0700

>the IANA on how to assign FUTURE values in that series.

well, we changed it as instructed, to make IANA/RFC Editor happy. Could you 
suggest text that would make you happier?

---

From: Allison Mankin <[email-masked]>
Date: Sat, 07 Apr 2001 15:43:51 -0400

> Apologies if I am misunderstanding...

Bob,

IANA asked IESG to make the IANA Considerations in this draft
point out what section each IANA action was in, and to be 
explicit about the requests made.  The concern was serious enough
for the fixes to be the obstacle for transmitting the doc to
the RFC Editor (it has passed IESG for PS except for this).

IESG now gets guidance from IANA directly on every document we pass
to standards track.  My understanding is that new/revised specs:
1. always include IANA Considerations
2. give explicit instructions in that section, even if it
   is just to point back to the text, not only for forming new registries

I think a side benefit of this is for education:  spec writers (the
Internet authorship group has become very large), WG chairs,
even we IESG who may forget things (as well as coming in new) find 
instruction in each spec about how IANA protocol number registrations 
work and are used.

I've added IANA to the cc list, and they should feel free to speak up
if I've misstated...

I hope the ISSLL WG (I've left the WG cc'd) isn't saying "sheesh, what
does this have to do with ISSLL?", even though it's about a WG doc.

Allison