Subject: [Jcardcal] File name extension for jcard files

From: Bert Greevenbosch <[email-masked]>
Date: Thu, 23 May 2013 01:09:05 +0000

Hello all,

I noticed that we haven't defined a file name extension for jcard files. Maybe we should consider this? We could add this to the MIME registration in the IANA considerations section.

Just for consideration for now. Peter and I think we can fix it during WGLC, provided that folks think it is useful of course.

Best regards,
Bert

---

From: Philipp Kewisch <[email-masked]>
Date: Thu, 23 May 2013 10:16:28 +0200

Hi Bert, all,

we considered this within calconnect too and came to the conclusion that 
an extra file extension is not needed. I guess the most common use case 
for jCard is to use it to transfer and use the card data in an area 
where JSON is common, for example web applications.

If for some reason it is required to save the card data to a file, this 
can be done with a .json file. If type detection is needed, this can 
still be done using the vcardstream construct, the root element being an 
array and its first element will let you know if its vcard data or 
something else.

This is of course up for discussion in jcardcal, if we come to the 
consensus there needs to be a filetype its an easy issue to fix.

Philipp

On 5/23/13 3:09 AM, Bert Greevenbosch wrote:
>
> Hello all,
>
> I noticed that we haven't defined a file name extension for jcard 
> files. Maybe we should consider this? We could add this to the MIME 
> registration in the IANA considerations section.
>
> Just for consideration for now. Peter and I think we can fix it during 
> WGLC, provided that folks think it is useful of course.
>
> Best regards,
>
> Bert
>
>
>
> _______________________________________________
> jcardcal mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jcardcal

---

From: Michael Angstadt <[email-masked]>
Date: Thu, 23 May 2013 16:33:31 -0400

I think might make sense to include this.  I agree that a good use
case for jCard is in web apps, since web apps commonly use JSON for
their network communication, but who knows how people will decide to
use it.  Maybe the specs could state that a file extension alone
should not be relied upon when parsing a jCard file (if the ".json"
extension were to be used, the file could contain any kind of JSON
data, not just jCard data).

Thanks,
-Mike