Subject: [Jcardcal] sabre/vobject implementation status

From: Evert Pot <[email-masked]>
Date: Mon, 17 Jun 2013 19:14:08 +0100

I hope this is appropriate for this list, if not, apologies.

I wanted to quickly announce that I just released a 3rd beta of the sabre/vobject library (a popular vcard/icalendar parser for PHP).

This beta can generate both jCard and jCal, and is (afaik) fully compliant with:

http://tools.ietf.org/html/draft-ietf-jcardcal-jcard-03
http://tools.ietf.org/html/draft-ietf-jcardcal-jcal-04

Link:
https://github.com/fruux/sabre-vobject#readme

This library is integrated into the cal/carddav server 'SabreDAV'. I intend to automatically convert to jCal/jCard in a future release using content-negotiation.

Cheers and thanks for the hard work,
Evert

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 17 Jun 2013 12:42:05 -0600

> I hope this is appropriate for this list, if not, apologies.

It's fine for the list! We love hearing about running code.

> I wanted to quickly announce that I just released a 3rd beta of the
> sabre/vobject library (a popular vcard/icalendar parser for PHP).
> 
> Link: https://github.com/fruux/sabre-vobject#readme
> 
> This library is integrated into the cal/carddav server 'SabreDAV'. I
> intend to automatically convert to jCal/jCard in a future release
> using content-negotiation.
> 
> Cheers and thanks for the hard work, Evert 

Thanks for the note. Perhaps Philipp will add your implementation to the
list in the documents. :-)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Evert Pot <[email-masked]>
Date: Mon, 17 Jun 2013 20:28:45 +0100

> list in the documents. :-)

That would be pretty great (Y)

Cheers,
Evert