Subject: [Jcardcal] About 'recur'.

From: Evert Pot <[email-masked]>
Date: Thu, 6 Jun 2013 15:10:39 +0100

The draft says the following about encoding 'recur' properties:

      *  The "bysecond", "byminute", "byhour", "bymonthday",
         "byyearday", "byweekno", "bymonth" and "bysetpos" rule parts
         MUST each be specified as an array with multiple number values.
         Single-value rule parts SHOULD be represented using a single
         string value, but an array with one element MAY also be used.

Maybe I'm misreading this, but I think the 'MUST' part is incorrect here.

Since it says that "single-value rule parts SHOULD be represented using a single string value", this would be in conflict with "MUST each be specified as an array with multiple number values".

I also think the usage of 'string value' vs 'number values' is a bit confusing here. When should use use strings, and when should we use numbers? Or, are they always numerical strings?

Cheers,
Evert

---

From: Philipp Kewisch <[email-masked]>
Date: Thu, 6 Jun 2013 19:05:24 +0200

Reading ovet it again I agree the wording isn't ideal. The jist of it is:

• if there are multiple values then an array must be used
• if there is only one value an array MAY be used, but it can also be a single value
• if it can only be a number per rfc5545, then the type is a number or array of numbers
• if it can be a string (i.e -3MO) then the value type is a string or array of strings

"string value" is likely wrong there, good catch!

I'll include a revised text in the next update.

Philipp

On Jun 6, 2013, at 16:10, Evert Pot <[email-masked]> wrote:

> _______________________________________________
> jcardcal mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jcardcal

---

From: Philipp Kewisch <[email-masked]>
Date: Sun, 09 Jun 2013 20:13:58 +0200

> I also think the usage of 'string value' vs 'number values' is a bit confusing here. When should use use strings, and when should we use numbers? Or, are they always numerical strings?
FYI I have changed it to the following text:

                 <t>
                   For the rule parts "bysecond", "byminute", "byhour",
                   "bymonthday", "byyearday", "byweekno", "bymonth" and
                   "bysetpos" containing multiple values, an array of 
numbers
                   MUST be used. Single-valued rule parts SHOULD be 
represented
                   using a single number value, instead an array with 
one number
                   value element MAY be used.
                 </t>
                 <t>
                   For the "byday" rule part containing multiple values, an
                   array of strings MUST be used. Single-valued "byday" 
rule
                   parts SHOULD be represented using a single string value,
                   instead an array with one string value element MAY be 
used.
                 </t>

Philipp

---

From: Evert Pot <[email-masked]>
Date: Sun, 9 Jun 2013 19:34:40 +0100

>                  "bysetpos" containing multiple values, an array of numbers
>                  MUST be used. Single-valued rule parts SHOULD be represented
>                  using a single number value, instead an array with one number
>                  array of strings MUST be used. Single-valued "byday" rule
>                  instead an array with one string value element MAY be used.
>                </t>

Good stuff!

Evert

---

From: Michael Angstadt <[email-masked]>
Date: Sun, 9 Jun 2013 15:06:39 -0400

I think this wording sounds better:

The following rule parts can have one or more numeric values: "bysecond",
"byminute", "byhour", "bymonthday", "byyearday", "byweekno", "bymonth", and
"bysetpos".  If a rule part contains multiple values, an array of numbers
MUST be used for that rule part.  If a rule part contains a single value,
the value SHOULD be represented using a single number value, instead of an
array with one number value (although an array MAY be used).

Similarly, the "byday" rule part can have one or more string values.  If it
contains multiple values, an array of strings MUST be used.  If it contains
a single value, the value SHOULD be represented using a single string
value, instead of an array with one string value (although an array MAY be
used).

Thanks,
Mike

On Sun, Jun 9, 2013 at 2:13 PM, Philipp Kewisch <[email-masked]> wrote:

>> Since it says that "single-value rule parts SHOULD be represented using a
>> single string value", this would be in conflict with "MUST each be
>> specified as an array with multiple number values".
>>
>> I also think the usage of 'string value' vs 'number values' is a bit
>> confusing here. When should use use strings, and when should we use
>> numbers? Or, are they always numerical strings?
>>
>> Cheers,
>> Evert
>> ______________________________**_________________
>> jcardcal mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/jcardcal<https://www.ietf.org/mailman/listinfo/jcardcal>
>>
> ______________________________**_________________
> jcardcal mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/jcardcal<https://www.ietf.org/mailman/listinfo/jcardcal>
>

---

From: Philipp Kewisch <[email-masked]>
Date: Sun, 09 Jun 2013 21:48:35 +0200

That wording would be fine with me too. I'll wait until tomorrow morning 
in case there are more comments and then upload a new draft version.

Philipp

On 6/9/13 9:06 PM, Michael Angstadt wrote:
> The following rule parts can have one or more numeric values: 
> "bysecond", "byminute", "byhour", "bymonthday", "byyearday", 
> "byweekno", "bymonth", and "bysetpos".  If a rule part contains 
> multiple values, an array of numbers MUST be used for that rule part. 
>  If a rule part contains a single value, the value SHOULD be 
> represented using a single number value, instead of an array with one 
> number value (although an array MAY be used).
>
> Similarly, the "byday" rule part can have one or more string values. 
>  If it contains multiple values, an array of strings MUST be used.  If 
> it contains a single value, the value SHOULD be represented using a 
> single string value, instead of an array with one string value 
> (although an array MAY be used).
>
> Thanks,
> Mike
>
>
> On Sun, Jun 9, 2013 at 2:13 PM, Philipp Kewisch <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>         Since it says that "single-value rule parts SHOULD be
>         represented using a single string value", this would be in
>         conflict with "MUST each be specified as an array with
>         multiple number values".
>
>         I also think the usage of 'string value' vs 'number values' is
>         a bit confusing here. When should use use strings, and when
>         should we use numbers? Or, are they always numerical strings?
>
>         Cheers,
>         Evert
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>