Subject: [Jcardcal] Possible problem in jCal REQUEST-STATUS

From: Evert Pot <[email-masked]>
Date: Mon, 17 Jun 2013 18:39:34 +0100

Hey guys,

Perhaps I'm mis-reading this, but this example appears in the section 3.4.1.3 [1].

   ["vevent":
     [
       ["request-status", {}, "text", "2.0", "Success" ],
       ["request-status", {}, "text",
          [
           "3.7",
           "Invalid Calendar User",
           "ATTENDEE:mailto:[email-masked]"
          ]
       ],
       ...
     ],
     ...
   ]

Notice how one request-status value is wrapped in an array, while the other isn't.
Based on the language, I would expect this to be the correct encoding:

["request-status", {}, "text", ["2.0", "Success"] ]

Is this correct, or are both encodings supported?

Evert

[1]: http://tools.ietf.org/html/draft-ietf-jcardcal-jcal-04#section-3.4.1.3

---

From: Cyrus Daboo <[email-masked]>
Date: Mon, 17 Jun 2013 13:49:02 -0400

Hi Evert,

> Is this correct, or are both encodings supported?

The example is wrong. Your proposed correction above is right.

The goal is to have REQUEST-STATUS value (and GEO) treated as if it were a 
"structured value" rather than a multi value. One reason for that is that 
multi-values are comma separated (e.g. CATEGORIES, EXDATE etc) and have no 
requirement for a specific number of items,  whereas "structured values" 
are semi-colon separated and typically do require a certain number of 
components. From an api standpoint I found it better to treat GEO and 
REQUEST-STATUS as structured because that keeps them separate from "normal" 
handling of multi-values.

-- 
Cyrus Daboo

---

From: Evert Pot <[email-masked]>
Date: Mon, 17 Jun 2013 18:50:19 +0100

On Jun 17, 2013, at 6:49 PM, Cyrus Daboo <[email-masked]> wrote:

> Hi Evert,
> 
> --On June 17, 2013 at 6:39:34 PM +0100 Evert Pot <[email-masked]> wrote:
> 
> The goal is to have REQUEST-STATUS value (and GEO) treated as if it were a "structured value" rather than a multi value. One reason for that is that multi-values are comma separated (e.g. CATEGORIES, EXDATE etc) and have no requirement for a specific number of items,  whereas "structured values" are semi-colon separated and typically do require a certain number of components. From an api standpoint I found it better to treat GEO and REQUEST-STATUS as structured because that keeps them separate from "normal" handling of multi-values.

That's what I figured ;) Just wanted to make sure you guys were aware.

Cheers,
Evert