Subject: [Jcardcal] I-D Action: draft-ietf-jcardcal-jcal-05.txt

From: [email-masked]
Date: Wed, 03 Jul 2013 03:34:36 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the JSON data formats for vCard and iCalendar Working Group of the IETF.

	Title           : jCal: The JSON format for iCalendar
	Author(s)       : Philipp Kewisch
                          Cyrus Daboo
                          Mike Douglass
	Filename        : draft-ietf-jcardcal-jcal-05.txt
	Pages           : 31
	Date            : 2013-07-03

Abstract:
   This specification defines "jCal", a JSON format for iCalendar data.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-jcardcal-jcal

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-jcardcal-jcal-05

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-jcardcal-jcal-05

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Philipp Kewisch <[email-masked]>
Date: Wed, 03 Jul 2013 12:38:30 +0200

Hey Folks,

I've also updated the jcal draft. I've tried to adapt all issues 
applicable from jCard to jCal, let me know if I missed anything.

Philipp

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 03 Jul 2013 14:33:56 -0600

> applicable from jCard to jCal, let me know if I missed anything.

Thank you for all your work on these documents! I'll review jCal and
start a Working Group Last Call on that one very soon.

Peter (as co-chair)

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Michael Angstadt <[email-masked]>
Date: Tue, 9 Jul 2013 19:14:02 -0400

In the examples in Appendix B of the jCal draft, there are a few small
errors in the JSON syntax.  Some of the properties that come at the end of
a component's property array have trailing commas.  These commas should be
removed, since they are the last element of the array.

For example:

["version", {}, "text", "2.0"],

should be

["version", {}, "text", "2.0"]

The effected properties are:

"uid" - page 25
"version" - page 27
"tzid" - page 27

==================

Also, in Example 2 (page 27), I think the "rrule" property values are
incorrect.  They should be using JSON objects as their values (as defined
in section 3.6.10), but they're using string values instead (it looks like
the "recurrence rule" data type was modified at one point, but the examples
weren't updated).

The corrections are as follows:

========
Page 27

["rrule",
  {},
  "recur",
  "FREQ=YEARLY;BYDAY=1SU;BYMONTH=4"
],

should be

["rrule",
  {},
  "recur",
  {
    "freq": "YEARLY",
    "byday": "1SU",
    "bymonth": 4
  }
],

========
Page 27

["rrule",
{},
"recur",
"FREQ=YEARLY;BYDAY=1SU;BYMONTH=10"
],

should be

["rrule",
  {},
  "recur",
  {
    "freq": "YEARLY",
    "byday": "1SU",
    "bymonth": 10
  }
],

========
Page 28

["rrule", {}, "recur", "FREQ=DAILY;COUNT=5"],

should be

["rrule",
  {},
  "recur",
  {
    "freq": "DAILY",
    count: 5
  }
],

Thanks,
Mike

On Wed, Jul 3, 2013 at 6:34 AM, <[email-masked]> wrote:

> _______________________________________________
> jcardcal mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jcardcal
>

---

From: Michael Angstadt <[email-masked]>
Date: Wed, 10 Jul 2013 10:26:47 -0400

Also, there seems to be an error in the REQUEST-STATUS property section.
 The example shows a REQUEST-STATUS property whose value is not an array,
which is incorrect.  According to the definition, the REQUEST-STATUS
property value must always be an array (since it is required to always have
at least two elements).

Page 9:

["request-status", {}, "text", "2.0", "Success" ],

should be

["request-status", {}, "text", ["2.0", "Success"] ],

Thanks,
Mike

---

From: Philipp Kewisch <[email-masked]>
Date: Wed, 10 Jul 2013 17:09:43 +0200

Ah yes, I think you mentioned this before, looks like I lost track of it.

This time I will go through all email since the WGLC started, but maybe 
you can add it to the issue tracker too?

Philipp

On 7/10/13 4:26 PM, Michael Angstadt wrote:
> Also, there seems to be an error in the REQUEST-STATUS property 
> section.  The example shows a REQUEST-STATUS property whose value is 
> not an array, which is incorrect.  According to the definition, the 
> REQUEST-STATUS property value must always be an array (since it is 
> required to always have at least two elements).
>
> Page 9:
>
> On Tue, Jul 9, 2013 at 7:14 PM, Michael Angstadt 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     In the examples in Appendix B of the jCal draft, there are a few
>     small errors in the JSON syntax.  Some of the properties that come
>     at the end of a component's property array have trailing commas.
>      These commas should be removed, since they are the last element
>     of the array.
>
>     For example:
>
>     Also, in Example 2 (page 27), I think the "rrule" property values
>     are incorrect.  They should be using JSON objects as their values
>     (as defined in section 3.6.10), but they're using string values
>     instead (it looks like the "recurrence rule" data type was
>     modified at one point, but the examples weren't updated).
>
>     On Wed, Jul 3, 2013 at 6:34 AM, <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>
>         [email-masked] <mailto:[email-masked]>

---

From: Michael Angstadt <[email-masked]>
Date: Wed, 10 Jul 2013 11:51:24 -0400

It wasn't me who mentioned it, not sure who did.

Tickets created:

http://trac.tools.ietf.org/wg/jcardcal/trac/ticket/21
http://trac.tools.ietf.org/wg/jcardcal/trac/ticket/22
http://trac.tools.ietf.org/wg/jcardcal/trac/ticket/23

Thanks,
Mike

On Wed, Jul 10, 2013 at 11:09 AM, Philipp Kewisch <[email-masked]> wrote:

> jcardcal mailing [email-masked]://www.ietf.org/mailman/listinfo/jcardcal
>
>
>