Subject: [Jcardcal] Protocol Action: 'jCard: The JSON format for vCard' to Proposed Standard (draft-ietf-jcardcal-jcard-07.txt)

From: The IESG <[email-masked]>
Date: Tue, 05 Nov 2013 14:51:01 -0800

The IESG has approved the following document:
- 'jCard: The JSON format for vCard'
  (draft-ietf-jcardcal-jcard-07.txt) as Proposed Standard

This document is the product of the JSON data formats for vCard and
iCalendar Working Group.

The IESG contact persons are Pete Resnick and Barry Leiba.

A URL of this Internet Draft is:
http://datatracker.ietf.org/doc/draft-ietf-jcardcal-jcard/

Technical Summary

   The document defines "jCard", which is a JSON format for vCard
   [RFC6350] data.

   The main advantage of using a JSON-based format over the classic
   vCard format is easier processing for JavaScript based widgets and
   libraries, especially in the scope of web-based applications.

   The jCard format is designed to be semantically equivalent to the
   vCard format, and conversion between the formats can be done without
   loss.

   Finally, the jCard format is designed to be easily used by a similar
   JSON-based format for calendar data: jCal. The latter format is still
   under development, but is expected to be finalized soon after
   finalization of jCard.

Working Group Summary

   Since the document's WG adoption on 25 March 2013, it has been widely
   discussed on the mailing list. In addition, other working groups have
   been consulted. The IETF working groups are SCIM, WEIRDS and CALSIFY.
   In addition, we have contacted W3C public-contacts-cord and the
   portablecontacts Google group. In-dept comments have been received
   from WEIRDS and CALSIFY. WEIRDS has a jCal example in its
   draft-ietf-json-response.

   All technical issues raised on the mailing list have been resolved.
   The topics have not been controversial, although several topics
   required some rounds of discussion. Topics included the format for
   date and time, handling of default values when converting between
   vCard and jCard, structured values and grouping.

Document Quality

   Section 6 of the draft mentions three implementations. These are
   ICAL.js, Py Calendar and ez-vcard. The implementations have led to
   some discussions on the list, resulting in clarifications in the
   text.

Personnel

   Shepherd: Bert Greevenbosch
   AD: Pete Resnick

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 05 Nov 2013 16:14:06 -0800

Many thanks to Philipp for all his hard work on the jCard spec!

Now let's finish the jCal document so we can declare complete success. :-)

Peter

On 11/5/13 2:51 PM, The IESG wrote:
> The IESG has approved the following document: - 'jCard: The JSON
> format for vCard' (draft-ietf-jcardcal-jcard-07.txt) as Proposed
> Standard
> 
> This document is the product of the JSON data formats for vCard
> and iCalendar Working Group.
> 
> vCard format, and conversion between the formats can be done
> without loss.
> 
> Finally, the jCard format is designed to be easily used by a
> similar JSON-based format for calendar data: jCal. The latter
> format is still under development, but is expected to be finalized
> soon after finalization of jCard.
> 
> Working Group Summary
> 
> Since the document's WG adoption on 25 March 2013, it has been
> widely discussed on the mailing list. In addition, other working
> groups have been consulted. The IETF working groups are SCIM,
> WEIRDS and CALSIFY. In addition, we have contacted W3C
> public-contacts-cord and the portablecontacts Google group. In-dept
> comments have been received from WEIRDS and CALSIFY. WEIRDS has a
> jCal example in its draft-ietf-json-response.
> 
> All technical issues raised on the mailing list have been
> resolved. The topics have not been controversial, although several
> topics required some rounds of discussion. Topics included the
> format for date and time, handling of default values when
> converting between vCard and jCard, structured values and
> grouping.
> 
> Document Quality
> 
> Shepherd: Bert Greevenbosch AD: Pete Resnick 
> _______________________________________________ jcardcal mailing
> list [email-masked] 
> https://www.ietf.org/mailman/listinfo/jcardcal
> 

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Bert Greevenbosch <[email-masked]>
Date: Fri, 8 Nov 2013 20:13:31 +0000

Indeed many thanks to Philipp!
Also thanks to all of you that contributed to the document!

Best regards,
Bert

________________________________________
From: [email-masked] [[email-masked]] on behalf of Peter Saint-Andre [[email-masked]]
Sent: 06 November 2013 08:14
To: [email-masked]
Subject: Re: [Jcardcal] Protocol Action: 'jCard: The JSON format for vCard' to Proposed Standard (draft-ietf-jcardcal-jcard-07.txt)

Peter

- --
Peter Saint-Andre
https://stpeter.im/

_______________________________________________
jcardcal mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jcardcal