Subject: [Jmap] Blob draft question: type vs datatype

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 08 Oct 2021 23:55:35 +1100

https://github.com/brong/draft-gondwana-jmap-blob/issues/1

I've partially renamed things from 'datatype' to 'type', but the problem is that "type" is also used for mimetype, which could cause some confusion.

But also "types" is used in RFC8620 for PushSubscriptions.

....

Suggestions, what would people prefer?  I'm working with "datatype", "data type", "type", "typename" and "type name" as ways to describe it, and they all have pros and cons.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: "Neil Jenkins" <[email-masked]>
Date: Wed, 13 Oct 2021 13:16:22 +1100

I would lean towards `typeName` for this.

—Neil