Subject: [Jmap] I-D Action: draft-ietf-jmap-blob-09.txt

From: [email-masked]
Date: Fri, 04 Mar 2022 15:52:51 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the JSON Mail Access Protocol WG of the IETF.

        Title           : JMAP Blob management extension
        Author          : Bron Gondwana
	Filename        : draft-ietf-jmap-blob-09.txt
	Pages           : 28
	Date            : 2022-03-04

Abstract:
   The JMAP base protocol (RFC8620) provides the ability to upload and
   download arbitrary binary data via HTTP POST and GET on defined
   endpoint.  This binary data is called a "blob".

   This extension adds additional ways to create and access blobs, by
   making inline method calls within a standard JMAP request.

   This extension also adds a reverse lookup mechanism to discover where
   blobs are referenced within other data types.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-jmap-blob/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-jmap-blob-09.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-jmap-blob-09

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 04 Mar 2022 15:57:17 -0800

Hi all, sorry for the delay in getting this revision out!  I've wordsmithed the introduction some more, and also rewritten the "Blob/set" to be "Blob/upload" based on feedback from Neil that it was different enough from a standard Foo/set that using a different verb made more sense.

I also decided to normalise the `catenate` behaviour, such that we now always take an array of zero or more `data` items, which may be data:asText, data:asBase64, a blob source, or in future some other extension for finding data.

And I trimmed the requirement that you check BOTH the capability for this and the maxUploadSize before uploading.  If the server wants to restrict size for Blob/upload, it can tell you in one place.

This document is already in WGLC, this is based on WGLC feedback. Given that it's a significant change, I'd love any updated feedback before IETF113 so I can ask Jim to ship it then if others are happy :)  I also plan to update the Cyrus IMAP implementation and Fastmail's use of it in the intervening time to make sure it's all nice to work with.

Cheers,

Bron.

On Fri, Mar 4, 2022, at 15:52, [email-masked] wrote:
> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]