Subject: Re: [jose] Keys in the documents

From: Mike Jones <[email-masked]>
Date: Fri, 21 Jun 2013 15:57:57 +0000

Will do.

________________________________
From: Matt Miller (mamille2)
Sent: 6/21/2013 6:06 AM
To: Richard Barnes
Cc: Jim Schaad; [email-masked]; [email-masked]
Subject: Re: [jose] Keys in the documents

+1

On Jun 20, 2013, at 8:48 PM, Richard Barnes <[email-masked]>
wrote:

> +1
>
> On Thursday, June 20, 2013, Jim Schaad wrote:
>
>> Is there any reason not to provide the public and private keys in the
>> appendixes as JWK objects?  This would make them easier to understand and
>> put them into a format that one expects to be understood by JOSE systems.*
>> ***
>>
>> ** **
>>
>> Jim****
>>
>> ** **
>>

- m&m

Matt Miller < [email-masked] >
Cisco Systems, Inc.

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 24 Jun 2013 23:18:07 -0700

I have gone through the process of trying to use this, and I have also sat
down to think about how I would like to use the examples and I would suggest
the following:

There be one or two JWK sets that are defined at the start of appendix A.  

.         All of the keys (public, private and secret) be included in the
JWK sets

.         We assign, for testing purposes, a URL to each of the JWK sets
defined

.         Each example then either has the necessary data to find the key
from the correct JWK Set (and possibly the correct JWK Set via a jku) or the
text defines which of the keys is to be used.

.         There should be examples of many (most? All?) of the key location
methods between the JWS and JWE drafts.

Jim

From: Mike Jones [mailto:[email-masked]] 
Sent: Friday, June 21, 2013 8:58 AM
To: Matt Miller (mamille2); Richard Barnes
Cc: Jim Schaad; [email-masked];
[email-masked]
Subject: RE: [jose] Keys in the documents

Will do.

  _____  

From: Matt Miller (mamille2)
Sent: 6/21/2013 6:06 AM
To: Richard Barnes
Cc: Jim Schaad; [email-masked];
[email-masked]
Subject: Re: [jose] Keys in the documents

+1

- m&m