Subject: Re: [jose] Working Group Last Call - draft-ietf-jose-use-cases

From: "Jim Schaad" <[email-masked]>
Date: Mon, 10 Jun 2013 17:48:58 -0700

This is a reminder to do this in the next week.  We need both positive and
negative reviews to judge consensus.

Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim
Schaad
Sent: Thursday, May 30, 2013 9:16 AM
To: [email-masked]
Subject: [jose] Working Group Last Call - draft-ietf-jose-use-cases
Importance: High

<chair>

This message starts the Working Group Last Call on the Use Cases document.

Minor issues should be sent to the list

Major issues (those that should block the document from proceeding to the
IESG) should be sent to the list and an issue created in the tracker.

The final day for Last Call comments is June 16, 2013

Jim

---

From: "Manger, James H" <[email-masked]>
Date: Tue, 11 Jun 2013 17:49:50 +1000

Being reasonably efficient when securing large amounts of data is a worthwhile requirement that seems to be missing from draft-ietf-jose-use-cases.

"Encryption" and "Authenticated encryption" are listed as separate functional requirements [section 6.1]. Can't we drop "Encryption"? A benefit of JOSE should be eliminating a whole class of crypto problems caused by unauthenticated (symmetric) encryption.

--
James Manger

---

From: Ludwig Seitz <[email-masked]>
Date: Wed, 12 Jun 2013 16:04:31 +0200

Hello,

as suggested by Jim Schad and Mike Jones, I've written up a proposal for
an additional small devices (renamed to constrained devices) use case.

I'm grateful for any comments and suggestion you may have.

Regards,

Ludwig Seitz

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2 
Scheelevägen 17 
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Mike Jones <[email-masked]>
Date: Tue, 18 Jun 2013 22:53:32 +0000

My last call comments are attached in the form of changes applied relative to the -02 source.  They can all be easily seen as tracked changes in the attached .docx version.  Most are editorial in nature, however there are a few factual corrections also applied.  Those were:

*         Make it clear that the application may specify another means or convention to determine the key used.

*         Corrected "JWT" -> "OAuth" in the sentence "In OAuth, the "client_id" parameter identifies the key to be used."

*         Don't say that OAuth is used in Mozilla Persona.

*         I reverted the "S1" Security Requirements text to the -01 version, since the -02 text would prohibit the direct encryption use case.

Once these changes are applied and Ludwig Seitz' direct encryption use case is added, I'm good with seeing the document progress.

                                                                -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Thursday, May 30, 2013 9:16 AM
To: [email-masked]
Subject: [jose] Working Group Last Call - draft-ietf-jose-use-cases
Importance: High

<chair>

Major issues (those that should block the document from proceeding to the IESG) should be sent to the list and an issue created in the tracker.

Jim

---

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 26 Jun 2013 04:04:28 +0000

Folks,

The WGLC on draft-ietf-jose-use-cases has closed. As a result of the WGLC, the chairs request the editor to update the document to add the additional use case and to address the additional comments posted on the list. Upon successful completion of the revision, the document will be forwarded to the IESG.

Thanks for all who reviewed the document.

Regards,
Karen

On Jun 10, 2013, at 8:48 PM, Jim Schaad wrote:

This is a reminder to do this in the next week.  We need both positive and negative reviews to judge consensus.

Jim

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Thursday, May 30, 2013 9:16 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [jose] Working Group Last Call - draft-ietf-jose-use-cases
Importance: High

<chair>

Jim

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose

---

From: Richard Barnes <[email-masked]>
Date: Wed, 26 Jun 2013 20:08:48 -0400

Request acknowledged.
Thanks,
The Editor

On Wed, Jun 26, 2013 at 12:04 AM, Karen O'Donoghue <[email-masked]>wrote:

>  Folks,
>
>  The WGLC on draft-ietf-jose-use-cases has closed. As a result of the
> WGLC, the chairs request the editor to update the document to add the
> additional use case and to address the additional comments posted on the
> list. Upon successful completion of the revision, the document will be
> forwarded to the IESG.
>
>   This is a reminder to do this in the next week.  We need both positive
> and negative reviews to judge consensus.****
>  ** **
>  Jim****
>  ** **
>  ** **
>   *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Jim Schaad
> *Sent:* Thursday, May 30, 2013 9:16 AM
> *To:* [email-masked]
> *Subject:* [jose] Working Group Last Call - draft-ietf-jose-use-cases
> *Importance:* High****
>   ** **
>  <chair>****
>  ** **
> ****
>  ** **
>  Minor issues should be sent to the list****
>  ** **
> IESG) should be sent to the list and an issue created in the tracker.****
>  ** **
>  The final day for Last Call comments is June 16, 2013****
>  ** **
>  ** **
>  Jim****
>  ** **
> [email-masked]
> [email-masked]