Subject: Re: [jose] #54: epk/apu/apv need to be REQUIRED

From: Mike Jones <[email-masked]>
Date: Fri, 6 Sep 2013 01:46:04 +0000

Hi Richard,

The text that you proposed for #55, in which “apv” is not used, contradicts the request that “apu” and “apv” be required.  Furthermore, as Brian Campbell pointed out, PartyAInfo is optional for Ephemeral-Static mode in RFC 2631, so “apu” should be optional as well.

“epk” is already required for key agreement.

Can you therefore agree to resolve this issue as “wontfix”?

                                                                Thanks,

                                                                -- Mike

-----Original Message-----
From: jose issue tracker [mailto:[email-masked]]
Sent: Sunday, August 11, 2013 3:55 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [jose] #54: epk/apu/apv need to be REQUIRED

#54: epk/apu/apv need to be REQUIRED

The Concat specification requires these fields to be non-empty.  So they  should also be required to be present here.

--

-------------------------+----------------------------------------------

-------------------------+---

Reporter:  [email-masked]<mailto:[email-masked]>   |      Owner:  draft-ietf-jose-json-web-

     Type:  defect       |  [email-masked]<mailto:[email-masked]>

Priority:  major        |     Status:  new

Component:  json-web-    |  Milestone:

  algorithms             |    Version:

Severity:  -            |   Keywords:

-------------------------+----------------------------------------------

-------------------------+---

Ticket URL: <http://trac.tools.ietf.org/wg/jose/trac/ticket/54>

jose <http://tools.ietf.org/jose/>

---

From: Richard Barnes <[email-masked]>
Date: Mon, 9 Sep 2013 13:16:01 -0400

On Thu, Sep 5, 2013 at 9:46 PM, Mike Jones <[email-masked]>wrote:

>  Hi Richard,****
>
> ** **
>
> The text that you proposed for #55, in which “apv” is not used,
> contradicts the request that “apu” and “apv” be required.  Furthermore, as
> Brian Campbell pointed out, PartyAInfo is optional for Ephemeral-Static
> mode in RFC 2631, so “apu” should be optional as well.****
>
> ** **
>
> “epk” is already required for key agreement.****
>
> ** **
>

Yes.

Thanks,
--Richard

> ****
> ** **
>                                                                 Thanks,***
> *
>                                                                 -- Mike***
> *
> ** **
> ** **
> #54: epk/apu/apv need to be REQUIRED****
>
> ** **
>
> The Concat specification requires these fields to be non-empty.  So they
> should also be required to be present here.****
>
> ** **
>
> -- ****
>
> -------------------------+----------------------------------------------**
> **
>
> -------------------------+---****
>
> Reporter:  [email-masked]   |      Owner:  draft-ietf-jose-json-web-****
>
>      Type:  defect       |  [email-masked]****
>
> Priority:  major        |     Status:  new****
>
> Component:  json-web-    |  Milestone:****
>
>   algorithms             |    Version:****
>
> Severity:  -            |   Keywords:****
>
> -------------------------+----------------------------------------------**
> **
>
> -------------------------+---****
>
> ** **
>
> Ticket URL: <http://trac.tools.ietf.org/wg/jose/trac/ticket/54>****
>
> jose <http://tools.ietf.org/jose/>****
>
> ** **
>
> ** **
>