Subject: [jose] Issue #76 - x5t

From: "Jim Schaad" <[email-masked]>
Date: Sun, 29 Sep 2013 20:59:20 -0700

Mike,

This is the suggested text modification that I have for dealing with bullet
B in for this issue.

OLD

The key in the certificate MUST match the bare public key represented by the
other members of the JWK.

NEW

If other members in the JWK representing portions of the certificate are
present, they MUST be consistent with the same fields in the certificate.
Additional details can be found in <xref target="x5c"/>.

Jim

---

From: Mike Jones <[email-masked]>
Date: Mon, 30 Sep 2013 07:32:09 +0000

The working group was clear in Denver that the normal JWK bare key elements MUST be present in the JWK and that the x5* fields are supplemental information that must align with their content.

Therefore, can you reword your suggested sentence below to remove the "if" clause and instead talk about the consistency between those fields that must be present?

                                                            Thanks,
                                                            -- Mike

From: Jim Schaad [mailto:[email-masked]]
Sent: Sunday, September 29, 2013 8:59 PM
To: Mike Jones
Cc: [email-masked]
Subject: Issue #76 - x5t

Mike,

This is the suggested text modification that I have for dealing with bullet B in for this issue.

OLD
The key in the certificate MUST match the bare public key represented by the other members of the JWK.

NEW
If other members in the JWK representing portions of the certificate are present, they MUST be consistent with the same fields in the certificate.  Additional details can be found in <xref target="x5c"/>.

Jim