Subject: [jose] draft-ietf-jose-json-web-key-14: Multiple keys - confusing

From: Anders Rundgren <[email-masked]>
Date: Thu, 19 Sep 2013 18:16:26 +0200

extract from draft-ietf-jose-json-web-key-14:

   The following is a non-normative example of a JWK with a RSA signing
   key represented both as a bare public key and as an X.509 certificate
   using the "x5c" parameter:

     {"kty":"RSA",
      "use":"sig",
      "kid":"1b94c",
      "n":"vrjOfz9CcjBPD5eunqsIo1vQ",
      "e":"AQAB",
      "x5c":
       ["MIIDQjCCAiqgAwIBAgIvACWpkA6SdS4xSvdXK3IVfOWA=="]
     }

How are applications supposed to deal with this?  Non-normatively I suppose :-)

What's the rationale for this if I may ask?

Anders

---

From: Brian Campbell <[email-masked]>
Date: Thu, 19 Sep 2013 10:24:10 -0600

The rationale is (hopefully) explained in
http://www.ietf.org/proceedings/86/slides/slides-86-jose-3 and
http://tools.ietf.org/html/draft-miller-jose-pkix-key-01

That was a proposal for a new key type that could hold a certificate. It
ended up getting folded into the main JWK doc as the x5c parameter.

On Thu, Sep 19, 2013 at 10:16 AM, Anders Rundgren <
[email-masked]> wrote:

> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>