Subject: [jose] Issue #85 - bullet B

From: "Jim Schaad" <[email-masked]>
Date: Thu, 12 Sep 2013 14:12:29 -0700

Matt,

Mike says that you requested that this column be added to the registry
table.   What is the purpose behind adding this to the table?  

I am not sure that I see the justification for having the column and am
looking for one.

Jim

---

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Thu, 12 Sep 2013 22:04:27 +0000

> I am not sure that I see the justification for having the column and am

I feel there is significant value with indicating the sensitivity as explicitly and concisely as possible, regardless of whether "private" and "public" parameters are further segregated into their own logical containers.  I have grave concern for the less-informed individual -- coming to some addendum to JOSE (or the core specifications themselves) after the much more experienced authors, editors, and reviewers have all passed over the lack of explicit text because some parameter is obviously sensitive (or not) -- unintentionally compromising their application by exposing something that actually was sensitive.

A specific column seems to me to be the best way to ensure at least consideration when defining new things for the registry.

- m&m

Matt Miller < [email-masked] >
Cisco Systems, Inc.

PS: The full thread where this is discussed starts with < http://www.ietf.org/mail-archive/web/jose/current/msg01864.html >.