Subject: [jose] JOSE -16 drafts addressing 45 editorial and minor issues

From: Mike Jones <[email-masked]>
Date: Sun, 15 Sep 2013 21:57:25 +0000

JSON Object Signing and Encryption (JOSE) -16 drafts have been published that address 45 editorial and minor issues.  See the Document History sections for lists of the specific issues addressed.  Thanks to Jim Schaad for again meeting with me in person to go over proposed text changes in my working drafts before these specifications were published.

One breaking change was made:  When doing ECDH-ES key agreement, the AlgorithmID value used in the KDF computation now has a length prefix.  So for instance, the representation of the "enc" value "A128GCM" is now prefixed by the number 7, represented as a 32-bit big-endian value, when used as the AlgorithmID value.  (Such prefixes were already in place for the other variable-length KDF parameters.)

The drafts are available at:

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-signature-16

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-encryption-16

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-key-16

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-16

HTML formatted versions are also available at:

*        http://self-issued.info/docs/draft-ietf-jose-json-web-signature-16.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-encryption-16.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-key-16.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-algorithms-16.html

                                                            -- Mike

---

From: Brian Campbell <[email-masked]>
Date: Mon, 16 Sep 2013 09:13:41 -0600

Looks like the very last part of the example in JWA Appendix D* got
overlooked in this change. It still has the base64url encoded
representation of the derived key as usEpwFIC_qrmBExntFwxMA but I believe
it should be VqqN6vgjbSBcIijNcacQGg

*
http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-16#appendix-D

On Sun, Sep 15, 2013 at 3:57 PM, Mike Jones <[email-masked]>wrote:

>  ** **
>
> One breaking change was made:  When doing ECDH-ES key agreement, the
> AlgorithmID value used in the KDF computation now has a length prefix.  So
> for instance, the representation of the “enc” value “A128GCM” is now
> prefixed by the number 7, represented as a 32-bit big-endian value, when
> used as the AlgorithmID value.  (Such prefixes were already in place for
> the other variable-length KDF parameters.)****
>

---

From: Mike Jones <[email-masked]>
Date: Mon, 16 Sep 2013 17:18:13 +0000

Thanks for your diligence, Brian.  I've fixed this in my working draft.

                                                            -- Mike

From: Brian Campbell [mailto:[email-masked]]
Sent: Monday, September 16, 2013 8:14 AM
To: Mike Jones
Cc: [email-masked]
Subject: Re: [jose] JOSE -16 drafts addressing 45 editorial and minor issues

Looks like the very last part of the example in JWA Appendix D* got overlooked in this change. It still has the base64url encoded representation of the derived key as usEpwFIC_qrmBExntFwxMA but I believe it should be VqqN6vgjbSBcIijNcacQGg

* http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-16#appendix-D

On Sun, Sep 15, 2013 at 3:57 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote: