Subject: Re: [jose] #50: "cty" (content type) should hold a media type

From: "jose issue tracker" <[email-masked]>
Date: Fri, 13 Sep 2013 18:12:03 -0000

#50: "cty" (content type) should hold a media type

Comment (by [email-masked]):

 Originally "typ" and "cty" values were in their own IANA type space that
 was independent of MIME types.  Quite some time ago (I believe based on
 comments from Jim), the working group decided to add a field in the types
 registry allowing the correspondence between the short-by-design JOSE type
 names and MIME types to be registered.  At the time, we also decided to
 allow the use of MIME types in those fields, which is fine in cases where
 compactness isn't a goal.

 However, for many cases, compactness is a goal, and the current solution
 is designed with that in mind, and is already working fine.  I don't see a
 compelling reason to change it at this point.  It's already used, for
 instance, in Section 6 of JWK, for indicating that a JWK or JWK Set are
 the encrypted content.  It's used by JWT for saying that a JWT is the
 encrypted content.  Etc.

 To address your concerns about the "MAY be used" language, I propose that
 "MAY be used" be changed to "is used".  You're right that the "OPTIONAL"
 phrase already covers the "MAY" intent.

 To address your concerns about MIME types being case insensitive, I
 propose that we add this text after saying that MIME types values may be
 used: "When MIME Media Types values are used, it is RECOMMENDED that they
 use the exact character case used in the registry, since this field is
 case sensitive, whereas MIME values are case insensitive."

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-jose-json-web-
  [email-masked]    |  [email-masked]
     Type:  defect       |      Status:  new
 Priority:  major        |   Milestone:
Component:  json-web-    |     Version:
  signature              |  Resolution:
 Severity:  -            |
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/jose/trac/ticket/50#comment:1>
jose <http://tools.ietf.org/jose/>

---

From: <[email-masked]>
Date: Mon, 16 Sep 2013 22:41:52 +0200

+1 for keeping the compact form for cty

I would even stay with case sensivity for mime-types because in (all?) other cases in JOSE we are comparing octets as-is to avoid complexity.
[Canonicalization is evil]

-axel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of jose issue tracker
Sent: Friday, September 13, 2013 8:12 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [jose] #50: "cty" (content type) should hold a media type

 Originally "typ" and "cty" values were in their own IANA type space that  was independent of MIME types.  Quite some time ago (I believe based on  comments from Jim), the working group decided to add a field in the types  registry allowing the correspondence between the short-by-design JOSE type  names and MIME types to be registered.  At the time, we also decided to  allow the use of MIME types in those fields, which is fine in cases where  compactness isn't a goal.

 However, for many cases, compactness is a goal, and the current solution  is designed with that in mind, and is already working fine.  I don't see a  compelling reason to change it at this point.  It's already used, for  instance, in Section 6 of JWK, for indicating that a JWK or JWK Set are  the encrypted content.  It's used by JWT for saying that a JWT is the  encrypted content.  Etc.

 To address your concerns about the "MAY be used" language, I propose that  "MAY be used" be changed to "is used".  You're right that the "OPTIONAL"
 phrase already covers the "MAY" intent.

 To address your concerns about MIME types being case insensitive, I  propose that we add this text after saying that MIME types values may be
 used: "When MIME Media Types values are used, it is RECOMMENDED that they  use the exact character case used in the registry, since this field is  case sensitive, whereas MIME values are case insensitive."

-- 
-------------------------+----------------------------------------------
-------------------------+---
 Reporter:               |       Owner:  draft-ietf-jose-json-web-
  [email-masked]    |  [email-masked]
     Type:  defect       |      Status:  new
 Priority:  major        |   Milestone:
Component:  json-web-    |     Version:
  signature              |  Resolution:
 Severity:  -            |
 Keywords:               |
-------------------------+----------------------------------------------
-------------------------+---

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose

---

From: John Bradley <[email-masked]>
Date: Mon, 16 Sep 2013 13:51:09 -0700

I think mime types should be compared as octets rater than introduce folding rules.  So it would be good to say that when they are used they MUST be lowercase as is the convention.

I think keeping the current short names is fine, and not likely to cause confusion.

John B.

---

From: Edmund Jay <[email-masked]>
Date: Mon, 16 Sep 2013 14:12:38 -0700 (PDT)

+ 1 for keeping the compact form since it gives a choice where compactness is needed and does not preclude using media types.

________________________________
 From: John Bradley <[email-masked]>
To: [email-masked] 
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked] 
Sent: Monday, September 16, 2013 1:51 PM
Subject: Re: [jose] #50: "cty" (content type) should hold a media type

John B.

---

From: Mike Jones <[email-masked]>
Date: Mon, 16 Sep 2013 21:32:50 +0000

FYI, I did add the following text on case sensitivity and the use of MIME types in -16:

When MIME Media Type values are used, it is RECOMMENDED that they be spelled using the exact character case used in the MIME Media Types registry [IANA.MediaTypes]<http://self-issued.info/docs/draft-ietf-jose-json-web-signature-16.html#IANA.MediaTypes>, since this field is case sensitive, whereas MIME Media Type values are case insensitive.

This is close to John's recommendation that we use lowercase media type names, since most registrations at http://www.iana.org/assignments/media-types use exclusively lowercase.  At least the spelling in the registry is well defined and authoritative.

                                                            -- Mike

From: Edmund Jay [mailto:[email-masked]]
Sent: Monday, September 16, 2013 2:13 PM
To: John Bradley; [email-masked]
Cc: Mike Jones; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [jose] #50: "cty" (content type) should hold a media type

________________________________
From: John Bradley <[email-masked]<mailto:[email-masked]>>
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Sent: Monday, September 16, 2013 1:51 PM
Subject: Re: [jose] #50: "cty" (content type) should hold a media type

John B.
On 2013-09-16, at 1:41 PM, <[email-masked]<mailto:[email-masked]>> wrote:

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of jose issue tracker
> To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
> Comment (by [email-masked]<mailto:[email-masked]>):
>
>  [email-masked]<mailto:[email-masked]>    |  [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose