Subject: Re: [jose] #119: Section 7. Serializations

From: Mike Jones <[email-masked]>
Date: Mon, 4 Nov 2013 18:53:09 +0000

I propose the following text to resolve issue #119 and the corresponding JWE text to resolve issue #176:

7.  Serializations

JWS objects use one of two serializations, the JWS Compact Serialization or the JWS JSON Serialization. Applications using this specification need to specify what serialization and serialization features are used for that application.  For instance, applications might specify that only the JWS JSON Serialization is used, that only JWS JSON Serialization support for a single signature or MAC value is used, or that support for multiple signatures and/or MAC values is used.  JWS implementations only need to implement the features needed for the applications they are designed to support.

				-- Mike

-----Original Message-----
From: jose issue tracker [mailto:[email-masked]] 
Sent: Monday, October 28, 2013 7:28 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [jose] #119: Section 7. Serializations

#119: Section 7. Serializations

Comment (by [email-masked]):

 Per last conference call - MTIs are to be removed.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |       Owner:  draft-ietf-jose-json-web-
  [email-masked] |  [email-masked]
     Type:  defect       |      Status:  new
 Priority:  blocker      |   Milestone:
Component:  json-web-    |     Version:
  signature              |  Resolution:
 Severity:  -            |
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/jose/trac/ticket/119#comment:1>
jose <http://tools.ietf.org/jose/>

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 4 Nov 2013 11:05:50 -0800

WFM

> From: Mike Jones [mailto:[email-masked]]
> Sent: Monday, November 04, 2013 10:53 AM
> To: jose issue tracker; [email-masked];
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [jose] #119: Section 7. Serializations
> 
> JWS objects use one of two serializations, the JWS Compact Serialization or
> the JWS JSON Serialization. Applications using this specification need to
> specify what serialization and serialization features are used for that
> application.  For instance, applications might specify that only the JWS JSON
> Serialization is used, that only JWS JSON Serialization support for a single
> signature or MAC value is used, or that support for multiple signatures
> and/or MAC values is used.  JWS implementations only need to implement
> the features needed for the applications they are designed to support.
> 
> 				-- Mike
>

---

From: Richard Barnes <[email-masked]>
Date: Mon, 4 Nov 2013 16:00:16 -0800

+1

On Mon, Nov 4, 2013 at 11:05 AM, Jim Schaad <[email-masked]> wrote:

> > To: jose issue tracker;
> [email-masked];
> > [email-masked]
> > Cc: [email-masked]
> > I propose the following text to resolve issue #119 and the corresponding
> JWE
> > text to resolve issue #176:
> >
> > 7.  Serializations
> >
> > Ticket URL: <
> http://trac.tools.ietf.org/wg/jose/trac/ticket/119#comment:1>
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>