Subject: [jose] Review of JWE draft

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 1 Jul 2014 09:10:21 -0400

Hello,

I reviewed the JWE draft and have some comments below.  The draft looks
good overall and my comments are mostly grammar related.

Section 3, It seems like it would be helpful to have the definitions for
the two defined serializations for JWE objects broken out into subsections
or at least distinguished in some way (bullets, etc).

Section 3.1, references may be helpful for included for algorithms:
RSAES OAEP [] for key encryption
AES GCM [] for content encryption

Section 5.2, for bullet number 1, Could you break the first sentence into
two and structure the second of those two sentences in a manner similar to
the current sentence 2?

Section 5.2, bullet #4, please break into two sentences

Section 11, Not sure on this, but would the use of the word 'faced' be
difficult for non-native English speakers to understand?  May use 'that
apply to' or something similar?

Section 11, In the last sentence of the first paragraph, it sounds as if no
additional considerations will be included, but there are subsections that
follow.  Could you mention that the following subsection include some
important considerations, however…

I think that will help the section flow better.

-- 

Best regards,
Kathleen

---

From: Mike Jones <[email-masked]>
Date: Wed, 2 Jul 2014 01:17:34 +0000

The -30 drafts incorporate all of these suggested changes.

                                                                Thanks again,
                                                                -- Mike

P.S.  I just checked and for some reason the production of the versions at http://tools.ietf.org/html/ seems to be delayed.  If the draft name you see doesn’t end in -30, try the plain text versions such as http://www.ietf.org/id/draft-ietf-jose-json-web-signature-30.txt or the diffs such as http://www.ietf.org/rfcdiff?url2=draft-ietf-jose-json-web-signature-30 for now (which do exist).

From: jose [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Tuesday, July 01, 2014 6:10 AM
To: [email-masked]
Subject: [jose] Review of JWE draft

Hello,

I reviewed the JWE draft and have some comments below.  The draft looks good overall and my comments are mostly grammar related.

Section 3, It seems like it would be helpful to have the definitions for the two defined serializations for JWE objects broken out into subsections or at least distinguished in some way (bullets, etc).

Section 5.2, for bullet number 1, Could you break the first sentence into two and structure the second of those two sentences in a manner similar to the current sentence 2?

Section 11, Not sure on this, but would the use of the word 'faced' be difficult for non-native English speakers to understand?  May use 'that apply to' or something similar?

Section 11, In the last sentence of the first paragraph, it sounds as if no additional considerations will be included, but there are subsections that follow.  Could you mention that the following subsection include some important considerations, however…

--

Best regards,
Kathleen