Subject: [jose] Other EC Algorithms

From: Anders Rundgren <[email-masked]>
Date: Fri, 19 Dec 2014 07:42:00 +0100

Somewhat related to my "WebCrypto/JOSE Algorithm IDs = Mess" posting
I wonder how you are supposed to for example deal with "brainpool" algorithms
which are more or less an EU standard?

The bitcoin folks apparently use yet another EC algorithm ("secp256k1" in JCE).

Anders

---

From: Michael Scott <[email-masked]>
Date: Fri, 19 Dec 2014 09:59:31 +0000

These are curves not algorithms. I wouldn't recommend secp256k1 - its
patented, see

http://www.freepatentsonline.com/7110538.html
http://www.freepatentsonline.com/7995752.html

This curve supports an endomorphism, which means it can be computed on
somewhat faster, although its cryptographic strength suffers a little as
well.

There is little to recommend the brainpool curves - they are based on the
superstition that random primes are better. If you want new improved curves
look at more recent literature, for example

http://safecurves.cr.yp.to/

or

http://eprint.iacr.org/2014/130

Mike

On Fri, Dec 19, 2014 at 6:42 AM, Anders Rundgren <
[email-masked]> wrote:
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 19 Dec 2014 11:20:16 +0100

On 2014-12-19 10:59, Michael Scott wrote:
> These are curves not algorithms.

My bad.

Anyway, my question was really only about how to deal with these
(already deployed) curves using JOSE.

Anders

> I wouldn't recommend secp256k1 - its patented, see
>
> This curve supports an endomorphism, which means it can be computed on somewhat faster, although its cryptographic strength suffers a little as well.
>
> There is little to recommend the brainpool curves - they are based on the superstition that random primes are better. If you want new improved curves look at more recent literature, for example
>
> On Fri, Dec 19, 2014 at 6:42 AM, Anders Rundgren <[email-masked] <mailto:[email-masked]>> wrote:
>
>     _________________________________________________
>     jose mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/jose <https://www.ietf.org/mailman/listinfo/jose>
>
>
>
>
>
>