Subject: [jose] Barry Leiba's No Objection on draft-ietf-jose-jwk-thumbprint-07: (with COMMENT)

From: "Barry Leiba" <[email-masked]>
Date: Tue, 07 Jul 2015 11:32:44 -0700

Barry Leiba has entered the following ballot position for
draft-ietf-jose-jwk-thumbprint-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-jose-jwk-thumbprint/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

-- Section 6 --

   This specification adds to the instructions to the Designated Experts
   for the following IANA registries, all of which are in the JSON
   Object Signing and Encryption (JOSE) protocol category [IANA.JOSE]:
   o  JSON Web Key Types
   o  JSON Web Key Elliptic Curve
   o  JSON Web Key Parameters

Because you're changing the DE instructions, either this document needs
to "update" 7517 and 7518 (where those registries are defined), or it
needs to update the registries to add itself to the reference field
("[RFC7518][RFCxxxx]").  And in either case, it needs to make it clear in
the introduction that Section 6 provides additional instructions to the
designated experts for those three registries.  Otherwise, it's too easy
for DEs for those registries not to notice this update.  [I know the
current DEs are well aware of it.  But that's not the point.]

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 7 Jul 2015 15:16:25 -0400

Hi Barry,

> https://datatracker.ietf.org/doc/draft-ietf-jose-jwk-thumbprint/
Thanks.  I asked this same question on Friday to IANA to see which of those
options was their preference.  I have not heard back yet.  The editors and
chairs were thinking another reference would be added to the reference
field of the registry.  I'm fine with whichever option works best.

-- 

Best regards,
Kathleen

---

From: Mike Jones <[email-masked]>
Date: Thu, 9 Jul 2015 14:11:06 +0000

Barry, we can augment the IANA Considerations section to say that the additional instructions are being added to the registry.  I’ll work on precise language with you and Kathleen.

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Tuesday, July 07, 2015 12:16 PM
To: Barry Leiba
Cc: Karen O'Donoghue; The IESG; [email-masked]
Subject: Re: [jose] Barry Leiba's No Objection on draft-ietf-jose-jwk-thumbprint-07: (with COMMENT)

Hi Barry,

On Tue, Jul 7, 2015 at 2:32 PM, Barry Leiba <[email-masked]<mailto:[email-masked]>> wrote:
Barry Leiba has entered the following ballot position for
draft-ietf-jose-jwk-thumbprint-07: No Objection

-- Section 6 --

Thanks.  I asked this same question on Friday to IANA to see which of those options was their preference.  I have not heard back yet.  The editors and chairs were thinking another reference would be added to the reference field of the registry.  I'm fine with whichever option works best.

--

Best regards,
Kathleen

---

From: Mike Jones <[email-masked]>
Date: Thu, 9 Jul 2015 14:37:54 +0000

My proposed change is to add this sentence after the bulleted list of specifications whose instructions are being updated at http://tools.ietf.org/html/draft-ietf-jose-jwk-thumbprint-06#section-6:

“IANA, please add a link to this specification in the Reference sections of these registries after the existing links to RFC 7518 for the first two and the link to RFC 7517 for the last.”

Would that work for you, Barry and Kathleen?

                                                            -- Mike

From: Mike Jones
Sent: Thursday, July 09, 2015 7:11 AM
To: 'Kathleen Moriarty'; Barry Leiba
Cc: Karen O'Donoghue; The IESG; [email-masked]
Subject: RE: [jose] Barry Leiba's No Objection on draft-ietf-jose-jwk-thumbprint-07: (with COMMENT)

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Tuesday, July 07, 2015 12:16 PM
To: Barry Leiba
Cc: Karen O'Donoghue; The IESG; [email-masked]<mailto:[email-masked]>
Subject: Re: [jose] Barry Leiba's No Objection on draft-ietf-jose-jwk-thumbprint-07: (with COMMENT)

Hi Barry,

-- Section 6 --

--

Best regards,
Kathleen

---

From: Barry Leiba <[email-masked]>
Date: Thu, 9 Jul 2015 10:43:30 -0400

> “IANA, please add a link to this specification in the Reference sections of
> these registries after the existing links to RFC 7518 for the first two and
> the link to RFC 7517 for the last.”

That'd be perfectly fine by me.

b